Unable to update to WD Smartware Pro 2.4.14

I bought and installed MY Cloud on May 4, 2014.when I was running Windows 8.1. I am now running Windows 10.

I am currently running WD Smartware Pro Version 2.4.12. When I check my “Software Updates” > “Check Now” box the message appears “WD Smartware Pro 2.4.14 is available for update”. When I click on “Update Software” a window opens reading “WD Software Download” with a horizontal bar to show the update progress. Only problem is there is no evidence that the download is progressing, even when I wait for 15 minutes. I have tried and failed 4 times to install the software update.

I have installed WD Smartware Installer.exe.

My Cloud is connected to a ZyXEL VSG1432-B101 Series 802.11n Wireless 4-port Gateway. I have 2 desktops and 2 laptops connected to the ZyXEL. All PCs are running Windows 10 and all have access to MY Cloud.

Other than this software update problem, the device is functioning as it should.

I am currently experiencing the same problem

I have also the same problem Update doesnt give me the opportunity to download or install

I am also experiencing the same. I tried altering the startup settings on Trend Micro Maximum Security and still could not solve the problem.

You may want to look at this prior forum post.


Quick and easy fix. It worked for me.
Visit a product page HERE and download it from there.

Link to the download: >>> http://download.wdc.com/smartware/WD_SmartWareInstaller_2.4.14.13.zip

Thanks Michael – Success! Downloaded and installed the software from the link you provided and it appears the upgrade was installed – although when I look at the version # in Settings it only shows 2.4.14 and not the final .13.

There was a little hiccup in the installation: At the very end when alerted that a Restart is necessary, I clicked Finish expecting the Restart to begin automatically. When it didn’t I ran the Restart myself and the system rebooted after a short delay and I was able to login no problem. Smartware appears to be running normally.

Bottom line – Looks like the update was installed and I’m happy.