SD cards & USB pendrives doesn't work AT ALL!


#1

I just bought my My Passport Wireless PRO. As USB Disk (even wireless) it works fine but as a CARD READER is terrific. WD MyPassport doesn’t work AT ALL.

It doesn’t see ANY SD Card and also doesn’t see any Pendrive.
I tried more then 10 different SD cards and pendrives and still nothing.

What happened? Am I doint something wrong? How to import SD cards?
I checked all options of automatic import and still nothing.

I have WD MyPassport Wireless Pro 3TB

I even have excatly USB disk from a official supported list and still doesn’t work:


SD IMPORTS doesn't work if we are not connected to PC via WiFi
#2

I can’t help too much since I personally haven’t had any issues, even with storage that’s not listed on the supported list. I do not use the auto import features, I actually click the sd/battery button to initiate the copy. I recommend connecting to the device and making sure you’re on the latest firmware.I would also recommend checking if the webui (http://192.168.60.1 when connected to the MPWP’s WiFi) to see if it detects the device under the USB icon.

Hopefully someone else more knowledgeable or has experienced the same issue can chime in.

P.S. Also, connecting a mobile device to the MPWP’s WiFi and using the WD app should list the drives. I don’t have too much experience using the mobile app since inserting the drive and clicking the button has worked for me with one caveat of large video files on my 360 camera using the USB cable.


#3

What’s WRONG with support of WD? How long I still should wating to any ANSWER?!
It’s a 4 MONTHS of my 1st post with desribing an issue.

WD MyPassport is a completely Junk like the other users said.


#4

This article helped me a lot:

There are obviously troubles with some smartphone brands. Click the URL above and check the reply posted by EmanueleP90 (Aug 21). I followed these instructions and everything works nicely and well. I had since days discussions with WD support, they are not aware of this issue at all. Today I found this article …


#5

Yes, you had right. But what about repair that issue by WD support?


#6

It is apparent some Android phones have issues. Reason being there is not a SOLID standard. On the other hand, there is only ONE iPhone maker and mine’works perfectly. When it comes to cell phones, you get what you pay for!


#7

Talked to WD support, there is no date for a fix. They didn’t even say whether this issue will be addressed at all.


#9

Has anyone tried connecting the My Passport Wireless Pro so the hotspot on their mobile phone?


#10

This post was flagged by the community and is temporarily hidden.