WD Wireless card reader not working, etc

#1

hi,
i have a WD My Passport Wireless 2TB. a few years old but has always worked great. terrific for traveling when i don’t want to lug my laptop but want to backup photos from an SD card. but in the past few days it’s no longer reading the card. and when i plug in to the laptop via USB, my computer (windows 10) says it needs to be scanned. did it, then tried to see if it’d read the card again, plugged it back into the laptop and it suggested scanning again. and the SD card hadn’t read either. also it doesn’t seem to want to charge up via the included charger. sat for hours. eventually plugged it directly into a USB port and that seems to be working better. fyi, i rarely use the wifi and it’s not password protected. able to transfer files when connected via USB to computer. do i just need to do some kind of factory reset or might there be a hardware issue?
thanx,
george

#2

Hi GMjr,

We have sent you a message. Please check your Community Message Inbox.

#3

Thanks for getting in touch. Sorry I couldn’t respond sooner but had to leave town urgently. Will be back home in a few days and will be able to follow up. Really appreciate it.

g