My Passport Wireless Pro won't import from any physical media

So, got my My Passport Wireless Pro home, configured and ready for my upcoming trip to Japan, only to discover that it won’t import from any physical media at all: no SD card, no SD card reader, no USB stick - nothing.

Only error message I get is that I should “check that your USB drive/SD card is inserted correctly” - that’s it.

I’ve tried several different USB cards, formatted both on my Sony camera and on my PC - makes no difference.

Hugely underwhelmed, to say the least.

Any ideas what might be wrong? Seems extremely strange that both the USB and SD card readers should both fail. Is there some obscure setting I’ve missed?

The Wireless Pro firmware is fully up to date.

EDIT: Forgot to say that wireless import works just fine.

Have you “overlooked” reading about the SD card reader in the complete user manual found on the MPW or as a download from WD Support? Also check that your SD card is a compatible model according to WD.
Do not use an external card reader, plug SD card directly into MPW.

I have two of these devices and both import from SD cards. It can be a bit tricky and I often need to revert to the manual.

Just don’t tamper with MPW and do something foolish like reformat the MPW! Call WD Support and get the support you have paid for!

Right - have now managed to get MPW to recognise a card three times, while messing about with the wireless connection to my PC and Android phone. There seems to be a correlation with whether I’m on the 2.4ghz or 5.0 ghz network though I can’t figure out what it is.

Strange - and very, very annoying. All the reviews I’ve read about MPW’s ability to back up SD cards in the field never mentioned it being this much of a PITA.

Good, some progress. Is the MPW wireless signal also connected to your router as per the setup instructions? If it is, you need to connect your phone, PC etc to home wifi and NOT the MPW signal. Only use MPW wifi away from home now, Also MPW should be near router and not you and devices. Best connection of MPW and router is assured when they are close together. 5G has less range than 2,4G but is faster if signal is strong.

Right - took me a few hours, but finally figured it out: the MPW loses the ability to recognize any sort of SD card or USB stick, the second I access the drive with the MyCloud app on my OnePlus 6 Android phone.

After that, only a factory reset will bring back the ability to recognize physical media. I’ve even tried the MyCloud app from a Samsung Phone - does the exact same thing.

Looks like I’m not alone in experiencing the bug, either: My Passport Wireless Pro won’t recognize SD/USB anymore after using MyCloud app

The inability to use MPW with my mobile phone is a major, major inconvenience, but as I haven’t got time to find a suitable replacement before I leave for four weeks in Japan, it looks like I’m stuck having to find public PC’s to access the drive from.

Pretty serious bug, though.

Tip: you can access the mpw through your phone by enabling ftp access. You have to connect directly to the mpw wifi network and access to ftp://192.168.60.1/

Yeah - just read that thread all the way down. Great that there is a workaround, but still be nice if it just… worked.

there’s a fix here if you know how to open a ssh shell:

Andy, There is no reason you need to use any suggested hacks for a new unit you have just set up that is not working well. As I mentioned, work with WD on this.

Already did - spent half an hour on WD customer support yesterday. All she could tell me was to do a factory reset (which, in a way, “solved” the issue, as that made me aware that the mobile app was the root of the problem).

If you need to contact WD again, ask to be transferred to the next level of support (Level 2).

Any news about this?
I have the exact same problem:
As soon as I pair the My Passport with the My Cloud Android App, the device completely stop recognizing any SD card.
If I factory reset and configure the device through the web interface, it goes back to working.
But as soon as I pair it with the app to look at my files, it stops backing up again and there is no other way to make it work than factory resetting again.

Semenne: If you access the drive via your BROWSER on your phone (I use Chrome) it goes back to detecting your SD cards. Just enter the IP address of your drive (198.XXX.XXX) in Chrome and you’re good to go again. Super weird workaround, but it does work.

Yeah, as I said… That’s exactly how I’m making it work, but I paid for a working device, and I don’t have a working device…