My Passport Wireless Pro not compatible with microSD


#1

Hello,

I think it is a known issue since I saw it on another post and it was the same problem. My Passport Wireless Pro cannot recognise microSD use with microSD to SD adapters…

The guy from the other post ended up using a card reader on USB port and it is the same for me… But first, my microSDs with SD adapter work perfectly in any devices with SD port (phone, computer, camera, etc.), how come My Passport cannot? And second, USB port is USB2 so the transfer is really slow… I use daily up to 256Go so I need fast transfers and to keep battery at much as possible since I go to places with no electricity…

Do we have a chance in a future firmware update that this problem can be solved?

Thanks


#2

Hello,

Public Beta is still available


#3

Thanks for the quick reply.

There is no mention about microSD to SD adapters or microSD… And I am wary about beta firmwares since I still have to use My Passport for work… Is there any way to go back to previous firmware if i install it?

Thanks


#4

Here’s what fixed in the most recent beta release

Here’s how to revert back to the old 1.01.11 firmware which is also included in the beta release download page.


#5

@pierreyj

Please check out the 1.02.xx Beta FW, there are many updated and Fixes concerning SD, MicroSD, and CFast Cards.

As @SBrown points out, we have ensured that you can always go back to 1.01.11 with no data loss.

@jrichard


#6

Ok thanks,

I will check this out asap.


#7

The new firmware solved my problem! But… I got very strange results though so I decided to run a complete test as below :

I have 3 microSD to Sd adapters : 2 Sandisk, 1 Sony. All work fine with computer, camera, etc.
I will name them as :
A1 : Sandisk
A2 : Sony
A3 : Sandisk

4 microSD cards : 2 Sandisk Extreme mSDXC u3 64GB (for the test sake 1 is formatted in exfat and 1 in fat32), 1 Sony mSDHC u3 32GB in fat32 and 1 Lexar mSDHC u1 16GB in fat32.
I will name them as :
C1 : Sandisk exfat
C2 : Sandisk fat32
C3 : Sony
C4 : Lexar

Tests results :
A1 + C1 : NO (not recognized)
A2 + C1 : NO
A3 + C1 : OK

A1 + C2 : NO
A2 + C2 : NO
A3 + C2 : OK

A1 + C3 : NO
A2 + C3 : OK
A3 + C3 : OK

A1 + C3 in exfat : NO
A2 + C3 in exfat : OK
A3 + C3 in exfat : OK

A1 + C4 : NO
A2 + C4 : OK
A3 + C4 : OK

So… first I didn’t know that mSDtoSD were differents from each other and I actually use A1 all the time on my computer, camera, etc and as you can see it totally doesn’t work with My Passport…
The Sony one works but not my 64GB cards… And finally my other Sandisk adapter works all the time…

Is there any logic here? Except that somehow I got the right adapter to work with My Passport but I cannot recommend it to someone else since my other Sandisk one totally doesn’t work…

Anyways, thanks for your help.


#8

@pierreyj

Thank you for your detailed testing and reporting. I asked our QA Group at Sandisk to run the same test with the MicroSD cards and SD Adapters they have, with the same FW version. As you can see by the results below, all the tests are passing. There are many times when a delay was observed (up to 21 Sec in one case) so that may be what you are seeing?

After inserting the card, did you manually refresh either the Web Dashboard or Mobile App to verify the card was mounted?

It is also strongly suggested to only use the same SD Card that came with the MicroSD card, as some incompatibilities may occur when mixing manufactures devices. Please see the below details, if you still have questions feel free to ask them in this thread, or, you can contact WD Support directly.


Following are the details of our verification:

  • MicroSD to SD Adapter (Table : “Details of Experiment done by SanDisk QA team”)
    ** Tested with firmware 1.02.24
  • User has reported that cards are not detected in KORRA but works fine with PC / camera (Table : “User reported Information”). Did the user refresh the WebUI when the card was not detected ?
  • As per experiment it is observed that WebUI takes few seconds (5s – 30s) to reflect in WebUI and any operation before that would result in non-detection.
  • It is always recommended to use bundled MicroSD to SD adapter for optimum performance, any other configuration would result in unknown behavior.
    *** SanDisk cards with suggested adapter takes ~9sec to detect the card, when with used other adapters it takes either more or less time.


Thank you again
@jrichard


#9

I checked using both WebUI and Mobile App. I refreshed multiple times and waited for up to few minutes while trying to force manually SD card import via the Mobile App with “Check that your SD card is inserted in My Passport device correctly and try again” error showing up all the time. With each failed combinations, I tried to mount the adapter+mSD 2/3 times to be sure with no change whatsoever on the outcome.

I just did a quick test again with Sandisk mSD + Sandisk adapters and still A1 failed 5 times, I then used A3 which worked and tried A1 again for 3 more failures…


#10

@pierreyj

Thank you for the quick response, from looking at your results it appears to be an incompatibility with the A1 Adapter?

I will check with our QA and Customer Support to see what the next steps should be.

Cheers
@jrichard


#11

Hello, I just came back from a shooting where I only had My Passport Pro for backup and I encountered a lot of difficulties…

Right before leaving I saw that a new firmware was up (1.02.24) so I updated thinking it would improved everything… But it is the opposite in fact.

Here are what I found out:

_microSDs with SD adapters are well recognized and it will only import 1 folder out of many but indeed the most important so I don’t really mind but in that folder it will copy just few files or only one and empty (0 bytes) and then will show that the import is finished (4 blue leds). I had to check with the mobile app to find out that the import didn’t work at all. But everytime I tried to import or auto import, it did same and when I tried to manually copy/paste or move the files, it failed.
_The only solution was to use an microSD reader and plug it via USB on my passport pro but auto import/import put the files into the same folder (folder created on the first USB import so with the date as title) and since files had the same name since my camera reset titles after formatting, it created backups after backups after backup…
_So instead of using import, i chose to created manually a new folder each I imported new files and used copy/paste function but I found out that the status of the operation in the “activity” panel on the mobile app always told me that the operation failed but it wasn’t and succeeded all the time. Although there is no way to know it except looking at the hdd led. The 4 led for import don’t turn on for copy/paste, move actions. I don’t know if it had before but it would be nice if it did.

On the previous firmware, the import of microSD with SD adapter was working…

Thanks.


#12

I can confirm strange “sensitivity” of WD MP Pro to microSD2SD adapter.
I have never encountered such a issues in other devices and in my imagination “adapter” is just a dumb contact size conversion…
I am using uinterchangeably all my adapter I have ever received with PC devices, cameras or microSD card. And they always worked…until new WDMP PRO which constantly behaved as reported above - start coping OR just few seconds of browsing SD card folders and bum… card is unmonted with working stored in WD device history log.
Sometimes I got few folders created, sometime even one or part of camera video copied than all LEDs blinks as end of job…there is almost nothing copied.

But… by strange feeling I have picked another adapter ( SAMSUNG instead od Kingston) and …BINGO ! Everything works like a charm :smile:
This is god news, certainly but… what makes WD devices so sensitive about microSD adapter? And why some microSD cards works with one adapter but not with another and the opposite? This looks like ONLY WD my Passport Pro problem. Most (all?) other devices smiley…works through ANY brand of microSD to SD adapter.
This is worth closer inspection by WD engenring team.

Cheers


#13

Likewise, micro SD not working for me. A MSD in a standard SD adapter does work in the original MPW, but not in the Pro. Tried a standard SD adapter and a USB reader that has a micro SD slot. No joy. Card from a GoPro. It’s not good that this is not working.


#14

Very strange - is it possible to try a different microSD adapter? Or a microSD-to-USB reader?

@SBrown , tagging you here for your insight as well…


#15

I think it can be a hardware problem. Did anyone check this issue from hardware perspective? Is the layout of connections OK? Is it possible to try to change the slew-rate of the pins? Etc… I think that hardware guys should check this issue. Those mysterious problems may occur if the hardware is running on edge somewhere. Small difference in capacity (different adapters) or temperature (dies after some time) could explain this. It is also possible that this issue will affect only some pieces of the hard drive, because they can differ in tiny details.

I wanted to buy this drive to offload microSD cards while traveling. It is awesome, but because of this issue I will not buy until it is solved.

Edit: to workaround this issue, can you test different adapters (several pieces of each) and recommend one that works best? Possibly you can do the same with micro SD cards.


#17

WD team, do you have any updates on this issue I have bought the Passport to use with my sony action cam and I am not able to use it. This is such a frustration


#18

Alex, any updates on this issue?


#19

Richard, any updates on this issue?


#20

Hello, have you managed this issue somehow, or maybe you found out any kind of the workaround


#21

I have same issue as well, microSDs just do not read via SD adapter which is very disappointing. It is important to note that the SD adapter / microSD works fine on a WIndows 10 PC so it tells me the SD Card reader is either poor quality or its a firmware issue.