Remote backup failing , error 1400

I have 2 Mycloud devices. I think they are both DL4100 (they look the same (black boxes) with 4 drive bays) They are in a remote location so I can’t look at them right now, and I can’t figure it out from their web interface. I can see that one is running firmware 2.41.116 (2 bays populated with 1 TB drives, RAID), the other one is running firmware 5.08.115 (4 bays populated with 1 TB drives, also RAID).
The smaller device is used daily for work, the second one serves as backup drive for the first one (and some other things). Lately the backup has failed with Error 1400, possibly after a firmware update on the larger drive.
I have been trying to re-establish the backup, but I am running into all sorts of issues. Sett the SSH password on the second drive, as well as the backup server password, but when I try to set up a new backup task on 1, I still get a “wrong backup server password” when I try to set the target folder for the backup.
Is this perhaps an incompatibility between the devices after the firmware was updated on the second one? I tried to update the firmware on the first one, but it only tells me that no updates are available.
How do I set up a backup from device 1 to device 2?

Thanks. Missed the model number on the login page. Thankd for the hint.

One of the devices is a DL4100, the other is a PR4100.

The DL4100 is running version 2.41.116
the PR4100 is running version 5.08.115

Can I upgrade the DL4100 to a version that works with the PR4100?

Thanks. Yes I knew about the Backup app, and it is installed:

But I don’t think that helps me with my backup issue, does it? I am not trying to backup something ON this drive somewhere else, I am trying to backup another MyCloud device TO this drive. I see that the firmware was updated on the DL in December. Is there an indication when, and if at all, the DL firmware might be updated to one that is compatible with the OS5 versions?

Maybe it is port forwarding. I am following the link to the backup procedure step by step, and I am running into an issue with the port forwarding. Everything checks out in steps A1 and A2. In step A3 I am supposed to see this:


What I see on my device is this:

i.e., no backup server. I do see it listed, though, before I click on the “Add” button as the instructions advise:

When I click on the details, I see the settings for remote backups, but the status is “failed” (after going through “checking …”:

What does that mean now? It is not clear to me where the port would have to be opened, given that the 2 devices are on the same network behind any firewall.

Would this even go through the router? the two devices sit on the same network segment behind the router. How would the router come into play here? I did talk to one of my (remote) IT people, and they said that the router should not come into play.

Also, what are the “external” and “internal” ports? Again, I understand that from a router perspective, but why would the NAS need this information, unless it has it’s own routing implemented. Does it?

I looked around in this forum a bit, and I did find some posts that dealt with a similar problem, but I think all of them tried to access the NAS from the outside, through a router, while I am trying to set up a backup BEHIND a router.

Thanks. I’ll start a new thread with a different title. Perhaps I can get someone else to respond.

Thank you very much for your help with this.