Remote Backup Failure - DL-4100 to MyCloud Mirror Over Internet

Have configured my customer’s office DL-4100 NAS to perform a scheduled backup (Synchronize) over the Internet with a MyCloud Mirror NAS located at his residence.  No problems setting it up and successfully ran a test job on one small folder.  Then set up another remote backup job to include 7 shared folders from the DL-4100, totaling about 250 GB, and the job failed on one of the last couple folders. It took about 10 days to get to the point that it failed.  The only clue that I get from the DL-4100 is an e-mail alert and a notification that appears on the DL-4100 dashboard that says:

“Remote Backup Error:  AN error occurred during your remote backup job name:  JobName, to the destination device:  RemoteName, on the share:  RemoteBackup/DL-4100-SN_DL-4100Name/JobName/.  Please check your system settings.  Data and Time of failure.  Code: 1400”

  • How can I determine what caused the problem?  I can’t find any explanation for backup job error codes on the WD support website. 

  • Is there a backup log somewhere on the primary or remote NAS that I could check for clues?

  • I checked the System Logs on the DL-4100, but see nothing related to backups.

  • Could there be a problem with the backup feature on the WD NAS that doesn’t like certain file or foler name characters, or could there be a “path too long” issue, like there is with Sharepoint?

Any assistance in determining the cause of this remote backup failure would be greatly appreciated.  My customer purchased both systems recently for the sole purpose of providing his small business with a reliable backup solution with offsite storage capability.  Thanks.

Hello, welcome to the community.

I have never seen this error and you might want to talk with someone at  Western Digital. But a few things I would try would be:

  • Change the names of the shares to reflect something smaller.

  • Remove all shares from the backup jobs and start adding them one by one and see which one fails.

  • I would also take the Mirror to the same location as the DL just to make sure that is not network related.

I know the last one is a little hard to accomplish, but its just something that I would try if put in the same situation.

All changes that I propose are just for testing. 

Thanks for your reply and for your suggestions, Lluna.  I did talk to WD tech support yesterday, after posting my message in the community.  The person I spoke with said that there is no problem with “illegal characters” in file or folder names and no problem with “path too long”, so I’m focusing on the network setup and suspect a problem with the ISP-provided router at the business owner’s residence, where the MyCloud Mirror target NAS is located.  When I set up the Mirror, I was able to access the home router remotely and the port-forwarding rules necessary to support the remote backup were correct and everything worked for the initial, test backup job.  I’m also going to try your suggestion of backing up one folder at a time, to see if there is a problem with a particular folder, or folders.

Did you get a resolution to this error? I have the same problem across a LAN. Three of the backups work on, but the fourth gives the error code: 1400.

Was the failed backup suppose to retry after sometime if its due to network or any activity related issues

Sorry for the late reply, Paul, but I only just received an e-mail with your question. To the best of my recollection, I took the suggestion to break up the backup of the DL4100’s 7 shared folders into 7 separate remote backup jobs, which worked. The business owner’s home Internet service was pretty low on bandwidth and maybe the length of time it took to back up all 7 folders, especially during business hours with files in use by his office staff, led to the failure… After making that change the backups have been running flawlessly for a long time now. The next time I have the opportunity to set up a remote backup, I will first do the backup on the office LAN and then move the remote NAS to the offsite location and see if that works better, since subsequent backups will be incremental.

DirtyMacho
.
I don’t know if a failed backup is supposed to resume, if there are temporary network problems or if files being backed up are in use. I doubt it. There just isn’t adequate documentation on a lot of the WD NAS features. I have had some good input from WD tech support though.

It seems that “error code: 1400” just means something happened that I cannot recover from. Almost a “general” error and so inspecific it is almost worthless.

My backups seem to be running again now.

The Error Codes are listed here… https://support.wdc.com/knowledgebase/answer.aspx?ID=16771
sadly without any recommended rectification actions.