Backup between Clouds fail on same network

I have an issue with 2 Cloud devices on the same network BEHIND a router. One device is a DL4100 with firmware 2.x, the other is a PR4100 with a firmware 5.x. The PR is used to back up the info ion the DL. Worked fine until about December (possibly when firmware on PR was updated). Now I can’t get it to work.

The DL manual describes the setup like this:


I have followed that to the T, but the backup fails. I have also tried to set up a new backup. If I follow these instructions, it fails at the “Destination Folder” step. the DL does not seem to find the PR.

I have looked into port forwarding under network settings. they all fail (both on the DL and the PR), but I am not sure if port forwarding even comes into play here, as this is all on a single network behind a router, and I have used IP addresses to specify the server.

Both NASes are visible on the network, and I can access them and store and retrieve files.

Are there any other resources that i should check for this?

Ok, I am at my wit’s end. I tried GoodSync, but found out that it only works to backup data from a computer to a NAS, not between NASes.

So, is there no way to backup the data on a DL2100 to a newer device running OS5?