Remote acces with Dlink DIR-880L Router

I can acces all files on the local network, but not remotely.
Tried fix adress and port forwarding but no luck yet.
I am using a DLINK DIR-808L router for the Gigabit connection between PC and MYCloud HD.


I recommend you turn off remote access, power cycle the drive and then re enable remote access.

define what you mean by remotely and how please…


Remotely means , when I am on another Network, mobile or either on another
location, Hotel, Company etc.
WD2GO cannot acces my WDMcloud disk, despite that all seems OK, as seen on the
message “Connected - Port forwarding connection established”
I believe it is related to the Dlink D808L router, but nothing indicates in
that direction.


The remote access service (now called or the Windows Phone app?

If the latter, it is no longer supported.

If the MyCloud says port forwarding is established, then your router is set up correctly to allow remote access.

Did you setup remote access for a user account?
Did you click the link in the welcome email sent to that email account?

I just want to acces my files remotely, with my own user account.

I know that the windows App is not supported anymore.

I use the Android app or connecting directly on IP and that works fine when I am at home.
Once on another network … no access…

When using WD2go Services it can’t connect to my disk named WMD-Cloud on another network.(see screenshot)

I still need to try Hamlet’s advice.
“I recommend you turn off remote access, power cycle the drive and then re enable remote access.”

What I did do is that I redid the install in the hope that UPNP is setup by the program on the rouiter, and that worked.
I got msg “port forwarding established” but still no connection from outside.