Red Lights, Not Recognizing Hard Drives Installed

I have a 4TB Mirror that I haven’t had attached in a few months and just plugged it back in today. The desktop software and Dashboard could see the device, but couldn’t access any data on the hard drives. I updated the firmware, which seemed to go through successfully, but then looked at the device and saw two solid red lights for the hard drives.

I’ve tried resetting and restarting, with no luck. I tried uninstalling the software and running setup again. When I run the setup program (or try to log into the Dashboard), I get a pop-up notification asking me to install hard drives in the device. I’ve removed and reinstalled the drives, but it’s not recognizing them at all. Because of that, I’m no longer able to get into Dashboard and can’t access any other functionality on the device whatsoever.

Any thoughts? I can’t see any way both drives would have gone bad. They’ve been in the device on a shelf, just not plugged in.

Hi, I would suggest you to contact support as the way that the drive is behaving looks like the drives are good but the enclosure is defective.


Following up on this, I spoke to Level 2 support, who initiated an RMA to provide a new device. The new unit arrived, and upon plugging it in I’m seeing the same problem. Two solid red HD lights, and an error message in Setup asking that I install hard drives.

I need some suggestions here. So far I’ve tried:

  • “40-second” reset of the unit
  • Resetting my router (a Netgear R6400)
  • Trying a different router (a Netgear N600)
  • Assigning the My Cloud a static IP address
  • Plugging the unit directly directly into my Mac’s ethernet port
  • Trying to run setup through a PC which has never accessed either this unit or my original

All lead to the same error. There’s clearly something that’s getting in the way of the Setup program or the Dashboard being able to see the drives correctly in the enclosure.

Any ideas from the community?