Problems after FW upgrade: WDMYCLOUD

I’ve had a variety of problems after the FW upgrade which occurred last night. I had set it automatically install upgrades.

I have 3 computers (W7, Vista, XP) networked to the 3 TB MyCloud and a 1TB harddrive connected to the MyCloud via the USB port. I backup the computers to the 1 TB drive. This worked fine until this morning.

Following are the issues I’ve found:

● Backups on all computers failed

● The USB drive no longer shows in windows explorer on any computer

● WD Quick view shows only

            “0% used – temperature unknown” – on one computer, and

            “WD Quick View” on the others

            No longer shows the USB drive

● Dashboard is only accessible from the W7 computer, not from the others

            Loads very slowly

            Reboot from dashboard times out

            USB drive does show on dashboard but with “0KB free of 0KB”

● Opened MyCloud software package on W7 computer.

            It asked that I upgrade. I did.

            It asks for login – I have no password

            I log in without entering password, and it does nothing

            I close login screen and watched the “Sit back while we connect” for over an hour

   On Vista machine, my cloud software opens. It did not ask me to upgrade.

                        The shares on MyCloud show, but the USB drive is no longer there.

I need to gain access to the USB drive. Any suggestions?

1 Like

hi from spain

i have the same problem!

i have a wdmycloud 3tb and wdmybook 3tb connect by usb

the control panel is ko


Can you try the following:

Please connect your USB drives to a PC/Mac.  After you verify that they mount and can access the filesystem, please safely eject your USB drive

Please reboot your WDMyCloud drive through the Dashboard (webUI)

After the drive has been rebooted, please connect your USB drives again and wait about ~3 minutes.  Do the drives show up now?

Thanks for the reply. I cannmount and access the drive through a PC. I cannot reboot the mycloud through the dashboard. It times out. Other ideas?

It’s showing 0% used in Quick View for me too. Also accessing My Cloud user interface is very slow.

It didn’t do this before the firmware update.

:cry:My WD MyCloud drive is now unresponsive following the firmware update too.

Before the firmware update my Drive worked very nicely! Much better than my previous NAS! Since I updated it it has now become largely useless and totally unresponsive!

Yesterday at least I could access the dasboard. Today I cannot even do that. It looked to me that the main problem seel#med to be the drive was endlessly trying to rebuild the media catalogue so I wondered if maybe I should re build it rather than refresh it as it had been doing that for over 24 hours. So I set it to do that and went to bed as there would be no point in watching it’s glacial progress. Now this morning, the Dasboard no longer accesses the drive at all. The desktop WD My Cloud software no longer accesses it at all, and hasn’t since the so called upgrade… When I could access the dashboard it maybe took a a few minutes or more instead of the usual 30 secs or so.

The whole device has become unresponsive. I might have to do a ‘pull the plug out’ re boot!

On the face of it this would appear to be a disaster. If the device can be brought back to life I will probably never trust to upgrade the firmware again.

Is there a way to ‘update’ the firmware to the previous version? Is it possible you could put out an update to do that? Is there a way to do it when the dashboard ISN’T working?

I have been reading other threads on this. For the record I am on Win7. I don’t know what is meant by ‘messing around with the SSH’ or adding thrird party Apps - not something I have done as far as I know - I just store music, videos and images on my drive.

I am a pretty basic home user, albeit a somewhat dissappointed and frustrated one just now! And please watch the jargon like SSH, as I will have little idea what you mean.

Thanks in hope of a solution

Phil (UK)

Just an update to my last.

Would you believe not only have I regained access to my NAS but also it seems to be working again!!

I decided to pull the power plug and leave it for 10 mins or so, then I plugged the power back in and it started booting.

The key to my success with Dashboard access seems to be to launch dashboard DURING the boot up (flashing light) phase and I was asked for passwords and I was in. It took quite a while for the data boxes to fill and the drive still seemed somewhat preoccupied with something…scanning the data perhaps? That box variously indicated ‘scanning’, ‘error’ and just ‘-’

After maybe half an hour or so the drive settled, the error message in the media scanning bit turned to idle which it is normally. Once again my WD My Cloud software on my Windows 7 PC is connecting with the drive too, it hasn’t since the firmware update whilst all this has been going on. My iPad connects again too, thought hte WD photos app on my iPad isn’t connecting anymore???

Whatever has been going on (some sort of glacial scan of the data) seems to be over and things seem to have returned to how they were.

Interestingly, I use Foobar on my PC to access music data on my NAS. There was a playlist of tracks already set in Foobar, non of which it could access on the NAS when I tried to resume playing the list - though they were still all there on the NAS? Once I deleted the play list and re added them they play fine! Curious. Fingers crossed I am back to normal. that would seem to indicate that somehow their addresses have changed?

The watchword here at least for my installation (and maybe I just got lucky) would appear to be that a firmware update mught take the drive some considerable time to ‘recover’ from and seems to involve a glacially paced re cataloguing of the entire content of the drive before normal service might be resumed? But that is my very much layman take on this.

But, as an observation, this whole experience has severely damaged my trust and confidence in the whole business of frimware updating, something I am sure many others will also be feeling. I politely suggest WD need to take heed of this. I will be VERY reluctant to update it again in the future without some cast iron assurances

If there are further developments I will post again.

Phil (UK)

An update:

I disconnected the USB drive and did a reboot on the mycloud using the button on the back.

When it came back up, I reconnect the USB drive. It still said “0KB free of 0KB available” on dashboard and did not appear on any of the networked computers.

I then ejected the USB drive on dashboard, waited an hour, and reconnected it. Then the real capacity appeared and it now appears on the computers.

I’m attempting a backup to the USB drive. The backup program found the drive, but I’m concerned that the slow response time will cause a problem.

Quick view and the mycloud software are still dead.

At least I can access the USB drive.

Update…myearlier euphoria might have been premature…

Dasboard crashed after linking to support to post the above. SO I closed it

Having listened to music off the NAS for a couple of hours or so via Foobar I decided to watch a video on my WD Media Streamer.

All went well except the file I chose wouldn’t play - not found on server of similar error message. I couldn’t get anything to play…it occurred to me that the Media Streamer’s view of the location of the contents of the NAS might be wrong now - as indeed Foobar’s was when I tried to play the earlier list from pre firmware ‘upgrade’ and couldn’t.

I returned and fired up Dashboard…no…no connection tot he NAS again…nor any connection now from WD My Cloud…back to square one! I left the dashboard trying to access the drove and took the dog out for a walk!

When I go back it was still trying - and failing - to access the drive so another pull the power chord out re boot has taken place…

Once again I regained acces via the dasboard…and WC My Cloud and both now access the drive again.

I am considering my next move! I can feel a system restore coming on!

Immediately I did so the content scan showed scanning, and now error…hmmm

But I am going to see what happens during the evening first. I have wasted a lot of time on this today on what is a lovely summer day here in the UK…

As an observation, I would say that this is so NOT how the user experience should be with this product and given it’s target user market, I suspect that statement could be multiplied 10 fold.

I wiull post again what experiences the evening brings.


2nd Update

Back-up operation failed. Uable to access network drive - Operation timed out.

Slowed response killed it.

I can still see the drives via explorer, but it takes ~5 minutes to load.

No longer able to access web interface - “Waiting for reposnse…”

I don’t know what else to do. Open to any suggestions.

Unfortunately I did the upgrade and now nothing works.

It takes ~ 5 minutes to get a response from the Drive.

When trying to change something, I always get the error “Share function failed (400099)”


Not tried to access or use the drive most of the evening but returned to my PC to see the following alert within the dashboard…

Red Hexagon with Exclamation Mark in it

Media Server connected list internal server error (400159)

Does that mean error code anything to anyone?

Dashboard still not crashed at least, but Capacity is currently a ‘-’ and scanning status is idle.

Accessing the drive takes much longer than it did generally.

Can still feel a system factory reset coming on! I would if I knew it would work and how long it might take to recover from fully. Lack of detailed info from Dashboard leaves one not knowing what os actually occuring.

A rather sorry state of affairs all in all.


1 Like

OK - so I can again log into the forum (there have been times when I could not) so this is the update of where I am today.

Drive reports Buliding content scan, then reports and error doing this,…then reports building and now error.

Seem to to have access to NAS from my iPad this morning. Maybe that interrupted it and caused an error…but how would you know?

As with all problems such as this, the key is information on the situation. Sorry WD, but this is an aspect you are not dellivering on at the moment. The weekend maybe?

I would say that you should either a)fix the firmware and issue and upgrade or b) repackage the old firmware and issue it as an udate and you should do one of these two ASAP.

Then you have the task of re building consumer confidence in any future firmware updates and your products and their support, and that will be another slow thing.

Oh for not having pressed that ‘update firmware’ button…

Phil (UK)

What surprises me is they have issued a Fw intended to barrage some use of their product instead correcting the zillions of bugs it has.

They have issued a fw which prevents downgrade purposedly.

They have issued a fw which prevents the execution of some tools.


Ok Sunday evening here in the UK 4 days after firmware update.

I have to say that the drive here is now showing signs of having returned to normal, well near normal.

Things that weren’t working yesterday seem to be again. I have accessed and played a video file from my WD Media streamer - something it would not do yesterday. Several times today I have successfully launched the Dashboard and WD My Cloud software and have even used the latter to upload a new file to the drive…which seemed to take about as long as it would normally to upload. Dashboard seems slower than it was perhaps, but I never used it a great deal week to week so it’s hard to be sure.

Over night I set it to rebuild the media DLNA database and left it for several hours. This is the one main area of concern at the moment - the content scan now usually shows ‘error’ instead of ‘idle’ as it used to. SO something isn’t working as it was here. I should add that the Nas has around 50,000+ files on it of various sorts - so a scan will take some time I guess?

Ipad connectivity seems fine again for now using My Cloud app - though the WD Photos app isn’t working and says ‘first time set up’, so that’s lost it’s way in the world!

It would appear to the layman (me!) that the firmware change was quite ‘shock’ to the system and it need time to recover! Maybe the slow pace of the media scanning has preoccupied the drive rather over the past few days making it so unresponsive etc.?

I will keep you posted - though several times over the past few days I have been unable to log in and post to the forum? Maybe it’s being swamped rather in the fallout from all this?

If I could get the content scan out of ‘error’ mode and assuming everything else remains stable as it (touch wood) is at the moment it would all seem to be looking positive here again now…fingers crossed!

Phil (UK)

Monday morning

For the first time since the firmware upgrade the content scan box in the Dashboard is reporting Idle this morning (after a night in building mode perhaps) and all the sub boxes have green ticks against them! Last night the DLNA boxes were ticked but the media scan ones were yellow triangled. 

WD My Cloud on win 7 connects to the drive quickly as does the My Cloud app on my iPad. Not tried my WD Media Streamer yet but that was working yesterday.

Also my WD Photos iPad app has gone through a set up routine and once more appears to be finding it’s way in the world and connecting to the drive again…I am able to browse photos again on the NAS. All good.

The only thing that doesn’t seem to be working is the drive isn’t yet going into sleep mode at all…but I will monitor that. The data base scan and build might have only just finished when I came to the drive this morning so it might not have had time to go into sleep mode.

So 4+ days on and despite fearing the worst and at one point having a pretty much completely unresponsive My Cloud drive, it now seems to have sorted itself out and seems to be back to normal and running the firmware update. (just pinched myself and yes I am not dreaming this!!)

Giving it time - and plenty of it - seems to have been the key here? Pity we weren’t told that maybe? Information is king. Like many folks perhaps, the upgrade could be left to a time when the drive wasn’t needed (unlike a weekend perhaps) and had such time to do what it needed to in relative peace! My  drive here is a 4TB one around 50% full with 55k+ files on it of photos, music and video…which seems to take a LONG time to scan and index etc. Interrupting this and trying to get responses out of the drive only seems to have hindered and delayed the compltion of this to the point that the drive seemed to be failing as a result of the update.

If anything untoward happens - I will come back.

Fingers crossed

Phil (UK)

All still relatively stable with the drive EXCEPT trying to upload some images.

Got around 400 images to add, gets around 10% in then the content scan starts showing ‘building’ and the whole transfer grinds to a very slow crawl. Seems liek the systems’ preoccupation with content scanning just takes over all it’s capacity.

Small uploads complete before the content scan jumps into action. Was this how it usedto be? Would be useful if content scanning kicked in after uplaod activity has finished?

Otherwise, using the drive has been smooth and good all day when it is delivering content.

Phil (UK)

OK Uploading quantities of files via WD My Cloud on Win 7 seems to be a REAL problem, I counted around 30 files at approx 1Meg or so each (+/-) in around 30 esconds (good transfer speed) before content scanning kicked in and the whole upload slowed to a completely unuseable crawl

This is bad and makes uploading say 400 holiday images a REAL BIG PROBLEM!

If nothing else this needs fixing…but then we’d have to update the firmware again…!

Aside from this uploading issue, everything else at least seems to be running smoothly again post firmware update to v4…and I didn’t think I would be saying that a couple of days ago!!!

Drive sleep mode still not seen though.

Phil (UK)

Using Windows Explorer I got around 50% odf the remaining files acroos before crawl mode kicked in…I will leave it this time and see what happens to the rest of the 300 or more files I dragged and dropped…5 hour or so left by the looks of it!!!

As a deliverer of content the My Cloud NAS has to be able to accept upload of content to deliver don’t you think???

Phil (UK)

Didn’t take that long in the end, maybe 10 mins…so better via Windows.

Thank you for the updates here on this thread.

Is it possible for someone to submit logs through the webUI and PM me their case ID number?