Just installed new firmware update v04.01.02-417 Lost connectivity to USB Drive

After experiencing significant performance issues copying files to the My Cloud, I installed the new release of firmware. Now I cannot access external USB drive which has been connected to the My Cloud for many months. (Seagate Backup + drive). I’ve powered off several times and disconnected from WD drive several times with no positive outcomes. Need help.

Do you also encounter issues with other USB drives?

Similar issue… After installing the firmware update, I lost connectivity to my MBP (running OS 10.10.1). Several reset attempt left me hanging. Removed the external USB hub from the myCloud disk and everything is now hunky dory. TimeMachine is connecting fine. Shares are available (except for the additional USB drives of course).

Have now turned autoupdate off…

My experience - after updating over the past 3 or 4 updates - with a USB attached to the MyCloud,

I have found that doing any update, will result in the unit loading slow, not finding the usb drive that is attached and the main page does not fully load.

Here is what I do…

Disable both media sharing services. Reboot. If you get the steady blinking white light on the mycloud that means it did not shut down properly. Power off both Mycloud and USB devices and then power back on. Wait until booting is complete. If all seems good, do a shutdown. Then, power cycle both devices again and wait for both devices to come back up. If all is good, turn on media sharing services. Wait a while until all is good. If system becomes slow or unresponsive again, try the reboot process and if necessary the power off and restart process.

I have found that eventually the device figures itself out and becomes normal again and will be until next firmware update.

This issue has happened with every single update I have done, no matter what you do to prevent it.

I have tried everything else including factory restore, quick restore etc but the only thing that has worked is the reboot and/or power down process about 2 or 3 times after updating.


just curious if you tried unmounting and disconnecting the USB driver before the upgrade and leave it off until the mycloud stabilizes after the upgrade then re-attache

No. Upgrade completed. Now what? I’ve tried recycling both drives several times. The dashboard recognizes the Seagate drive, but with 0kb storage.