Latest firmware has left me with a BRICK

It seems I am not the only one to regret updating to the latest firmware yesterday.  My MyCloud is now a BRICK.  No access via the dashboard - it sees the unit but will not complete system scan, nor let me logout.  The Mac app and ios app cannot even find the unit on my network.  Data must be there because there is only 2.3TB available (on my 4TB drive), but I can’t access my data!

So this latest firmware is a total disaster as far as I am concerned.  I have tried resetting the unit, unplugging etc. no use.

So next step, unless someone from WD support can be reached and can help fix this, is to get an RMA number.  Or maybe it’s better to learn my lesson, trash the whole thing and get a real NAS server from QNAP or Synology.  There will be no WD drives in them either!

Welcome to the Community. Have you tried resetting the device or a power cycle? Does the unit respond to a PING and direct volume access using its IP address?


The only access I have (and not every time I try) is via Quick View.  It usually finds the disk, but never completes the content scan, and only sometimes finds the shares and users.  The MyCloud app on both my MacBook and ios devices cannot find the disk.  Attempting to get in via IP address doesn’t work - no response.

New post - now the WD Quick View doesn’t work either - tells me Smartware is not installed.  So downloaded new Quickview software (Oct 24 version) and quick view still does not work.  SO firmware and software is now equally unreliable. Just help me get my data off the device so I can send it to the recycling depot.

My WD MYCloud software stopped working after it updated today. I could no longer detect any WD devices on my network.

I could still access the dashboard and shares though. On the dashboard I could see the firmwear needed updating so I updated it hoping it would cure the problem

Now the shared have stopped working so just have a dashboard, and no means to accessing the drive!!!

Mine is now a brick also.

Why are these software releases so unreliable? We need a means of going back to the old firmware and old software.


We have passed this along to support.

Thanks. Looks like they are going to be busy figuring this out.  How about reissuing the previous firmware so we can all go back to where we were?

We definately need a way of going back to the old firmware and old software. Both updates (WD My Cloud for desktops, and MyCloud firmware) have just broken their respective functions, leaving me with nothing.

Well I was going to update tomorrow morning, but I guess that’s delayed for now.

Is there a way to go back to Firmware Verision v04.00.01-623 ?

It was usable and fairly reliabale.

Verision .

v04.01.00-408 is NOT USABLE.

Where is Pablo?  He called me on Sunday and said that WD would have an answer for me within 24-48 hours.  So 60 hours later there is no contact.  He offered to give me an RMA number - so I said no - I send you the unit, I lose my data!  I am asking WD support one last time to provide me with a way to retrieve the data on my disk.  I know it’s there, because the odd time I can get in via Quick View, it shows 2,3 free TB, and shows the shares and users.  After that it quits scanning and the whole app freezes.

SO one more time WD - how do I retrieve my data?  I am going to buy a Synology NAS and a hard drive from anyone but WD!  

Pablo called me immediately after my post - thank you.  We are working out a resolution

I can’t move files, is this related?