Help, Help, Help!

Well for nearly six months, I have been a very satisfied owner of the MyCloud 2TB unit, reading a lot of complaints on this forum and about “bricks” and wondering just what I was doing right since I never had any problems, even with always updating to the latest firmware. UNTIL NOW!!!  This evening I attempted to log into my Dashboard and check for updated backups (as I faithfully do), but I could not get in.  It just kept saying I was not connected, but my device shinned “blue” as always and my back up USB was showing connected.  PANIC!!!  I tried and I tried, no luck.  Couldn’t even see it on the network (I have a Mac).  I was able to access the dashboard briefly after several attempts (like 15) and when I tried to power the device down, so I could do a cold restart, it just went into a never-ending “updating” screen (which after 40 minutes I gave up.  

I disconnected the power waiting 1 min and tried a 4 sec reset, but that only let me access the dashboard in a browser, but again, anything I did seemed to go into a never-ending UPDATE.  I managed to get into the utilities and have executed a FULL RESTORE, hoping to start all over (as I have all my data backed up) and I even have a USB drive which is normally attached to the MyCloud that has the safepoints on it.  

Right now I have a brick and while it is going through the full restore (at 1%) I am hoping this will bring me to where I can use the safepoint on my back drive to put everything back as before, but if not, I will start all over.  MY BIGGEST CONCERN is how this could have happened, and also, if it happened again, is there some way I could have more easily got it all back without having to do what I am doing, staring all over???

Any thoughts would be appreciated.  Worst part is that you are completely in the dark and relying on the color of a single light to know where you might be.  Too bad you could not observe transfer activity, and why it was no recognized on the network befuddles me.    Thoughts, suggestions, guidance would be much appreciated.  I tried to contact WD but after 35 mins on hold listening to a “we will be with you shortly” and “all calls are monitored…” I gave up.

Hello vpasq,

I think you should try to contact WD Support again. You can do that through the email support as well.

WD Contact info:

Actually, I am VERY PLEASED to report that 1) I got it up and running having completed a full restore and then transferring all the data (12 hours worth of transfer time) to the drive.  Then I reconnected the USB drive and all is up and running again. 2) I actually got an offer to assist call from WD support, but I missed the call, however, an offer to return the call and assist as necessary was rendered.  THAT’S TRUE CUSTOMER SERVICE AND SUPPORT AND MANY THANKS TO WD (Ken)!

I have been a longtime owner of many WD products and frankly this is the only one I have had any problem with, but now fixed I am back on my “happy, happy” wagon again, and the extent an effort to assist was made by WD further renews my appreciation for WD products and their degree of support!!!  Thanks to all who helped (in this posting and another about the USB).