NOT Resolved USB is Broken in latest firmware

I have tried to upgrade 3 times to the latest firmware but every time my usb drives are not liked by the latest Firmware.!!

My setup is WDMycloud to 4 way usb3 hub with 2 self powered usb3 drives connected and 1 usb2 drive usb powered.

it is apparent that a lot of usb3 enclosures do not spin the drives down when not being accessed (Google it). therefore I need to switch the drives off when I am not using them (the usb powered usb2 drive is never disconnected but spins down when not accessed,

with firmware version 030401 everthing works well and even after downgrading the firmware the drives are recognised quickly and accessible and can be turned off and on whenever required (ejecting the drives from the dashboard makes no difference except for the “unsafe device removal warning”) the usb2 drive is always accessible, and this has worked for months so is good.

Now when I upgrade to version 4.00.01_623 the upgrade goes ok and recognises the usb2 drive quickly which is permanently connected and when I switch on my 2 usb3 drives it takes quite a while before they are mounted and accessibble with an “internal usb server error” message generated for each one but it works. and the WDMycloud will eventually sleep.

if I then turn off the usb3 drives the WDMycloud wakes up temporarily but will eventually go back to sleep.

the problem starts when I turn the usb3 drives back on,

the WDMycloud then becomes totally unresponsive and the dashboard cannot be accessed and on the odd occasion that access is available no usb devices (including the usb2 drive that has always been accessible) are detected but the usb shares are listed (although they cannot be accessed from the network) and the capacity for the WDMycloud is blank,even WD Quick View shows 0% and no usb drives.

as stated this arrangement has been working for months without issues on the old firmware and the only reason I want to upgrade is to use safepoint backups to usb which doesn’t work on the old firmware.

The hub can be powered or not and the drives ejected or not but this all works with the old firmware and not the latest so why break what ain’t broken

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country:



After yet another attempt to start the drives and WDMycloud becoming unresponsive and dissapearing from the network I switched off the 2 usb 3 drives and pulled the power plug on the WDMycloud and restarted, after initailising all was ok and the usb2 drive was recognised and accessible.

after reading other posts about upgrading I then done a factory restore (system only)

after adding the users I started the 2 usb3 drives which were recognised and made accessible quite quickly.

so far I have switched the drives off & on several times with only a small delay of a few minutes until the drives are mounted and accessible so looking good at the moment:smiley:

Unfortunately the result was short lived:confounded:

when I checked whether my WD TV live could stream from the usb drives they were not visible on the media server,

restarting the drives or the media scan or media server had no effect except once again drives were not recognised by WDMYCloud and it became unresponsive, at one point when I managed to access the dashboard I tried a reboot, an hour later the light on the front of the WDMYCloud was still flashing and it was not accessibble on the network. so back to pulling the plug, I tried switching media serving of and on again as suggested elsewhere, this worked the first time but after rebooting the usb drives they failed to appear in the media server again!

I have had enough playing with this firmware and have downgraded to with which I can use the usb drives without problems as I have done for several months previous.

Thank you Trancer for your suggestion but I have not got the time or inclination to go back over all of these actions with WD support staff who do not seem to be held in high esteem by many users on this forum.

Just tried updating to the latest Firmware v04.01.00-408 and as I expected connecting the drives works ok for a couple of times then the WDMyCloud goes off into a mega sulk and cannot be accessed until the drives are removed and the Cloud is unplugged and restarted I tried using just a single drive and ejecting it and unplugging the usb before switching off then switching on before plugging in the usb but still sends the cloud off on one,

So once again I have reverted back to firmware v03.04.01-230 and immediately everything works as it should as it always has done with the old firmware!!!

I have spent too much time trying to find a workaround so that I can upgrade to the latest Firmware and still use my devices as expected so guess I will just have to live with the shortcomings of the older Firmware and any vulnerabilities it may have or bin the WDMyCloud and find a competitors device that does “what it says on the tin”:confounded:

Still using V and having no issues whatsoever with my 3 usb drives

Media streaming is working

safepoints are working

My cloud is accessible at all times whether local or remote