Problem updating from OS3 to OS5

I have problem, the manual firmware update gets stuck at Upgrading

Screen Shot 2021-12-06 at 2.22.31 PM

Kind Regards

As a troubleshooting step. Try accessing the My Cloud Dashboard from a computer rather than a mobile device and initiate the OS5 update.

I accest the Dashboard from my computer but I can not find the place to initiate the OS5 update.

One of the boxes outlined in red says “Next”. Did you click on that?

If it doesn’t work on your desktop, do a 40 second reset and try again.

My Cloud OS 5: How to Update Automatic and Manual from My Cloud OS 3

In the My Cloud Dashboard:

My Cloud OS 5 Dashboard Update

  1. Click the Box NEW OS 5 AVAILABLE

  1. Introducing My Cloud OS 5 click Next

Or manually update:

My Cloud OS 5: How to Manually Update From My Cloud OS 3

I’m having the exact same problem - it’s so frustrating. I don’t have a box anywhere on my dashboard saying:
Can’t find it anywhere, been trying for hours. Please help.
I’m running Firmware version 2.41.121

I have the exact same problem, but the manual firmware update gets stuck at Upgrading
Screen Shot 2021-12-06 at 2.22.31 PM

thank you your link saved the day for me.

I have tried to update the firmware manually but it locks when it should start the upgrade. I have tried with Crome and Microsoft Edge and even from my Ipad with the same result. Is there anyone that have a solution?

Me pasa lo mismo tengo la primera luz en rojo hace días y no podía ver nada y ahora lleva tres horas las tres en rojo. solución por favor

Do a 40 second reset and try again.

Is anyone successful updating to OS5? I see below issue on my device:

On selecting the icon, i get next as:

Any suggestion please?

Search this forum. There is an “official” way to fix this (a bit long winded) or you can do a 40 second reset and/or a manual install.

See this WD Knowledge Base Article on how to fix that issue and update to OS5.

My Cloud OS 5: Update Screens Blank and Missing Text

There are probably not many who succeed with the update. Very hard. At first it was not possible to update the firmware and after many attempts on different browsers on the computer and on the iPad, I got the text that my update was successful. When I first tried to upgrade to OS5, there was no text. The next day, however, the text was there and the installation was successful.

I think the vast majority of upgrades go through just fine. A very small number have issues such as this but most have been solved by one or more of the methods described above.