Problem Updating Firmware - Can't See Text?

Hi All,

So there is a firmware update for my WD My Cloud and but when I start this all of the pages are missing text? I can’t see what it’s saying, it’s like that for every page. For example a couple of pages in, all it says is “minutes” but I can’t even see how many. I can’t see if it’s giving me any warnings or telling me to do anything before clicking next etc.

Anyone got any ideas? I’ve tried chrome, edge and firefox - no change. I’ve also tried rebooting the device.


If one is using a single bay/single drive My Cloud they should read through the issues (in this OS5 subforum) that unit is having with the OS5 firmware before upgrading to OS5. Particularly issues with the indexing that may render their device unusable/inaccessible for a period of time.

The missing text/graphics is something that’s been complained about in the past.

One option is to collect the My Cloud system log files and open a support case (and send them those log files) with WD Support.

How to Collect My Cloud System Logs

Contact Us | WD Support

Another option is to try and do a manual firmware update.

My Cloud OS 5: How to Manually Update From My Cloud OS 3

My Cloud OS 5: How to Update From My Cloud OS 3

1 Like

Thanks for the links, I think if people are having problems post update I’ll stick where I am - don’t want to cause problems for myself. Kind Regards.

@DeltaBaby There’s a KBA that explains how to address this issue.

My Cloud OS 5: Update Screens Blank and Missing Text

Answer ID 31083

1 Like