No text displayed in upgrade firmware dialogs

Today I got a prompt to upgrade my firmware, but no text is displayed. I don’t want to blindly click “Next” since i have no idea what is being displayed.

Product Number: WDBCTL0020HWT-10
Current Firmware: 2.41.116
New Firmware: 5.11.112

Tried on Windows and Linux, tried 3 different machines, and tried on Firefox, Chrome, Chromium, Edge, and Internet Explorer.

Main page:
image

Clicking upgrade firmware button:

EDIT: Added product number

Limit of 2 embedded images for new users, so here’s the third image after clicking “Next”:

I’m having the exact same issue. Can’t see enough to upgrade safely.

Requesting support results in this:

Ok, @nickhutch - here’s what I did:

Went back to Settings, Firmware Upgrade, and upgraded it again, as there was an additional upgrade, like yours (Current Firmware: 2.41.116 → New Firmware: 5.11.112); I couldn’t see the text on each screen, but I just risked and kept hitting the bottom right button, waiting through upgrades.

There was also a phase where there was a blue animated circle - be patient and it’ll eventually load up and allow you to login as per Stage 11 here: My Cloud OS 5: How to Update From My Cloud OS 3

In fact, you can see what each screen should say on that link ^.

Hope that helps.

@nickhutch @jjswin This forum is for My Cloud Home. We have a dedicated forums for My Cloud and My Cloud OS 5. Please collect your My Cloud System logs, send to support and let me know your case numbers.

How to Collect My Cloud System Logs

Answer ID 18374

CONTACT

I’m all for brevity, but “I’m sorry to hear you’re having a problem updating your devices, I’ll try and help.” would have been nice, @SBrown!

As you can see above, I was getting error messages when trying to access support using the support button in the system, which was frustrating. I looked for live chat: wasn’t available, couldn’t see a phone number, couldn’t find a relevant contact form. Sorted it myself in the end, but not in a satisfactory way.

The article that I provided doesn’t include steps to “upload logs”.
It includes steps to download the logs to your local computer and then upload them to the support case.

Thanks. How do I provide general feedback about customer support, @SBrown? Is there an email address or contact form you could link me to?

@nickhutch Ad blocker? Try incognito mode or have you tried a different browser?
Have you opened a support case and submitted your system logs?
If so, please let me know the case number. You can also go to Settings > Firmware and click the Update Button to get the same upgrade flow.

@jjswin “Customer Support” doesn’t have a presence on the WD Community. WD Staff, Admin and Moderators monitor and moderate the WD Community. The best way to provide feedback is to sent to support and it will reach the proper management queues. https://support-en.wd.com/app/ask

Oh sorry, apologies; as you’re a staff member providing some degree of support to customers I’ve been very silly and referred to that as customer support.

Thanks for your help as to providing feedback, but I’ve found the UK WD director Graham Holmes’ email address, I’ll probably just start there. Thanks and take care.

Thanks @jjswin, Did the upgrade following the images on the link you provided, and was able to complete the upgrade without further issues.

@SBrown, My apologies, Didn’t know there was a difference between “My Cloud” and “My Cloud Home”. I tried every possibility I could think of, (ad blocker on/off, incognito, etc…), on multiple browsers, on multiple operating systems, on multiple systems to the same result.

The post by @jjswin resolved the issue.