Can't update to OS5. Dashboard links don't work

From my dashboard I can see the link to update to OS5. The graphic is there but no text. I click on it anyway and it opens the next screen; again just with graphics and no text. I can not do update without seeing the dialogue boxes. This happens both in Chrome and Firefox. I go to settings and click on the update and the same thing happens, no text on the subsequent pages.

I have been through chat and phone help several times (argh) and have downloaded the link for manual update. I run that, it downloads, and then tries to install for an hour or so before it times out.

Anybody know how to resolve this?
thanks / Kozmo

Try refreshing the page while you’re on it. I had this happen but don’t remember how I got past it! If that doesn’t work do a 4 second reset or a 40 second reset.
Are you using the latest OS3 firmware?
Failing that, download the firmware manually and update the NAS manually.

Thanks sktn77a, I’m using the latest firmware. I downloaded and tried updating manually; the update sat there for over an hour doing nothing and finally timed out.

Thanks dswv42, This looks like the solution, but I’m half way through and stymied. I enabled SSH and kept good track of the password, but when I try to log in as sshd, the screen reverts to the login page with the admin as the username. Then I try to log in as admin with either the admin password (which is blank) or with the new SSH password and I get an error “user name or password incorrect.”

It seems I’m now blocked from any access. ARGH

I went back through all of the instructions to be sure I did it right.

Any ideas?
thanks / Kozmo

thanks. I’ll give that a try

Thanks for the help. Got it working thanks to your guidance.

@Kozmo_Bates and @dswv42
I’m having the same problem,
please could you post what you did to resolve the problem?
I’m not able to see it in this thread.
I am using the latest firmware and I already tried the 4 second reset

WD has a knowledge base article explaining (one) workaround to the issue of a blank update screen and or the update screen missing text.

My Cloud OS 5: Update Screens Blank and Missing Text

The solution provided by Bennor was what I did and worked for me. The instructions were not clear to me. I had to download and run both SSH and PuTTY.

One first enables SSH through the My Cloud Dashboard > Settings if it is not enabled already. Then one uses Putty or similar SSH command line program to connect to the My Cloud (using SSH that was enabled in the Dashboard) to issue the commands listed in that WD support article.

@bennor Thanks for the reply.
I followed the istructions, after the reboot I get this message when I tried to download the firmware
I**“Unable to connect to firmware update server”**
I also found that the proposed solution is to update manually.
Is this true? thanks for your patience


Manually downloading and installing the firmware is always an option to update the firmware if one doesn’t use the automated method included in the My Cloud Dashboard.

My Cloud OS 5: How to Update Automatic and Manual from My Cloud OS 3

Thanks all,
I have just manually updated my system to OS5.
It’s seems that every is OK
great community!
thanks again
Ernesto Giuliani