PR4100 Firmware Update Bricked my Unit Update to my earlier post PR4100 displays welcome to wd my cloud pr4100 and flashing blue light after latest firmware update

After working with WD support, it is official, my PR4100 is dead after trying to install the latest firmware update when I was prompted. The unit said an update was available, I think it was 2.41.116, it ran as usual, went to restart and the result was a flashing blue light on the power button. The unit was on a APC UPS so I know it was not a power issue. After hours of working through it using support chat, I was told to replace the unit. During these conversations when I stated the unit was fine pre-firmware update and only died after the update process, it fell on deaf ears. In fairness to WD, this was a 2 year old warranty replacement for a DL4100 that failed with critical warnings after 3 years of use. The replacement carried a 90 day warranty. Now I am in the process of working to recover the data off the drives using Ubuntu. The easy way would be to buy a new unit, pop the drives in, and I would be back up. My experience on this is a 2 to 3 year life cycle on one of these units, a very disappointing and costly experience. And an experience which I can’t justify continuing.

Thanks for the reply and info. I was told by a WD level 2 tech the unit cannot be reprogrammed, as in the usb port cannot be used. I used xenix / linux 30 years ago and have not since, until I started playing around with Ubuntu a few days ago. Initially the process seems both doable and yet difficult. I’m starting to look at doing it. I started this response yesterday and forgot to send it.

Just read your last response and says you withdrew an earlier post. Is that correct? Reading your last post I was going to attempt it. If I understand your update, you are now saying it is bricked, or do I misunderstand?

So it looks like something happened during the update that wasn’t a power failure since it was on the UPS. On its restart after the update the power light was flashing and the unit was unreachable via Ethernet. This is really frustrating and I question how ethical WD has been on it with me. In your opinion, do you think there is any further recourse with WD?

Thanks Bruce

Hi dswv42,
Thanks for the response. Today I was able to create a bootable usb stick. I have gotten into the pr4100, installed a couple drives and established a raid 1. I could use help getting the system booting from firmware on the PR4100 by using ssh. I haven’t used ssh before, so I need to learn it all.
Thanks in advance

I created the usb stick with the downloaded rescue file, and I’ve tried twice using chrome, and once with Microsoft edge. After each process reboots the screen on the pr4100 says “Firmware update failed”.

At what point in the process do I remove the usb drive?
Feels so close.
Thanks

Not quite there. When it comes back up the display on the pr4100 looks ok. When I try to log into it at the ip address I get the following.

Safe Mode

Your device firmware appears to be corrupted and your device is currently running in Safe Mode.

Please download the latest firmware from the WD Support website at http:\www.support.wdc.com and upload the firmware file below:

Firmware Version:
Upload File:

Do I download the software from the wd site and try it again?
Thanks

Pulled the firmware off the wd site, went through the process again, ending with the same result. When it reboots and I log in via chrome it is back on the safe mode screen, prompting me to upload firmware.

First off, I sincerely appreciate your help and time on this, and when you decide its toast, I will accept that. I will do what ever you ask in performing tasks on this. Depending on what they are, I will need direction. As for taking time, your helping me, and I respect you will attempt to work on it if and when you have time.

Thanks again. Bruce

It didnt work. when i try to login to the pr4100 it goes to the safe mode screen. I then tried to update the firmware again and this time when I start the firmware update I get 4 of the spinning indicators with no counter and it hangs forever. When I just tried to go back in an run the ssh process again, on trying to enter ssh i get a warning that the verification has changed and a possible man in the middle attack. I also notice that the pr4100 is no showing in my asus router connection list as 2 connections to the client and although i still use the same IP when i try to log in to the pr4100, the asus router is showing a different IP address for the pr4100.
I need to add, when I was typing in the e2fsck lines i made a mistake, which the system informed, so I retyped the line correctly and kept going. With the exception of that, the ssh process seemed to go as you indicated. After completing the process per the info on using ssh I was following from a website, I closed the powershell window to exit ssh.
If I screwed it up, let me know. I have no idea where to go from here.
Thanks

Yes I do, I’m guessing it would only be temporary.

sorry for the delay in performing this next step. How do I know if it’s doing anything? I had the usb plugged in with the drive for an hour and the power light was flashing blue, the hard drive light was solid, the fan was still running at full speed. When I started the process with the power button the pr4100 was connected to the router. After the hour, although I thought the drive was empty, I powered it down, formatted the drive, and started the process again. I think the pr4100 was connected to the router, except it isn’t showing as connected now, its been 50 minutes again. I checked my download speed and it is 40MB. When I extracted the Pr4100 zip file to the usb stick the only file that asked to over write was the grub.cfg. There are other directories on the drive. Was I supposed to extract all of the files into the root directory on the usb, or just start it in the main directory and let it keep the directory structure?
Thanks

When I put the original usb stick back in and boot the system, the router shows the connection again.

So I created a new usb stick for this process, this one has an led. when I first power the system on , the hard drive lights are all red, the usb light starts to flash, and the power button led is flashing. The led light changes to blinking blue like its reading or writing eventually going solid. And the router connection drops. The preseed.cfg.safe file name was changed as I deleted off the .safe from it. When extracted the pr4100 zip file that I downloaded from the link the grub.cfg was overwritten. There is a prx directory that was added. All sub directories from the pr4100 zip appear to be present as sub directories on the usb stick. Based on your last comment, my problem would appear to be linked to the connection to the router dropping and not reconnecting. The led on the usb drive stays solid, the hard drive light stays solid, the power button led continues to blink blue.

the led hard drive light changes to blinking blue eventually going solid. left off hard drive.

I tried working again with it last night and again this morning. Originally no success. An hour ago I tried the various usb sticks I had created to see if each still provided that same results, or what each would do now. Not sure why, but I did the 2nd stick, usb rescue last. When I got to the safe mode page, I selected the firmware update file and it completed successfully. I don’t know what was different that it worked this time. I had also tried it yesterday without success, no idea why it worked today. The only difference I can think of was that I had one drive in the first slot today, instead of 2 drives, or none.

So thanks, thanks, thanks, for getting me this far with the system operational again.

My shares are gone which I would expect since the drives were wiped. The users are still present, and so are my settings from what I have looked.

Now a couple of questions. I can access it on the static IP address I have it set for. The router still shows a 2 in a circle for connections and when I hover the cursor over the 2in the circle, I see a note “2 clients are connecting to RT-AC86u through this device”. However the IP address shown for the 2 connections is different than the static IP address. The dashboard is accessible by the static IP address. The PR4100 is not showing on my computer network.

Why is it showing 2 connections, is that causing my issue with the pr4100 not being available to users to see on my computer network? How do I get it back to one connection to the router and is that causing my problem? The 2 in the circle started showing after I connected to the pr4100 using ssh with the 3rd usb stick, debian 9 netinst iso.

To insure a clean start and nothing garbled, would you suggest a system restore?
How do I get back to only 1 connection to the router that provides access for computers on my network?

Thanks Again.
Bruce

Thanks

Im documenting the process of what was done from start to finish in case I have it happen again. I see that your first link or direction on how to see if the pr4100 would still boot has been deleted. Can I ask for you to send it again so I have the info and process.

Thanks again,
Bruce

I got it, thanks again.
Bruce