PR4100 firmware update stuck at 99%

I purchased a new PR4100 two days ago. The front USB drive auto upload feature wasn’t working. I tried upgrading to the latest firmware - but it got stuck at 99%

So I can not upgrade the firmware - and the USB application is also not available in the apps. Due to which I can not use the auto upload feature for USBs.

Support hasn’t been able to find solution for past two days. So I thought I should check with others on the forum - to see if they have encountered similar issued and how were these resolved.

Thanks for your help

Do you know the current firmware version, the version of the firmware prior to the update attempt? A 40 second reset may help. Otherwise, more advanced methods may be required.

Thanks for your reply DXA.

Current firmware in the drive is : 5.11.112

Latest firmware on website is: 5.25.124

After remaining stuck for more than 10 seconds, it issues the error: “Download failed”

PS: I’ve tried doing manual download and do manual update as well. But it issues the error: “Firmware file not found. Please try again”

And the support made me do the 40 second reset. It didn’t work. The only difference now is that when I try to do the update, it stays stuck at 99% but then issues an error after around 15 minutes that download has failed. (earlier, it remained stuck at 99% for much longer)

It should be easy enough to fix. Are you comfortable with enabling SSH and using basic Linux commands?

Thanks DXA. I wouldn’t’ be comfortable due to security concerns.
Thank you for your help!

As a last resort, you can try re-uploading the existing 5.11.112 firmware to see if it works. Sometimes files in the config partition can become corrupted and re-uploading the existing firmware may fix it, thus allowing further updates to succeed.

If the first step is successful, you can then try uploading the latest firmware again.

If the first step is successful, but updating to the latest firmware version fails, incremental firmware updates may be required to reach the latest firmware version.

Otherwise, you’re stuck because using SSH and basic Linux commands is the ONLY remaining way to fix your problem.

I once had the same problem and a manual firmware update did the trick.

Saw this post and have had the same issue. But here is the fix YMMV this worked for me.
Current firmware in the drive is : 5.11.112 and would get the dreaded stuck at 99% Manual upgrade gave the message firmware file not found.

Rebooted the device and upgraded to this;

Then proceeded to upgrade manually to 5.25.124


Thanks! Worked like a charm :slight_smile:

1 Like

Here is the article to that explain the workaround.

I have the same problem.

I purchased a WD PR4100 from the WD online store. The firmware was version 5.11.112. Attempting to update from the home screen stops at 99%. Attempting to update from a file always ends with “Firmware update failed”.

After reading this thread I tried:

  1. Uploading the firmware from the file 5.11.112 - OK
  2. Retry update to the latest version - fail
  3. Uploading the next firmware 5.12.108 - OK
  4. Upload 5.13.115 - OK
  5. Upload 5.14.105 - fail
  6. Attempt to upload more from the file - all fail

I noticed that the files up to version 5.13.115 are less than 200MB, the next ones are over, maybe it has something to do with it?


I installed a new HDD, re-partitioned and formatted the drive. This allowed me to upgrade to 5.15 and later to 5.16, but subsequent versions would not install. Then I did a 40 second reset, this allowed me to upgrade to 5.17 and then to the latest 5.26.


Howdy. I have tried manually updating several higher and lower firmwares, reboots, hd raid rebuilds and it will not update to anything. I am at 5.14.105.
It always errors out saying Firmware not found.
Right now I tried the download again and it goes to 99% over and over again.
If I try manually it downloads anywhere from 5% to 10% then shows installing at (0%) then just shows (%) and gives me the Firmware Not Found error. uhg

Sooo if you don’t mind, can you post the SSH stuff and commands I need to runs I can update this thing? I use another nas that does have the current 5.26.119 firmware on it and I need this one to work so I can use the backups on it.

p.s. I have also already tried the WD workaround with that 5.17.107 with the same results, Firmware Not Found.

Thanks so much in advance!