PR2100 no longer visible on Network. Can't access

I have been using my PR2100 without fail for about a year now. Yesterday, after losing internet connection in the house and once the internet came back, I can no longer access it. It’s no longer visible on my network. I had the PR2100 directly connected to my AT&T gateway which is an Arris BGW210-700. I have multiple computers and devices connected to my home network and only the PR2100 is giving me issues. The PR2100 seems to boot up fine. Solid blue light on the power button. The really strange part is it appears something is accessing it. The lights on the ethernet port are blink. The drive lights are blinking like they’re being accessed. The HDDs are making that sound they make when they’re being accessed. But I can’t see it on the network, from any computer. If I try to access via mycloud.com, it says it’s offline.

Items I’ve tried.

  1. Rebooted the PR2100 multiple times.
  2. Rebooted the Arris gateway multiple times.
  3. Swapped out the network cable, tried different ports on the Arris gateway
  4. Tried plugging into a Netgear 8 port switch (which I have after the Gateway). Tried Plugging into a Netgear router in my home office that I use as an access point (switch). Everything else connected to any of the switches are fine.
  5. Tried the 4 second reset. Tried the 40 Second reset.
  6. Tried to go through the set up process again. (mycloud.com/setup)
  7. Viewed the devices from the admin portal on the Gateway. Ran an IP scanner on my entire network and the PR2100 does not show up anywhere. Tried connecting directly to the IP address (that it was connected to previously) - nothing.
  8. tried accessing from various different computers, my phone, via plex, etc. nothing sees it.
  9. Spent at least 5 hours searching the interwebs for any solution.
  10. I’ve tried everything I can think of short of burning sage and doing an exorcist.

As I initially mentioned, this seems to have happened after I lost internet, but that is just when I first noticed, it’s possible I lost connection prior.

A couple of questions for anyone who might have suggestions.
a. Is it possible to direct connect to it?
b. Is it possible to update the firmware via a USB flash drive?
c. If it’s bricked (which I have a hard time believing it is). How do I get the info off the drives. I’m running two 8TB WD Red Pro NAS HDDs in Raid1 probably 25% full.

Any Suggestions? Thanks,
Nick

Yes using the local computers Ethernet Port

https://support-en.wd.com/app/answers/detail/a_id/16312