Power led is solid red - Firmware 2.10.302

Hey Guys,

I just updated my firmware, related or not, my power led is solid red.

I tried to reboot device, after reboot led was solid blue, but 2 min after, it turned solid red again.

I have performed disk test, all pass success, the only “extreme” situation I have is that one of the disks which is 2Tb size, has “only” 100Gb of free space, but that is not new.

Any idea…? I couldn’t find any reference in the documents or the web on solid red led (there are blinking blue, yellow, even blinking red, but never solid).


Goldschmidt, Shay.


We have passed this along to support.


Hey There,

Thank you for your quick reply and help.

Any idea what is the SLA of support team?

Any other ideas what could that be…?  :cry:


I have a same problem with my : MyCloud Mirror 6TB but i don’t have same problem with MyCloud Mirror 8TB

Same Firmware in same models, very strange.

Hope and waiting a solution from WD.

bye, Start.


What are the type of drives? Was one of the drives previously replaced? How long has it worked in this configuration?

“Updated my firmware, related or not, my power led is solid red”. Isn’t that pretty conclusive that the update did cause the problem?

Have you investigated manually “updating” the firmware to the previous version that you were happy with e.g. 1.05.36 - it’s also the version listed on the WD website for download. See Settings, Firmware Update, Manual Update (Update from File).

I have used the current 2.10.302 firmware, the previous one 1.05.36 and the previous version without any problems (n, n-1 and n-2).

Hi to everyone.
It’s interesting, I have the same problem with 6TB version.
I wrote in this topic: http://community.wdc.com/t5/My-Cloud-EX2/Firmware-2-10-302-Observations/td-p/904096

I’ve never removed discs from the device from the moment of its installation. I use WD Red drives. But one HDD is older than other for about 1 year. This is because I already had one 3 TB WD Red drive when I decided to buy My Cloud EX2. So I purchased My Cloud without HDDs and one more 3 TB Red drive.

FWIW - I bought my WD EX2 with 2 WD red 4TB drives pre-installed.  My unit is working fine in raid 1 mode with the new firmware.  Having said that, the top front LED now stays on and does a slow blink even when the drives are asleep.  (The drive LEDS turn off when they are sleeping)  So it IS different than the old firmware, of course none of this explains why you guys are seeing a red led.  Hopefully WD will fix that since a red led is universally known as an error condition.


Hey There,

I have same disks last 14 months in my trays:  2TB black caviar, and 3Tb “regular” WDC.

Power Led was always solid blue… till the upgrade…




Having exactly the same issue on my 8tb Ex2 which is about 6 months old since latest firmware update

Have run system test etc. and all reports as OK. Tried the turning on the Flash System LED and now get a flashing blue power light.

is this affecting the actual running of the drive? 

or is it just the colour is red instead of blue?

Two drives with 2TB and has about 100GB free. That’s about 5% free on the 2TB drive which is nearly “full”. new firmware is using output of df command to determine that more than 95% full is (incorrectly) an error condition.

So what does it mean? I can’t use last 150 GB (in case of 3TB drives) of free space, if i don’t want to see a red light? It’s ridiculous, 150GB is a huge amount of information, it’s about 10 movies in HD quality. If it’s a new function - it is a bad function. As it was said before, red light usually means that something is wrong. Less then 95% of free space is not “something wrong”. Also i’ve never seen a red light on a previous versions, even if i have no free space at all.
And all this does not explain another problem - that disk LEDs doesn’t switch off.
I think that power management of EX2 doesn’t work at all now. WD Red (and Green) drives have their own power management function - IntelliPower. And now they turn to sleep mode by their own controller. I don’t know about Seagate, i don’t use these drives.

The good about the new firmware: It is significantly better/quicker at indexing and “slinging/serving” files on demand in the apps and on the network. Photos populate almost instantaneously.

The bad about the new firmware: When the unit tries to sleep, the power light does the standard glowing fade in and fade out but both drive lights remain solid blue and do not go out as in the previous version of the firmware. I currently have two EX2 units and both do the same while sleeping. Are the drives not going to sleep but the processor is?


Seems all is working,but i have no clue what to expect due to the red light which usually implies on critical situation…

BeeHaven ,

As i wrote in previous message, WD Red drives have their own power management. So they will go to sleep even if EX2 processor didn’t give them a command. Of course if this function is not disabled by the manufacturer for preinstalled drives. Also you can hear, are the HDDs now spinning, or not.

Did the red LED on get resolved by moving data between drives?

The behaviour of the blue LEDs seems to match the description in the manual:

  1. Power LED is on (blue) if the “Device is in a power up (on) state” and off only if the “Drive in standby/sleep mode”
  2. HDD LED is on (Blue) if “Drive is present but there is no activity” and off only if “Drive is not present”

All the WD pictures show a box with three blue LEDs on and the implication that three blue LEDs on is “good” and a blinking blue LED means activity e.g. not a good time to unplug it.

I much prefer the LED = OFF setting. If there is a real drive fault then the red LED should come on regardless of this setting.


My drives are in RAID 1 mode, so amount of data on them is the same. Now I have no ability to move data somewhere.
May be Shaygo (topic starter) will try to do it.

Yes, the behavior of the drive LEDs on the new firmware really matches the description in the owners manual. But on the previous version it was not as now. In addition the user manual was written in 2014 and it doesn’t seems to be changed since that time.
On the previous version when any drive goes to sleep mode, its LED turns off. When both drives go to sleep, power LED starts slowly flashing (like breathing).
Also on previous version drives went to sleep when there is no activity for about 10 minutes. On the new firmware drives go to sleep after a long time, about 30 minutes, and this time is very similar to the time that is set in the IntelliPower controllers of disks.

It is interesting, I recently received an e-mail message from WD tech support from my country. It is interesting because I didn’t ask them for help. They asked me to describe the problem in details. So i did it and will wait for the answer, perhaps they will provide some more information on this issue.

Now I manually installed a previous version 1.05.36, and everything is working as it was before.

100% agree with Felix.

I have the 8TB vdrsion in RAID 1 mode, so 4TB, which I assigned them all to a unique iSCSI volume. With the old firmware it was alright, now with the new one the system thinks that the disk is full and it reports a warning on the logs, but on windows I can see I still have more than 1 TB free space on the volume. I 

I’m also downgrading to 1.05.36, and I’l remain there for a long while, I think.

Hello there,

With the latest firmware update to the My Cloud drive we have enhanced the reporting of error codes. LED behavior has changed to pulse blue when EX2 goes on standby mode (Sleep mode) and also to show solid red LED when there is attention required (such as Ethernet cable not connected). We are in the process of creating a Knowledge Base Article to address this change and I will add it to this post as soon as it goes live. Sorry for any confusion.

Need Help? Please click below for further assistance or contact us at 1(855) 556-5117

Hey Folks,

Here are a couple of Knowledgebase Articles that may help explain the led light functions.  

The front LED on a My Cloud Mirror or My Cloud EX2 displays solid red

The front LED on a My Cloud Mirror or My Cloud EX2 remains solid blue