Phone connects to My Cloud but PC does not

Hello everyone.

After moving and switching ISP’s I’m having trouble connecting my Windows 10 PC to my My Cloud on mycloud.com. My Android phone connects no problem with the My Cloud OS 3 app.

My new ISP is Verizon Fios and I have the My Cloud connected directly to the modem/router. I can access the Dashboard and I tried updating the firmware but it says I’m up to date (v.04.05.00-342). Remote access is on, and the connection status says Connected (port forwarding connection established). UPnP is also enabled on my router.

However when I login to mycloud.com I can’t connect to the My Cloud, it says it is offline. If I click the link to accept my devices security certificate I get a page can’t be reached error.

I used to be able to access the My Cloud in my browser but now I can’t. And I can access it with no problems on my phone.

Please help!

Eric

found a post that says manually setting the My Cloud and Router to 9080 and 9443 ports solves the problem … at least for the person in the last post in this link below

Thank you for linking this, I got it to connect! Although my method was a little different.

There are port forwarding settings in both the Advanced area and Firewall wall area for my router. In the Advanced area, I kept the protocols for HTTP/HTTPS at the defaults of 80 and 443. I then went to the Firewall area and added specific rules for the My Cloud HTTP TCP Any -> 80 and HTTPS TCP Any -> 443. I also turned off UPnP someone said to do in the link.

On the My Cloud end, I kept the Remote Access setting as automatic. The Connection Status now reads Connected (Relay connection established) which means it can’t open the ports. However I can now connect to my My Cloud through mycloud.com.

So something isn’t quite right. Maybe I need to change the protocol to something else like 9080/9443 like the person in the linked thread.

But anyway thank you again.

Many, many people have had this issue since the later versions of Windows 10. It invariably ends up being network settings in windows and/or the router settings (port forwarding). A correctly configures system should give the message “Port forwarding established”. My MyCloud EX2 at my main home has this message. My MyCloud and MyCloud Mirror (same as the EX2) at my second home both have “Relay connection established”.

Go figure!