MyCloud local works, doesn't

Hi there,

I’ve read that there are many problems with the MyCloud drive.
Everything was working fine but suddenly I can’t login through the site.
It said that it’s not connected to the internet, but it is.
Did a reset, unplugged the router and de drive, switched ip’s, port forwarded, changed passwords, made new accounts, updated the firmware but still not solved. And no, I don’t use OpenDNS.
What I noticed was when I reached the drive on the local ip it took ages to load everything on the dashboard.
Even when applying new settings, sometimes it just doesn’t work and I get a pop-up with ‘No internet connection’.

Anyone who can help me? It’s driving me crazy


try this:

Thanks for your reply but unfortunately it didn’t work.
When I created and removed the account I get a pop-up that there’s no internet connection…
Thanks for your help though :slight_smile:
Anybody else with the same problem or a solution?

Are you on a Windows, Apple, Linux etc. PC? What is showing under Settings>Network in the Dashboard? Who is your internet provider?

Have you read through the User Manual for your version of My Cloud? Use link below and scroll down to the links for the User Manuals.

What does the Dashboard Cloud connection status indicate?

Have you tried disabling, then re-enabling Cloud Access?

You need to find out why internet access is not available? What changed in your network to cause the loss of connection? Router reboot? Firmware upgrade?

Has your router go UPnP control eabled? If not (and i don’t; don’t trust it), have you set up port forwarding rules?

1 Like

It said ‘Connection Status No Internet access’.
I think everything changed when it lost the internet-connection when the ISP was working on it.
But we restarted multiple times now, so I don’t know what the problem may be.
I tried to disable the Cloud Access, but I can’t apply it because I get the pop-up that there’s no internet-connection.*****
And I haven’t applied any rules for port forwarding.
I don’t think the PF is the issue…

And we’re all on Windows 10 btw.

*EDIT; I finally succeeded to turn the Remote Access off and on again, but still not working.
(‘Connection Status: No Internet access’.) :frowning:

Ah; that’s new information… What was the ISP doing? Were they doing something to your router? Could they have applied blocks to certain ports? Which brings us to which ports you are using for internet access for the MyCloud: are you using the default ports 80 and 443?

If your MyCloud is connected to your router, and can be accessed locally within your network, then there must be something blocking your MyCloud from accessing the internet. It is likely that this block is provided by your router and ISP.

1 Like

I know for sure nothing big has changed.
The ports I use are indeed 80 and 443.
I can access the cloud LAN, but not WAN…
They can’t just block some ports right…?

Thanks for your help, I’ll contact the ISP if they changed something :slight_smile:

Yes, they can, by a hard configuration of the firewall, depending on the capabilities of the router. It’s not unusual for ISPs to apply such port blocks to protect their customers from common attacks.

If your router has been reset, or had a firmware upgrade, it may have disabled UPnP control of the firewall, and thus removed any port forwarding rules; UPnP control allows the MyCloud to set up the router port forwarding rules it requires to gain internet access. That’s why I asked about this setting earlier.

Manual port forwarding setup is required on the router if you disable UPnP control of the router.

Note that this UPnP router control has nothing to do the the DLNA/UPnP media streaming…

1 Like


After many hours I can say that the problem is solved :grin:
Mycloud is finally functioning as it used to.

The problem why the cloud didn’t connect was the static IP.
Our router provides all devices an IP through DHCP, but when I was looking in de tables it wouldn’t recognize the cloud.
When I cleared all IP’s in the router and set the cloud to DHCP I restarted everything.
And after a few minutes… DONE!

Thank you so much for your efforts!

Kind regards,