Osx 10.10 yosemite - can't see MyCloud

3 pcs and  a mac book on the nw see the new MyCloud HD fine. an imac running Yosemite 10.10 can not see it even with ethernet connection. any ideas on how to fix this? is it because WD My Cloud doesnt support the latest version of OSX? surely not? any help most appreciated folks! HNY!

Hello,

I recommend you contact support directly for assistance with this.

Contact WD

Please let me know if you find a solution to this problem. I am having the same issue. I believe the cause might be the latest firmware (v04.01.02-417). I wasn’t experiencing any issues before I upgraded to this firmware. I am considering reverting back to a previous version.

WD support was of little help. They suggested restoring settings back to factory default on the MyCloud, which did nothing.

Thank you and good luck.

thanks man … WD support online have been as much use as an ashtray on a motorbike. they have no instrictions for connecting to server for yosemite. this is a brand new drive out of the box. works with mac book pro and 2 other dell pcs but not the yosemite imac. if out of the box includes that new problematic firmware - i suspect you’re right. still no joy 4 days in here. thanks  for the response tho. 

dude thanks but i’ve already done that… WD sent me an email which had no instruction for osx 10.10. still cant see the drive. if its a new firmware issue what would you reccomend? the drive is new and right out of the box. works fine on 4 other devices … just not with 10.10

did it work ?? 

I bought My Cloud WD yesterday  and when i try to install on my mac  it can’t find it… 

what can i do !? 

I had the same problem of my Mac not communicating correctly with other wireless devices like My Cloud and my HP wireless printer.  Resetting the WiFi interface helped.  Write down your WiFi router password as you will need it to reconnect after the reset;  Yosemite or Mac OS X 10.10 has WiFi config issues that they are not solving/acknowledging but Reddit has other info to optimize and reset;  here is the WiFi Reset instructions.

Re-Install Wi-Fi Interface

  1. System Preferences -> Network -> “Advanced …” -> [Select All Wi-Fi Networks] -> [Press Minus Button “-”] -> [Apply]
  2. System Preferences -> Network -> “Edit Locations …” [Available From “Location:” Drop-Down] -> [Delete All Locations (not Automatic)]
  3. System Preferences -> Network -> [Select Wi-Fi In Left Panel] -> [Press Minus Button “-”] -> [Apply]
  4. Reboot.
  5. System Preferences -> Network -> [Press Plus Button “+”] -> [Select Wi-Fi From “Interface:” Drop-Down] -> [Name it “Wi-Fi”]
  6. Reboot.
  7. Done  (go back to installing My Cloud and it should be found)

Hi,

i tried like you said… but nothing… still can’t find WD My Cloud… :confused:

any help? 

Tks

Guys did you try go to the Finder… click Go…Concect to Server and write either

smb://nameofthedrive

or

afp://nameofthedrive_._afpovertcp._tcp.local_

or try it with the IP

smb://192.168.1.XX

or

afp://192.168.1.XX

Personally I use SMB because AFP has some problems when my mac get back from sleep… dont know why…