WD My Cloud on OS X El Capitan HELP!

Hello there,
I have read through the threads and noticed there are A LOT of problems with mycloud and El capitan. Has anyone found a way to connect wd my cloud with osx el capitan? i am at my wits end here. I bought this back in August and I cannot for the life of me get it to work. The customer service here is horrible. I had to file 3 claims and send 4 emails before I finally got a response and all they did was send me to the set up page and said if that doesnt work ask the community.

can someone, anyone explain to me how to set up wd mycloud to a mac book pro late 2012 with el capitan? please. im begging you.

thanks guys.

Hello there,

I have El Capitan, and what I have been able to do is mapping the drive manually by going to the connect to server section and this way i am able to access the NAS drives. You can try this, see if it helps you out:

Thank you. I tried that. But for some reason the computer can’t even find the my cloud device. I even tried it with a windows laptop. It’s like it doesn’t exist

Some basics, then.

What is the front panel LED doing? (refer p10 User Manual}
What are the Ethernet port LEDs doing? (refer p11 User Manual)

What IP address has your router allocated to your MyCloud?
Can you connect to the Dashboard by using the IP address? Use:

<IP address>/UI on PC

Thanks man.

The front LED is Solid Blue
The Ethernet is lit up with solid lights for:
Power
Ds
Us
Online
Telph1

“Link” & Telph2 are not lit up

I’m not sure How to figure out what IP address my cloud has been assigned.

All I did was plug it in and connect it to the router. Whenever I search for it it cannot be found. I’m positive its hooked up right and the router works because I had a desktop pc plugged into it for Internet access just last week. Just for the heck of it I tried switching Ethernet cords but nothin doing on that either. I just hooked the my cloud up to my parents windows laptop with the ethernet and it recognized it that way. Or so I thought.

When I connected my cloud to windows laptop via direct Ethernet cord this showed up.

Followed by: my cloud needs a driver update. So I get the driver update and click open and it opens up my windows media player! So I click on "go to product website and it takes me too this:

Now I got something calls twonky on my parents computer and still no access to my cloud on my Mac. This is quite frustrating.

Ryan

Twonky is a good sign; it means that the MyCloud is running, and it has started the Twonky server, and you can communicate with the MyCloud.

There are two media serving settings; one on each Share, and then one to turn on the DLNA server; that’s under Settings|Media|Media Streaming

And, if you open up the ‘Detailed Status’ on that Twonky page, it will tell you the IP and MAC addresses of the MyCloud.

I can’t really see the first image properly.

If you connect the MyCloud to the router, can you see it using your parents’ PC?
Can you see the Twonky page (in a web browser)?
<IP address>:9000
Can you see the MyCloud Dashboard?
<IP address>/UI

You have read the El Capitan threads, haven’t you? And you do know there’s a bug with 10.11.1 that Apple are working on, and that the 10.11.2 beta seems to sort this problem?

And finally, you have read the user manual, haven’t you? Especially p23, about mapping the device into file systems.

If you need to set the device up, and can get to the Dashboard (the MyCloud’s control panel) on your parents’ PC, follow the ‘Mobile Devices’ setup path shown in the ‘Quick Installation Guide’ that was in the MyCloud box. That, combined with the user manual, should help you get it working.

Mac access might have to wait for Apple to sort their bug out: go and complain to them.

Can I get the beta version of el
capitan?

I’ve gone back and forth with WD customer service in the last fortnight. It appears all the WD MyCloud mac users on El Capitan have issues using

  • the WD MyCloud desktop app (when trying to upload and/or access the drive)
  • Merely connecting the to drive through finder

I got the following response today from WD Customer support:

Thank you for your reply.

Could you please try uploading files to the device manually through finder or through www.mycloud.com as there is an issue with the application and our engineers are still working on a fix for the application on Mac OS , I sincerely apologise for this, but now you could also upload them the way I mentioned, try if that works.

If you have any further questions, please reply to this email and we will be happy to assist you further.

They do not appear to know when it’ll be fixed, yet it is on the radar.

I got mine working with elcapitan

I had no problem using el cap other than with the Mac App which stops uploading files at 512k for some reason.
The solution to that problem is to use the web portal on https://idp.mycloud.com/

I also managed to upgrade the firmware remotely from a mac using el cap and all is working fine (apart from the annoying 512k problem).

See the following post for a possible workaround to the Mac 512K upload problem on certain iOS devices. The workaround involves setting the iOS Auto-Lock option to Never before beginning the upload.

https://community.wd.com/t/up-loading-pictures/148114/3