Failed to connect to the device - OSX 10.10.3

Hi all,

I’ve started having an issue with my WD MyCloud 4tb over the last 3 or 4 days, I am unable to connect to the device on my Mac, running OSX Yosemite 10.10.3. I’ve searched for similar issues posted on the board and tried following any and all steps suggested but to no avail.

  • Connecting via Finder: Connection failed
  • Connecting via Finder using ‘Connect As’: ‘There was a problem connecting to the server “Cloud”. The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again’
  • Connecting via WD MyCloud Desktop (Version It finds the device but when I click on it to connect, I get a red ‘Failed to connect to the device’
  • Connecting via WD MyCloud Setup for Mac: It finds the device but is unable to connect
  • Connecting via IP address to the dashboard: This webpage is not available
  • Connecting via http://devicename.local: This webpage is not available

I can connect to the Cloud device via the app on an iPhone 6 (iOS 8.3) as well as on 2 laptops running Windows 7. Everything works fine, I can access all files on it. Issue only seems to be when connecting via Mac. 

Hope someone can shed some light/support. Thanks for your time. 


Welcome to the Community.

Since other devices seem to be working fine then perhaps it would be best to double-check your Mac’s networking settings. A different IP address segment, subnet, or workgroup and isolate it from your network.

I had major issues getting it to work with yosemite. One thing i found in the end was that i had to connect via finder go>connect to server then enter enter smb://mycloudipaddress/public and then choose guest, not registered user.

I also had to update the firmware first and then also found the connection unusable from my imac unless both ethernet and wifi were enabled with ethernet at the top of the list in network preferences.

Also check connection through wifi only to see if that works, then do same with ethernet.  Also worth swapping cables if using ethernet.

Also is the ip address fixed for the my cloud ?

I just fixed what appears to be the same problem tonight. I have Yosemite. A few days ago we had a power cut, and all that you described has happened. My solution was to manually type in the 192.168.100.? addresses in my browser, counting up and down until I chanced upon the right address, at which point the MyCloud webpage connected. I have Port Forwarding set up in my router, but it was still forwarding to the old IP address the MyCloud was looking at before the power cut. What had happened was that MyCloud had restarted and reset to another available free IP address, so now nothing could see it. Once I discovered its current IP address and I could see the drive on a webpage, I changed the Port Forwarding addresses to match. Suddenly everything started working again and all my devices, including Smart phones, could connect. Still doesn’t resolve the MyCloud changing its IP address by itself though, so if anyone knows how to stop that happening, a little script or something, please post it here!

Set it as a staic ip in your router settings assuming its connected to the router ?