Option B: 40 Second Reset (Reset with Power Off)

Hi, I don’t recall setting an administrator account during the initial set up of My Cloud, therefore I need to re-boot, it looks like I am required to do the “Option B: 40 Second Reset (Reset with Power Off)” reboot.

Question - if I do this reboot will I loose all my files on my hard drive ? (photos pictures music etc)

Cheers

Kev

No. See this link if you haven’t done so already:

http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13986

From that link they state the following: “Critical: The following process is Not Data Destructive and will not impact user data on the device.”

Further from that link, the 40 second reset performs the following:

Option B: 40 Second Reset (Reset with Power Off)
The 40 Second Reset, also known as System Only Restore, will reset the following:
•Admin User Name (default = “admin”)
•Admin Password (No password by default)
•Device Name (default = “WDMyCloud”)
•Remove all Users except Admin
•All Share permissions (default = Public)
•Automatic Firmware Update (default = off)
•Network Mode (default = DHCP)
•Remove all Alerts
mycloud.com account association (default = not configured)
•Mobile app account association (default = not configured)
•WD Sync association (default = not configured)
•Backup jobs (default = not configured)
•Safepoint jobs (default = not configured)

This PROCEDURE DOES NOT WORK ON MY CLOUD WITH PC RUNNING WINDOWS 10 OS.

Please note that all caps for a sentence on the internet is the equivalent of shouting.

The procedure linked to above is for the single bay/single drive My Cloud only. If you have a My Cloud Home or multi bay My Cloud model a reset procedure may be different for those devices.

A 40 second reset is performed the following way:

To execute the 40 Second Reset :

  1. Power down the device and remove the power cord from the device
  2. Using a paperclip or narrow tipped pen, press and hold the reset button
  3. While continuing to hold the reset button, reconnect the power cord to the device and continue to hold the reset button for at least 40 seconds
  4. After releasing the reset button the device will reboot

Note: This process may take upwards of 15 minutes. Please wait until the Power LED is solid blue, indicating the device is ready to use.

Typically after a successful 40 second reset one should launch the My Cloud Dashboard and be confronted with either a login screen where they would enter the administrator user name (default is: admin) and a password. The default password is blank (no password). Or one may be confronted with the following screen.

If so, agree to the licensing agreement (click the check box) then click the Continue button to continue to the My Cloud Dashboard.

If one is seeing something different, or is receiving an error message. Post more information about what steps one performed, the specific problem, and a screen capture of the error message.

If one doesn’t know how to access the My Cloud Dashboard, see the following WD Support article.

Hi Bennor,
The use of capitals was deliberate to seek attention as the method you stated, been tried many times on my single bay My cloud device. I also exchanged many emails and telephone discussion with WD technical assistant to resolve the issue. So far no results.
I have been using this my cloud for few years and didn’t have real serious issue in accessing the dashboard until this year. I never reset this device before. When the system failed recognise my password after many attempts, I proceeded with the reset and it didn’t work. This may be due to latest windows 10 update as microsoft keep issuing updates to OS every few weeks or may be faulty reset button.
I also see lot of people on this site complaining on this site and elsewhere with same problem with the whole family of wd cloud hardware.
My view is these hardware are not compatible with the current version of Windows 10.
My cloud works ok to access files using file explorer but I can’t log in to do admin stuff using dashboard.
Swingman

Just so we are on the same page. You are accessing the My Cloud Dashboard using a web browser, correct? Or are you trying to use the My Cloud Desktop program to access the My Cloud? They are two different things.

The My Cloud Desktop program has been End of Life (https://support-en.wd.com/app/answers/detail/a_id/28748/) since 2016 and recent My Cloud firmware updates (last year) generate login errors attempting to access the My Cloud.

If one uses Windows ensure SMB1.0/CIFS is enabled. If it is not enabled one cannot reach the My Cloud using it’s name, instead one has to use the My Cloud’s IP address. Microsoft disables that option in Windows 10 through recent patches or when doing a new install of Windows 10. Once enabled one can reach the My Cloud using it’s name again.

Hi Bennor,
I have all the above. No joy. I have spent many hours reading all the fixes suggested in this web site and elsewhere.
Swingman.

Post a screen shot of the issues you are having. Post a screen shot of the Dashboard error if you are getting an error.

Just saying I have a problem without giving any detail doesn’t help anyone who is trying to assist you with your issue(s). Often people will ignore assisting someone who doesn’t provide any details. Be as detailed as possible. What troubleshooting steps have you tried, exactly. What is the specific error you are receiving?

This is what happen every time I enter password. After resetting the device (40+ sec), I still see my old username no admin. So I don’t get to open the software.
After making following all different workaround, now I can’t access my personal share but I can access Public share. This is new development.
All files are accessible in mycloud.com

Have you tried the user name: admin and leaving the password field blank then hit the login button?

Edit to add: Did a quick test on my first gen single bay My Cloud. Did a 40 second reset as the WD directions posted above indicate.

After waiting for the boot up to complete after the 40 second reset this is the screen that got displayed:

After I checked the “I agree” check box (I left the Participate check box unchecked) and then clicked the Continue button I get the following screen.

Clicking the Cancel button brings up this screen.

Clicking on the OK button brings me to the Home tab screen of the first gen v4.x single bay My Cloud. When I click on the User tab the following screen is displayed.

All previous user accounts other than Admin are gone (per the 40 second reset). However any prior account Shares are still present. The administrator password option is set to off. Which means one should not be presented with a login screen when attempting to access the My Cloud Dashboard when they attempt to access it again (after closing the browser). Once the password option is enabled (and one enters a password) for the admin User then one will be required to log into the My Cloud Dashboard with the admin user name and it’s password.

Yes I have tried admin with no password. Never got past the first screen. It simply shaw the same screen as before with admin in the user name.

Swingman

What specific My Cloud model do you have?

Have you made any changes to the model’s firmware using SSH or adding unofficial modules?

I have a single bay 2TB wd mycloud. I haven’t made any modifications. It is about 5 years old. Worked well with my older Windows PCs running win 7. With windows 10 it had intermittent problems with disappearing network which often required re-boot With changes to 1smb access restrictions this has become even more difficult and repeated resets (but never successfulLY rest wdcloud) and rebooting, now I can only access public shares only from yesterday.
I normally use mycloud as extension to my hard drive; i.e. access data files directly from mycloud by the programs like Excel, Word and photo editing programs.

All I can suggest is keep trying to do a 40 second reset. Make sure to keep pressing down the reset button on the back of the unit when you insert the power plug and keep holding that button down for at least 40 second (I typically do at least 45 seconds), then release the button. Wait upwards of 10 to 15 minutes for the unit to boot and the front LED to turn blue. Then check the My Cloud Dashboard.

Windows 10 has zero effect or impact on resetting the My Cloud using the reset button on the back of the My Cloud enclosure. Only issue with Windows 10 is if it has cached the web page for the My Cloud Dashboard and is showing the user that page rather than the actual Dashboard page of the My Cloud.

My unit doesn’t have a easy rest button. It appears there is some metal strip about 6mm deep. It is not easy to keep pushed down. I have already tried about 20 times! May it is faulty. I also followed other suggestions found on the forum pages such as removing network cables, restarting rooter and reinstalling windows 10. None has worked. If anything I have made it worse. Can you recommend a good nas system at reasonable price which allow full access to windows 10 and programs to use as external drive as well as backup.

Use a paperclip unwound so you have enough to grab. There is a small button that gets depressed in the hole for the reset button. I found putting the unit in my lap with the back side containing the reset button facing up then using a paperclip in one hand and the power cable in the other works the best (for me).

One could always remove the outer plastic covering of the My Cloud enclosure to exact the hard drive and it’s backplane. Then one has easier access to the reset button.

An NAS is not a “external drive”. If you want an “external drive”, buy an external USB hard drive. Devices like the My Cloud are designed differently and function differently than an “external hard drive”. For all its faults the WD line of My Cloud devices (not the My Cloud Home) are good basic NAS devices. There are several other NAS manufacturers (Synology, Qnap for example) but their devices tend to be more expensive due to their better hardware and more robust firmware/feature set. Keep an eye on Black Friday/Cyber Monday sales if you live in the United States. There usually are deals on lower end NAS boxes (both bare units and units with hard drives) in addition to hard drives one can use in bare NAS boxes. Generally what people do is buy a bare NAS box then buy lower cost hard drives like WD Easystore external hard drives (3.5 inch drives) and shuck (remove) the drive from the USB enclosure and put the drive into the NAS box. In the old days (two or three years ago) this was a cheap way to get a WD Red drive which is what comes with My Cloud units. Most Easystore external 3.5 drives tend to be white lable HGST drives these days.

I use Microsoft’s surface pro tablet-pc which comes with smaller ssd drives. As a retired person, I don’t need full function top end nas drives. That is the main reason for choosing this one. Do lot of (hobby) photo editing and so I use this box as my external wireless hd to store and access, a bit slow but perfectly ok for my needs. So my limited use of Excel, Words etc, I tend to save my files directly to this. The periodically I back them to external portable hds. I looked at buying wd mycloud home, but my understanding is that it can not be used to access files for processing.
I live in UK, we also get special BF deals.

Do a forum search for My Cloud Home to find the various complaints about it. It is not the same as a My Cloud line of devices. It uses a different operating system and has different features/options. The general consensus seems to be its a step down from the low end My Cloud line in most cases.

There are various NAS manufacturers that offer low cost NAS devices but typically it means the firmware or operating system on the NAS is not polished or has issues. There are entry level NAS devices from Synology and Qnap but they are limited feature and hardware wise.

Most seem to go from the single bay My Cloud up to the My Cloud EX2 Ultra. Once you enter the Ultra price range there are more NAS options to choose from. Again, if one just wants an external hard drive then USB external hard drives are fine. The main advantage of an NAS is not having to lug it around a home or while traveling, and that it can (in most cases) be accessed remotely.

My wife use it to do normal backup as she uses traditional laptops. My kids do watch movies stored in it on TV connected via wifi. We also backup photos direct from phone. I also use traditional camera and upload files to manipulate photos. When we are out and about we show photos via mobile to friends etc. So normal external hds won’t do.
I saw refurbished by WD in brown sealed box similar to mine in 2,3,4 TB in ebay. WD uk or other major retailers don’t have this. I assume this type is discontinued by WD. Are these refurbished one will work with Windows 10 or I will encounter same issues?
I think my reset button is faulty as the username doesn’t change to admin. Also typing my username as admin also didn’t work.

Hi Bernard,
Hope you had a good thanks giving. I bought another My Cloud, similar to my old one which was refurbished by WD. I managed set that one up after spending few hours as windows 10 was stubborn in accepting the not secure device.
On the heels of of this success, I tried yet another full reset of my old drive. Sots law, it rebooted and managed to get the dashboard working. I have also noticed there are additional shares in the drive, the difference in the name is just the first letter capitalised and the new share has full access rights but nothing in it, where as my original share has everything but no access rights.
In the mean time my web access, i can see both drives and access to all files.
After spending few hours, I have managed to tidy up the access and removed the unwanted share, which required few reboots within the dashboard.
Now web access (mycloud.com) only has the new drive but no old drive.
I checked the dashboard general section and can confirm the remote access is set ON for both drives.
Any idea how get web access working for both again?
Thanks
Swingman