General Feedback - WD My Cloud OS 3 Operating Software

WD would like to invite the My Cloud users to share their experiences with the new My Cloud OS 3 operating software.

Some general feedback ideas:

  • Look and feel of the new user interface
  • Dashboard and drive functionality
  • Remote access functionality

Please post your feedback in this thread.

it looks white…

Looks broken I have tried reseting it many times and get nothing but errors on the dashboard.

I do not see anything different on my DL4100 other than perhaps the power schedule and MYCloud connects now

Oh yea, the WD2Go app does not work on a Windows 10 phone.  Shows the device, shows the shares, then says No network available

          wd2go.png

2 Likes

My experience has been very poor.  I can live with a slightly more sluggish Dashboard, but I can’t live with the fact that NAS to USB backups hang.  I thought they were just going very slow due to making multiple copies of many files (appended _1 and _2), but the drives don’t appear to be transferring data (after 18 hours) even though Dashboard says it is still backing up.  I have tried to cancel the backups but the progress thermometer just keeps spinning (30 minutes now).

I have relayed this to Level 2 support and will likely revert to the previous firmware.  I had similar, though worse, issues when I upgraded my original My Cloud from v3.x to v4.x firmware.

looks nice and clean… but

I selected the root of my shares to backup my iphone photos because there wasn’t any create new folder to store my photos in… and all the photos of my iphone ended up in the root of my shares, but the interesting thing is, I don’t see all the photos  in my apple mapped drive, unless I move them into sub folder using ssh, mkdir photos, mv IMG*.* photos.

So quirky…

Look & feel of the Dashboard? As Ralphael says; it’s white. That’s the only tangible difference. Oh, and the ‘swipe’ page changes. meh.

Dashboard function? Only real change I’ve noticed is the ability to exclude USB from cloud access; other stuff has been moved to home page (usage breakdown, shutdown/reboot).  Even the button mouse focus bugs are the same. I don’t care about cosmetics, provided they don’t obscure the function.

Remote access? MyCloud app seems to work much as it did before, the little I’ve used it.

Removal of remote disk mount: bad.

Removal of Windows Mobile app support: bad.

As absane says, and I noted on the -303 release, it’s obvious from the image size that a lot of tidying has gone on. Security improvements? Yes, that’s good, but that really ought to be SOP, and nothing to shout about.

Twonky still breaks.

Still can’t disable thumbnailing.

Still can’t add apps.

Still can’t set share size quotas.

Still can’t access the Mirror-like admin tools.

http://community.wd.com/t5/My-Cloud/New-Firmware/m-p/902772#M41170

2 Likes

Since a little positive feedback can go a long way…

  • update went well.   quick and seemless
  • UI is faster
  • cloud stuff, new IOS and android apps and WD Sync working well.  WD Sync - nice touch.  Got to turn off some other stuff.
  • overall, performance is better
  • Safepoint working perfectly.   First full backup and daily automatic without error in 2-3 weeks.
  • local and remote access working well.
  • email notificaiton working

Still needs work on…

  • not sure sleep is working.   seems not.
  • would really love to see the network, cpu utilization etc display from MyCloud Mirror ported back to standard MyCloud.  I can accept no “apps” function due to CPU limitations but really…utilization display?   As a former network guy, so uselful.   (Think of me when beta candidates are being considered)
  • capacity display is partly correct.   individual catgories values displayed seem correct, free space is displaying total space.   No biggie but puzzling. 

Not using Twonky since I have a PLEX/Ubuntu server that just does a better job.   Store all the content from MyCLoud, pushes to all my media devices.   Roku, Smart TV etc… 

tim/waldo

1 Like

cpt_paranoia says it all…

you know… seriously… I really don’t know what to say at times…

First of all this password panel thing is really really confusing as I don’t know if I’m logging into WD’s server to gain access back to my cloud and from the app it asks me which I guess are the user names from my Cloud which results in the password that I assigned on my Cloud. 

The First time I signed onto your server though it ask me for a new username… which then proceeds to create a new share on my Cloud or actually it replaced the top one which then the next time I logged in my Dashboard, it showed me this new username replacing the one that I had originally had on my Dashboard.

Ha… I bet you got a headache just from reading what I wrote… I got a headache trying to describe your idiotic username/password system…

And somewhere admiss all this, I forgot where, but one of your sign-on panels ask me to log on with my email address. Ok I couldn’t, so I had to reset my password… which like all the new password systems I could not use password1234 (just kidding) but they forced me to use capitals mixed with lower case and numerics and symbols which is rediculous because if I want to use 1234 as my password, I should be able to.

I’ll sit back one day and figure which is which, but I think you might want to simplify everything and rather than use usernames in some panels and email addresses in others… just use emails or just use users.

Now the second rant that I got is the backup photos… So yeah the first time around, I selected the root of one of my shares which resulted in all my photos being stored at the root but as I said, I could not see them when I mounted the share on my Mac; not sure how you hid them probably the flag hidden was set.

So I moved the photos and went back to my iphone app to reset the backup directory. I had to do it 3 times because I found the create new folder, then went into the folder to select it (confusing) and it error out on me because I had moved the photos from the last backup and your app is trying to resolve the missing backup photos.

I ended up turning off photo backup… then logged off… then spent 10 minutes trying to log back on using various passwords and usernames (turned out to be the username that I created on my Cloud drive) and then the app prompted me if I wanted to backup my photos and I said yes and this time I noticed the create folder, which I did and it said do you want to use this folder for your backup… and yup… it finally worked. But coming the other way in your settings is confusing after you create a folder then how do you select that folder?

Your system is confusing… it was always like this from day one. 

Since I bought this cloud used, I couldn’t find a way to delete the first user so I just renamed the first user to my name. I thought it was the fact that he had access to shares which is the reason that I couldn’t delete him. Anyways later on in my setup, the first user got overwritten by the cloud setup app, the one that said to create a new user, so I did and it replaced the username that I had on top… so now when I go to select that username from Users, the option to delete him comes up… and I do…

It gives me an error.

Ok so I get it… the first username is the primary user… same with public… you cannot delete either of these resources.

but it not apparent when you are trying to set it up. It is like a undeletable folder and an undeletable username of franky.

I know it is too late to change… but you wanted feedback… this is the feedback…

Oh and by the way… your new Cloud app is able to access my old Cloud with firmware 3.04, so I didn’t have to buy this new cloud after all. So why did you say that for remote access (hmmm I’m guessing this isn’t remote access) that I needed the new firmware…

If it wasn’t for the fact that I managed to buy these little NAS devices for cheap… I would have gone to QNap a long time ago. Yeah I know… I now got two Clouds and it seems that I’m destined to complain on this forum for the next few years.

Great post.

I would ask that the WD Sync tool supported extended attribute “tags” so my Mac document Meta tags would sync.  Currently that feature seems to be missing…(grrrrrr!)

I like the new dashboard some speed improvements and usasability seems to be a bit elevated.

Hope to see much more 3rd party app development with the new SDK framework.  Specifically “ownCloud”

It hosed my device.

I can access via the right pane of Windows Explorer where prior to the ‘upgrade’, I could access via the NAS name under Network in left-hand pane. Once I double-click the icon within the Storage category in right-hand pane, the IP address appears under Network in left-hand pane.

HDD LED lights are continously blinking. LCD error message depends on which power supply I plug into on the back of the unit. I either have ‘power supply 1 failed’ or, ‘power supply 2 failed’.

Unit is slow to respond. Unable to access admin page using IE or Firefox browser. I get to logon page but it does not respond once password is entered. It is like the password you typed is just dumped and no trigger is flipped on.

I’m considering pulling all HDDs, replacing them with new ones, and slowly trying to rebuild all data files by pulling one of the new ones and inserting an old one - one at a time. I don’t know anything else to try because I can’t use a NAS that has no admin access/tools.

Oh, I hate the white of the new GUI…the black was better…and, yes, I’ve been in a couple of times. I just can’t get in anymore. And, the WD app for accessing is almost useless…but, it works…go figure.

Capacity display is not correct with remote access turned off, individual catgories values are not displayed - all files are in “other” category. It comes back OK again when you turn remote access on.

The drive does not go to sleep as It used to with remote access turned off.“No sleep” issue in my opinion is caused by lots of errors in user.log entered by restsdk-serverd process.

Update works fine.

Positive:

Android Tablet App works fine.

White theme is ok.

Negative:

  • Wd2Go App for my Windows Phone 8.1 is not working anymore. I’m really dissapointed about this and I’m in touch with the WD Support about this.

  • LED Lights do net get off.

  • I can’t add my e-mailadress to my users. I’m getting error 400235. Im in touch with the WD Support about this.

  • Running a Full Scan with WD Anti Virus made my device nearly unresponsive for about 1,5 days. This should run more in the backround.

  • Cloud Backups to German/European providers (f.e. Acronis, Telekom) are still not possible.  Also It is not possible to use the  Amazon S3 site in Frankfurt. Only Ireland is provided. For us europeans this is really a important thing. Alreaday yesterday the european court said that “safe harbor” agreement with the US is not gulity

  • USB Backup still only reports faild but does not show what failed exactly. There should be log.

  • When I still use the function "Requesting Automatic Support " nothing happens after sending data. How will WD get in contact with me.

2 Likes

Hello @Bill_S.  You asked.  In no particular order.

  • The white UI background is not easy on the eyes.  For people who need high contract on the screen, it failed this. Use the WCAG contract checker which is used to determine how color-blind people will see the site. There ara a LOT of faults flagged up with the NAS’s UI. It’s very unfriendly to partially sighted and color-blind individuals.
  • The vertical scroll bars on the U are way to thin.
  • The file and folder selection dialogues on the UI are a pain to use. Really…  A major pain. Actually uncomforeable to use and not intuitive.
  • There is an LCD on the DL4100 that could be utilised a lot more, like showing when app updates are availavble, being one example.
  • I’ve never managed to properly determine how groups work when managing users as as so I’m avoiding using this one feature. Whoever wrote the manual to the DL?100 and EX?100 think we are mind readers so have omitted a comprehensive descriptuion of how group permissions are applied to users.
  • The power scheduler will shutdown the NAS, but won’t turn it back on at the nominated switch-on time.
  • The port forwarding option’s existance in the firmware is confusing so I’ve also not used that.  It’s a NAS. It’s not a router.
  • It would be nice if when the Web File Viewer app didn’t tie up the UI while it’s copying or moving files.  Maybe a message can be shown on the LCD and a notification shown when a file operation is complete?
  • There does not seem to be an apparent way to recover full functionality of the NAS if the UI fails.
  • If after an unexpected shutdown the NAS starts and begins a file system check, at least for a message to be shown on the LCD to tell the NAS’s owner/manager that a file-system check is in progress.  If this happens it appears like the NAS has hung with the drives being really busy.
  • The UI is keyboard unfriendly.

:wink:

2 Likes

I’m new to the My Cloud thing, and it turns out that the day I bough my NAS, and in the minutes I was setting it up, WD2GO got shut down, right after I signed up.

So I waited patiently for about a month until OS 3 and mycloud.com were functional.  So far, I like the experience. What I’m struggling with is WD Sync.  Great in theory, not great in practice.

Note that folders I’m syncing both exist locally and already on the NAS before WD Sync implemented.

Here are my issues:

Constantly get “Unable to Sync” “will try again later” messages in the log (which by the way is a terrible log, showing only 1 item that has failed)

The worst of all is the duplication of files both locally and on the NAS.  For example, If I have a picture at c:\users\myname\desktop\picture.jpg WD Sync will duplicate so that picture.jpg is in both places, but so is a copy that is named picture-2015-02-07-random-numbers.jpg in both places! Not happy about this.

If I could suggest a future implementation for WD Sync, would be the ability to choose folders to ignore.  For example, selecting Documents for syncing, but ignore certain folder(s) within that Documents folder.

Thanks for your time.

REMOTE ACCESS

:smiley: The functionality of the WebApp is greatly improved. Lets me think of a MyClouc Mirror’s Web File Viewer app

:smiley::smiley:  Compatibility greatly increased:First time I can work productively with My Cloud from a Chromebook 

:cry: The new WebApp has no feature anymore to map shares in the Win Explorer/Mac Finder/ Linux kFM since WD said goodbye to Java (except for the capcha when asking for a new pssword in the portall). Please  re-enable this feature as several MyCloud owners really rely on this. The WD MyCloud Desktop app instead of the Webapp would be a good place for this.

DASHBOARD

:smiley: Controls look familiar. Now Look and Feel of a MyPassport Wireless.

:neutral_face: Timestamp of notifications a little weird. Just restarted the MyCloud and found:

:smiley::wink:The Dashboard’s jQuery Script basically didn’t change, so I could in no time patch my color code in, as I do after every Firmware update for the last 16 months. When the drive is empty, capacity is shown in green, when it’s fulll in red and in between in shades of green/yellow/orange:

:wink: This looked far beter on a black background, but the new dashboard also shows the capacity usage ring around the free space indicator.

Keep up the good work 

Mike Loud

I’m a general user who simply wants to be able to easily backup my various devices and serve our media (pictures/movies etc).  Since this update things have gotten significantly WORSE.  This device has always been slow to what I would expect out of a modern day NAS but it worked relatively OK.  

The looks and feel is fine but functionality has suffered. 

So far I’ve only attempted to access and interact with the Dashboard (black icon) and the My Cloud (white icon) on a Mac Air.  Some of our other devices are PCs so I’ll have to check those tomorrow.

If I click the My Cloud alias it opens up about 5 different windows prior to opening the My Cloud client which looks like it has not changed.  THe extra windows are finder windows opening each of the various top level folders we have like pictures, music, public etc.  

Everything about interacting with the My Cloud Mirror is now significantly slower.  If I try to use a Mac finder window to access pictures folder it has gone from painful to unusable.  Sometimes 5-10minutes to show a folder that has one #&^$ picture in it!   Copying is still about 4mb/s so no change there.  THis is using the default AFP.  SMB might be worse now, completely unusable.  Sometimes searches just time out now. 

It appears you’ve managed to mess up the Camera Backup from the Backup tab on Dashboard.  It now creates an entirely new directory structure within my PIctures folder instead of dumping dated folders.  The new folder is the name of the camera and it’s super long : Canon Inc. Canon EOS REBEL T3i_00.0    THe dated folder are in there but since I’m using a Mac there’s no easy way to merge the folders.  There’s no reason to break up pictures by the device that took them so please fix this ASAP.  Fortunately I was smart enough to not delete the original copy of photos so I can copy again AFTER you fix this.  

The WD My Cloud app for mac is also displaying v 0.0.0 so is that normal, I seem to recall it had a version number.

I do really like the new pie chart, that’s nice.  

I’ll try my PC tomorrow and see if it is any better and edit this post accordingly.  I don’t expect performance to be A+ given I’m using Wifi but I don’t expect it to get worse after the update.  

So far, time machine backup seems to be working - somehow it manages to find the disc a LOT faster than the finder window would!

An Update…

  The mystery of the Capacity value showing amount “in error” is resolved.   I have a 3Tb My Cloud with a 3Tb USB drive attached.  I use the USB drive for safepoints and other non critical stuff.   I have set the USB Sharable switch “ON”.   The MyCLoud is calculating the total amount of free space (internal AND USB) and displaying that value.   If I set USB Shareable = off, correct (for internal drive only) free space is shown.  

   In retrospect, I think showing total free space is a good thing so that issue withdrawn.  Still love to have the netwrok monitor window on teh dashboard though.  

tim/waldo

User Interface:

Personally I hate this white look. There is nothing “clean” about it. It just looks plain, boring and, frankly, unpleasant on the eyes. Much prefered the dark scheme.

It seems “clunky” in terms of performance. Things take too long to happen and sometimes just don’t happen properly, like not all the items appearing unless you select something else then come back again (like a bad web page). When Dropbox is installed in the Apps it takes AGES (20 seconds) for that to appear in the list of apps after I’ve clicked on Apps. I don’t mean to appear after installing it, I mean when it has been installed for several days. I login to the dashboard, click on Apps and it is like watching paint dry waiting for Dropbox to finally appear in the list of installed apps.

As someone else said, scroll bars should be BARS, not thin lines that are difficult to get the pointer over properly. Their lack of substance, coupled with the poor colour scheme, makes it hard to notice sometimes that they are actually even there! Take a look at the scroll bars on this forum when entering a post for comparison.

Why does the breakdown of capacity usage on the home page of the dashboard only differentiate into file types if Cloud access is enabled and working? If disabled it just shows a bland how much space is occupied with no graphic chart. If enabled but it can’t see the internet properly (it can’t configure the router) you get the graphic chart (circle) but the figures for the various file types are all 0 and everything is just lumped together under “other”?

Why no Daylight Saving option under Language and Clock?

Why no ability to configure the period of inactivity before the drives go to sleep?

Why has the report on fan functioning been moved from under Storage, Disk Status to Settings, Utilities and then having to click on System Test and wait. Even then all you get is OK. How about putting it back in Disk Status and it reporting the actual fan SPEED in RPM?

Why no proper control over the fan such as setting fan speed/temperature thresholds?

In Remote backups, why can’t the SSH login name be changed when trying to configure a remote backup to a NAS Server (as opposed to another My Cloud)?

General Performance/Functionality:

I’m still getting used to mine but why does it seem to take ages when first browsing my EX2 (either from Explorer under Network or even “net view” in a command promtp) before anything actually shows. The same when trying to map a drive.

I’ve a Seagate Central which is lighting fast in comparison - it is let down by being dire in almost every other way. Yes I’ve done all the bits of setting the four services to automatic (DHCP Client which is anyway, NET TCP Port Sharing/SSDP Discovery/UPnP Device Host which aren’t), but why should I need to? Almost no other device seems to demand these services be set to automatic. My Seagate Central doesn’t need it and it is blindingly fast in comparison both on first and subsequent browsing and drive mapping. Proper servers certainly don’t such as my ancient Centos 6.6 and SBS 2003 boxes

Once it finally decides to tell me what shares it has it seems quite a bit faster, but waiting 15+ seconds to see initially (or map a drive afterwards) is WAY too long. This has NOTHING to do with gigabit ethernet either. If it NEEDS to be on gigabit ethernet to give decent performance then something is seriously wrong. I get very much faster response in comparison browsing/mapping to the shares on a 450MHz PC running XP when it is connected via 10Mb!

Fix the non-sensical drive LED thing when it is in sleep mode. Most every other device in the world shuts almost all it’s lights OFF in sleep mode. So did the EX2 until FW 2.10.302. Silly change that one.

Nice to see the option of doing a remote backup to another NAS Server which is NOT a My Cloud has been added - but how the **bleep** are you supposed to make it work?

Other Comments:

Where is the updated manual? All the links on the WD website only give the OLD manual.

1 Like

I have two MyCloud Mirrors running side by side. One is 3+3 GB the other is 4+4 GB.

  • General

The upgrade came as a complete surprise with no warning or advance information. Maybe I dind’t look i the right place. But even after it came (via Auto Update) I could find no mention of it (2.10.302) and it wasn’t even amongst the firmware versions availble for download on the regular WD site. Some documentation (Release notes for example), showing what has changed would be nice to see.

Even now I am unclear. I received new “Firmware” 2.10.302 and the subject here is “OS 3 Operating Software”. Are they the same thing? If so where do we see that stated? If not, then what is the relationship between them?

My first comment on the update was that Auto Update ran with no regard to ongoing processes. I had about 8 backup jobs running and they were all trashed by the update and reboot. I’ve raised this elsewhere and from now on keep Auto Update switched off. This is obviously not caused by the new OS but rather by the old one which was running before the update. But I guess the same behaviour is present in the new one. But hopefully not in the next.

  • Look and feel of the new user interface

The white screen was a shock but easy to get used to. Most interfaces are white now - even this one we are typing on and noone complains about this one. Black reminds too much of old ascii terminal displays.

Also; as noted elsewhere by many there seems to be much confusion about the behaviour of the drive leds. As far as I can make out the documentation manual is ambiguous. Most of us thought that “drive leds off” when idle was good. But another interpretation was that “off” means" not present" and “on-but-not-flashing” means idle. Someone seems to have decided that the previous implementation was faulty and “corrected” it to implement the latter interpretation. This confused most of us who thought it was fine in the first place.

Despite the drive leds new behaviour I’m still happy that the box goes into idle state properly - the top led blinks slowly off then on when idle. 

  • Dashboard and drive functionality

I see one difference is that now the storage usage statistics and current actvity are presented directly on the first screen whereas before they were on a secondary screen after clicking a menu item. I guess this is why the startup screen is slower to appear now. I was happier with the earier approach - faster start and then choose what I wanted to see.

Hiding away the thumbnails was both good and bad. They were a source of irritation previously cluttering up every directory. But now we don’t know where they are and we have no way to see whether they are maintained correctly so as not to waste space. (eg if we delete or move files)

I’ve had both running for about 10 days since last reboot and noticed one issue. The automatic creation of thumnails stopped after some time during the 10 days. This happened on both units so it seems to be a common effect. I rebooted one box remotely and the thumnails started to appear on my remote App as expected. The other had remote access turned off so I had to wait until I was locally connected again. I just rebooted it and it’s been working frantically with the drives for about two hours trying to catch up…

  • Remote access functionality

I’ve had no technical remote connectivity issues.

As someone else noted the username/passowrd setup can be confusing. This is not really related to the new OS - but since it’s been broulght up already… As far as I can make out when a user is setup on the MyCloud Mirror itself the user name (ie email address), but NOT the password is uploaded to a WD database at wd2go.com or similar. Also the user is informed by email that an account exists and is advised to go to " https://web.wd2go.com/signup.do…" to create a password (again). The thing that threw me was that the requirements for the passwords are different. On the MyCould Mirror I used passwords with lower-case and numbers; on the wd2go site it demands that a capital letter is also present. So my initial password was rejected on the wd2go site. This confused me for a while until I figured out what was going on. Now I have two different passwords for the same account and have to keep remembering which one applies each time I login to something.   

WDSync I have tested recently and nice as it seems it is inadequate to be used as a Cloud Sync program. It lacks the simple common sense to replicate file and directory “moves” on the storage device. Instead, when you move a file or directory on your computer it deletes the copy in the oroginal location on the storage device and proceeds to upload the file or directory again to the new location. this is potentially a tremendous waste of time and data transfer. Imagine moving a directory containing 2 GB of files and having to wait while the whole lot is uploaded again. I really hope this is improved soon!

Also not really related to the new OS, but I see the WDMyCloud android app has improved and now includes browsing of the mobile device itself with “copy” working between different storage units and also between storage unit and local device.  Meanwhile the desktop program doesn’t do either of those (although I guess drag and drop makes up for tha a bit).