General Feedback - WD My Cloud OS 3 Operating Software

First off I have an WD EX4 with Qty:4 3TB WD RED Drives. I’m an IT consulant that recommends what clients should purchase. I feel I made my personal wrong decision and maybe should have went with Synology afterall. 

  • Look and feel of the new user interface

I enjoy the White setup looks nice and clean

  • Dashboard and drive functionality

 Dashboard - I don’t need the Storage size information every time I log in, that should be in the Storage Tab named Usage. Currently this takes 5 minutes for my GUI to come up to even be able to use it. 

 Drive/System functionality - I believe the CPU is tweaked more towards accessing the device and cloud not the GUI Dashboard as it’s painful, and I was expecting OS3 to resolve my issues of performance and hasn’t and only has gotten worse. 

Remote Access-WD MyCloud App Iphone Backup Photos-Doesn’t work well; when I view Activity it takes forever to send anything. My Iphone is 5S and 9.0.2 firmware with plenty of open space. 

I returned my unit RMA and got a new same version one EX4 and I’m disappointed that the firmware 1.05.30 is most responsive comparing to this recent OS3. I chose this EX4 based on my expierence with WD Hard drives throughout my life and the support received for hard drives is AMAZING!!! WD needs to honestly up their game and put more money to this “MyCloud” niche as it’s very important. Sad to say I can’t even provide extra $$$ to get the new version of EX4 that has a better processor and more than 512MB ram, reason why they came out with those because they most likely have MANY customers out there that B*tched about these models on performance(EX2, EX4). 

WD please contact me I need a resolution on my device; please take accountability and fix these issues.

Gramps wrote:

I do not see anything different on my DL4100 other than perhaps the power schedule and MYCloud connects now


Oh yea, the WD2Go app does not work on a Windows 10 phone.  Shows the device, shows the shares, then says No network available




In short, WD no longer support Mobile device remote access, instead you have to use a web broswer and login to their website to access files. This sadly doesn’t give the function that WD2Go did.

Quote an email this morning:

“Thank you for contacting Western Digital Customer Service and Support. My name is [[DELETED]].
Your case has been assigned to me regarding the problems of connecting your windows phone to our WD My cloud drive.
We would like to apologize for the inconvenience this has caused.

Currently there is no option with our apps to access the drive remotely on our OS3 platform.
The only way to access your unit remotely is with an internet browser by login on to []
If this workaround is not a workable solution to the remote access we would like to offer you a refund of the purchase price of your unit once this is received at our collection center.”

I’ve emboldened the particular statement that I still find shocking.

There is an ideas thread on the forum here that tries to get WD to pay attention to users’ requirements (ie function that they have now removed):

Here’s hoping, as the MyCloud device could be such a good thing. I don’t want to have to send it back to WD for a refund.

Ps, Amazon have suspended its sale too, owing to the feedback they are receiving as a seller.


1 Like

Dat’s a sad respones from WD

Do you have a link for Amazon?  I still see units offered. Where did you get that info?

1 Like

Gramps wrote:

Dat’s a sad respones from WD


Do you have a link for Amazon?  I still see units offered. Where did you get that info?

If you search “wd mycloud” Amazon finds it. I was also refering to the 2GB version btw…

I looked just now and see that the big red box of message has been removed now. I’m guessing they’re (Amazon)  happy to continue selling it. No further information unfortunately.

Please peeps, pop into the ideas thread (linked above in previous message) and smash the Kudos button to get the Windows (and all mobile platform) apps reinstated! I still cannot believe that a company as reputable as WD will leave users hanging in this way.


Is WDs statement aimed only at the DL4100?

Remote access is working fine for the MyCloud Mirror

I checked for the DL4100 and found

where is proudly says…

Mobilize your critical business data

From anywhere in the world, you are always connected to your My Cloud Business Series NAS with the My Cloud mobile and desktop apps. The mobile app allows you to securely access your business data using smartphones and tablets, and easily share files with co-workers, partners and clients. With the desktop app for PC and Mac computers, you can easily drag and drop files, manage your content and share links to specific files or folders via email.

If that is what they sold then that is what they have to provide even if is takes a new software update ASAP

I notice the distinct lack of detail in which smartphones and tablets can be used to do remote access: no details of which operating systems are supported.

Similarly, no specifics of App availability here:

Weasel words…

I still can’t use After I put in my user-name and password I am met with the following and it happens on three browsers.

My Cloud login failure.png

That error’s coming from WD’s own servers.  :cry:

Has been reported.

odd, i never see wd2go in any url

No, and I don’t get it if I click on the link.

Maybe a ctrl-refresh?

I’ve even tried another computer!

cpt_paranoia wrote:

No, and I don’t get it if I click on the link.


Maybe a ctrl-refresh?

I hadn’t upgraded the firmware for about 4-5 months, mostly since everything was running fairly smooth. I saw that I had missed a couple releases and decided to upgrade to 4.04.00-308. WHAT A MISTAKE. GUI is pretty much non-responsive or non-existent. A reboot usually brings it back but it usually never refreshes completely. My media library appears mostly unavailable over DLNA. If I log in with SSH and the load average is usually in the 20-30’s. I would love to just downgrade the firmware but with no GUI to speak of anymore, I am at a loss. HELP!

GUI is pretty much non-responsive or non-existent. A reboot usually brings it back but it usually never refreshes completely.

It’s probably running the indexing and thumbnailing tasks, like it will after every firmware upgrade.

Rebooting will only restart these tasks.

Either leave it alone for a couple of days (if you have a lot of media) to let these tasks finish, or kill them off:

My media library appears mostly unavailable over DLNA

Have you checked in the Twonky UI to see what shares it’s now looking at for media?  Firmware upgrades (and most other restarts) trash the Twonky settings. You can address this to some extent:

ps. you shouldn’t have to know these things… the device should ‘just work’. The reality is a little different.

After reading all the posts here about the new and highly awaited OS, i came to the conclusion that if i value my NAS sleep and power on at desired schedule capabilities, i shouldn’t upgrade.

So far since finally relenting and upgrading the NAS, I now have no ability to access the dashboard via the software or IP.

I can ping it and still access the files via mapped drives, but cannot control or configure the NAS at all and so far my thread asking for a solution on this has gone ignored by WD support. Really poor.

and so far my thread asking for a solution on this has gone ignored by WD support.

If you want support from WD, contact WD Support. this is a user forum, not an official Support forum.

I’ve tried clearing the Twonky database and rebuilding.  It’s just terrible and usually ends up with error messages.

This is the latest load value before even the ssh session went non-responsive.  I plan to disable twonky, followed by the Media sharing on each Share and see if I can try to re-enable each one.

top - 11:06:15 up 14:00,  1 user,  load average: 129.21, 116.52, 100.64
Tasks: 128 total,   1 running, 126 sleeping,   0 stopped,   1 zombie
%Cpu(s):  0.6 us, 47.3 sy,  0.0 ni,  0.0 id, 49.1 wa,  0.0 hi,  2.9 si,  0.0 st
KiB Mem:    232320 total,   197312 used,    35008 free,     1472 buffers
KiB Swap:   500672 total,   229568 used,   271104 free,     1024 cached

I guess the point of this post was that this update essentially ruined the MyCloud and it’s essentially worthless at the moment.

At this point, I really just want to return to the previous release and leave it there. 

For some reason, now, does not like working with Firefox, but is working with Chrome.  Don’t think I’ll be using the web-site NAS portal.  It’s because the only protection one user-name and one password and if my accdient these details get harvested then all NAS’s connected to a account get compromised.

I have suggested at least that two factor authentication is used, but I think the suggestion is being ignored.

So, use the remote access portal with caution.  A lot of caution.

It’s mad. For example, DropBox introduced 2-factor authentication quite some time ago as well as Google and Microsoft.

So, within the MyCloud NAS’s there should ba a built in facility to allow the use of 2-factor authentication on the MyCloud,com web portal and also all the apps.

Until that is done it’ll take me some convinving that WD does really take security on ther NAS’s seriouslty.

Honest feedbaclk.

1 Like

I can’t even find the link to download the software anywhere on your website…could you post it here please?

USB My Book does not connect and mount. When it does connect but not mount, it shows 0K free.

My feedback:

Login page is still really really bad. 

 1/  On chrome is needs Login to be pressed twice

 2/ If you enter the passowrd incorrectly, and then type a new password, it needs to clear the old error.  You have no idea where you are, if the password is still wrong, if it’s an old message.

The Android app and new firmware are really badly broken.  Not sure which has been at fault, but it’s never worked since upgrading, coming up with network errors.   Had several app updates, not of them have fixed it yet.

Other than that, all working as expected.  I have not seen any new features however, it’s just a lick of paint, plenty of existing bugs still present (the login bugs), and some new ones (the broken apps)./

1 Like