Old firmware to 2.02.32 => brick


I had not used my WDTV live gen3 for some time as I didn’t have a TV. I recently got one so we could watch movies.

I powered on my WDTV - great - it still works! In my enthusiasm I see there is a firmware update and think I’d best install it as I’m way behind. Oh how I regret this.

Now when I power on I reach the splash screen “WDTV” with blue sky/clouds. And it just sits there. Forever.

I’ve tried:

* multiple power cycles hard and soft

* factory reset button - does nothing

* usb formatted fat32 with 2.02.32 firmware from here:  http://www.wdc.com/wdproducts/updates/?family=wdfwdtv_live_G3

USB gave me hope as after the power comes on with the USB stick already inserted it seemed to try to read the stick (the light briefly flashes on the stick) then it power cycles and then I’m back to the never-ending splash screen.

It’s as though it’s trying to boot off the USB stick but fails and then falls back on the existing version installed.

I’m linux literate and willing to get my hands dirty but don’t want to spend an age on this. Any ideas?

Is the USB drive completely empty ?   (it should be completely blank, apart from the firmware files)

maybe try a different flashdrive ?

maybe try the front or back USB port ?

maybe try rollback firmware ?    http://download.wdc.com/wdtv/wdtvlivegen3_rollback_2.01.86.zip

1 Like

Hi JoeySmyth

thanks for the reply. I have already tried front/back. Only one flash drive, I think I might buy another. I’ve partitioned it with a single partition with cfdisk:

$ /sbin/fdisk -l /dev/sdb

Disk /dev/sdb: 513 MB, 513802240 bytes
166 heads, 4 sectors/track, 1511 cylinders, total 1003520 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000615e8

   Device Boot Start End Blocks Id System
/dev/sdb1 * 4 1003519 501758 b W95 FAT32

 I deleted the partition, recreated, reformatted also:

$ sudo /sbin/mkdosfs /dev/sdb1 -F 32 -v

 Copied over the files in the rollback zip (unzipped of course). Same again :frowning:

I guess my only other hope is another usb stick - is this something others have reported?

Frustrating / disappointing that the factory reset is ineffective the minute you need it!

is this something others have reported?

It’s happened to a few people … but it doesent seem to be a common thing … could not find too many posts about it ?



I would definately recommend trying another USB stick … as i have heard of people unable to upgrade firmware (ie. no notification message to upgrade) … then they try another USB stick and it works.

Personally, i use a 2Gb Kingston FlashDrive which i only use for firmware updating (or rollback) … been using it for years with success.

One other thing … dunno if it will help … disable your network (remove ethernet cable or power off the modem router) just in case it’s having a conflict with online update.  *just guessing* may have nothing to do with anything :confounded:

Yeah I’ll try another stick. Well with the perspective of a day to let the idea sink in I’m really very cross with WD for not having a better firmware upgrade process. Very poor in this day and age.

It certainly reflects poorly upon them and tarnishes the brand.

If anyone has any tips on why I might have the wrong partition type or have formatted incorrectly which is causing the firmware image on the USB to not load I’m all ears!

Well got a new usb 2.0/3.0 kingston today:

$ /sbin/fdisk -l /dev/sdb

Disk /dev/sdb: 31.5 GB, 31466323968 bytes
31 heads, 31 sectors/track, 63951 cylinders, total 61457664 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xdee8c2c7

   Device Boot Start End Blocks Id System
/dev/sdb1 * 8064 61457663 30724800 c W95 FAT32 (LBA)

And sadly still not even attempting to boot off the USB. Very disappointing - how can such a simple device be bricked by a standard firmware upgrade with no recovery path? Poor.

i doesn’t sound bricked to me

while device is powered - hold in reset button keep holding - when you hit the splash screen pull the power cord

next time you plug in the device there’s a good chance you’ll get a screen asking to insert a usb stick with valid firmware


thanks for the info. I’ve tried holding the reset button as suggested plus numerous other small tweaks. Not once have I been prompted for a usb stick.

I find this really poor. What’s the point of a factory reset that only works if your device is fine. :-x

What is the Part Number printed on the box?



S/N: [Deleted]

I originally bought it in the UK.

Any advice appreciated as it *was* a great device except for the incompetent firmware upgrade process.

See my post above for the cmds I used to format the USB. When I cold boot with the USB in it kinda flashes once then boots again as though it’s trying to use the USB (the stick has a light and I see it accessed at this time) but fails then falls back to the (flawed) flashed image. So it’s frustrating as I feel this thing could still be pulled back into the land of the living.

I know this might seem redundant, but suggest you redownload the rollback firmware linked by Joey Smith above.  Extract the contents to the new usb drive you bought.  Open the wdtvlivegen3.ver file and confirm the line inside:


If all is correct then unplug power, do the paperclip reset thing on the bottom.  Plug in the usb into the front port.  Reconnect power, relax , have a beer and give it one last try.

EDIT:  Oh be sure to safely eject the usb drive from computer before inserting into the WDTV.

Tried it from scratch again. Sadly the same outcome.

The whole process is cearly very flakey. Googling brings up many variations of “put it in this usb port / power off with the controller / power off by pulling the cord out / put the stick in before / after this part”.

Really this should just work if the usb stick is in either of the ports when the power is turned on.

I appreciate the help I’ve gotten from other members of the public on this forum, and if anyone has other ideas please do tell.

I’m underwhelmed by WD’s quality control. I work in IT as a developer, albeit not in embedded devices, and to me this seems very disappointing.

deleted per mod

ncarver - well the tone on the board has been fine until your comment. Not sure why it’s hard to believe I haven’t had a problem upgrading firmware before. I’m a developer not a helpdesk guy.

If you read the whole thread you’d see I have tried 2 usb sticks, the other is 500MB in size. The 32GB drive is usb 3 and 2.

I’ve seen many posts on the internet complaining about the WD firmware including one update to improve the update process that bricked many devices that had to be RMA’d. In trying to find how to successfully flash this device I’ve read *many* articles that are considerably more angry than anything I’ve posted. I think this example alone is the definition of “a poor upgrade process”.

Finally I’d say that I’ve never had a USB stick fail to work. The WD device seems fickle - I’ve read many comments about some USBs working and others not. This is not normal in my experience. Others wrote much the same. USB 2.0 should “just work”.

I have no hardware sitting around that requires windows as I’ve ran linux for 10 years and only buy h/w that works with linux. That is until this fickle little box which has an extensive catalog of similar issues strewn across the internet.

Was there a point to your post other than a rough guess that other devices are also fickle (they are not as bad in my experience and others) plus not reading the whole thread to know I’d tried 500MB USB 2.0?

I removed a couple of posts that were getting off topic, please keep it friendly guys