Insert USB drive with firmware


I tried to rollback the firmware of my WDTV live streaming (guess must be Gen3) because of freezing issues.
The WD TV recognized the “new” firmware and after I pressed ok it wanted to start again.
Unfortunately there was nothing going on for about half an hour so I pulled the plug.

Now I have a screen where I have the instruction:
“Insert USB drive with Firmware to recover your WDTV” in several languages.

I did this with various USB sticks and tried also various firmwares - but there is nothing going on at all.

Please help me somebody!


Well, nobody seems to have any solutions, but I could fix the problem.

Instead of using a USB Stick I placed the Firmware on an external Hard drive with external power supply.
It took around 30 seconds and the WDTV live started to install the Firmware.

May be there is somebody out there who can solve a similar problem.



Thank you for sharing the solution to your issue.

This problem is discussed here: Insert a USB Drive with firmware to recover your WDTV - resolved!


No this is not right!

This is another approach to solve the problem than mine - may be you should read befor to post?!

With a pen drive (I tried 2 different) it did not work al thought they worked before on the WDTV.

And I was not doing a rollback - this failed - so I had the screen that I have to install the firmware from a USB stick.

The solution was to use external hard drive with power adaptor - I think that this was the important thing, the extra power!

And this solution was nowhere to find - and I did quite a research - so that’s the reason why I did post my solution.

BTW: Is there any firmware out supporting miracast except the crappy one 3.2.32 (which you can hardly name “firmware”)? Or is there a fix coming for the latest firmware?

This is really poor what WD ist distributing!!!

I’m sorry.
English is not my native language an I may have miss-interpreted.
I am also stuck with the “Insert USB drive…” screen and I was looking for a solution.
For me, this was another idea how to solve the problem.

I would erase it if I could…

No problem at all!

Try with power supplied external Hard drive and firmware.

Good luck!