Insert a USB drive with firmware to recover your WDTV(WD TV LIVE STREAMING MEDIA PLAYER C3H)

Hi Everyone.

Welcome to the thread.

I was updating firmware of my WDTV, suddenly due to power outage WDTV restarted and it OS corrupted.

I have followed many threads and tried many solutions provided but got no output. I have tried to use multiple type of USB storages, Multiple filesystem types (NTFS,FAT,FAT32,exFAT,LINUX) but none worked.

Can anyone please provide me correct path to reset it ? and please do provide correct downloads.


First question to confirm … what’s the model number of your WD TV ?

C3H is not the model number.


Thank you for response

Please find this photo attached with model details.

That’s a PAL WD TV Live Streaming Media Player

PAL model number WDBGXT0000NBK

all i can suggest i using small capacity flashdrives to load the recovery firmware onto (1GB or 2GB) … and WDTV is only compatible is NTFS, FAT and FAT32 format

another user claimed that Linux Partitioning worked … but i can’t confirm that

Thank you for prompt response to thread.

Please note, i have followed the above solution, I tried it using 2GB Flash Drivs with 8GB as well as 16GB. But WDTV did not load firmware.

And i even tried it with linux partition. But still it doesnt make any change.

What i did?

  1. I formated usb’s in multiple partitions at diffrrnt plateforms as mentioned above.
  2. Than extracted the rollback above mentioned zip file to it.
  3. Switched off WD device.
  4. Put usb into front port of WD.
  5. Started WD.

Found same display as shown in first photo.

Please guide me if i went wrong at any step.

Any response Please.? Any help?

First question to confirm … what’s the model number of your WD TV ?

C3H is not the model number.


Heads up: We send a maximum of 100 daily emails. Check the site to see the
ones that might be held back. PS thanks for being popular!


As required the model is WDBGXT0000NBK.

Can you please suggest me proper recovery firmware url so that i may confirm if im going up with correct recovery firmware media file or not?

1 Like

I have RE-Flashed the FIRMWARE on my WD_TV live devices several times. It may be possible for you to fix this. But, the answer is a bit lengthy and, requires you to have: A thumb drive, formatted FAT32, about 32-GB or so is adequate; The firmware for your device, I am (intentionally) NOT using 2.02.32 version I use 2.01.86 ( and can show you where to download it ). Your device is currently ‘bricked’ but can be revived. If you are interested ( 2023-DEC-31 ) - reply and we’ll see if I can provide you with what you need. ;O)

Hi, i have a bricked wd player live WDBAAN0000NBK-00. i’d like to ask for the place to download the firmware from. Thanks.

Mr. Smyth / Joey / Sir-

I received an email today 2024-JAN-10, from you, asking for WHERE to get the FIRMWARE to fix your WD TV Live that you accidentally bricked.

I tried to respond to you on the WD site, and; it responded with what you see below in the screen shots. So, I am trying to REPLY to you directly here.

This is a WEB PAGE of instructions to “downgrade” from 2.02.32 to 2.01.86 (the version I use). It is no different for a BRICKED device. You follow the same steps.

There are 2-useful links for you, the FIRST is how to “downgrade” from 2.02.32 ( a horrible version ) to 2.01.86 ( the version I USE ). The second link is the ZIP FILE archive you need to perform the FIRMWARE installation.

I’ve done this several times myself - on a DOZEN WD-TV Live Gen3 devices. So, if you need some guidance, please do ASK ME, I will try to help you. My personal email is: roger.mukai (at) gmail

WD instructions link:

Firmware for 2.01.86 version download zip file:

You will need:
A FAT32 formatted USB stick, a 16-or-32-GB will do.

And, a PAPERCLIP, to press the RESET BUTTON on the bottom of the device. You must push the clip into the little hole - WHILE it is booting, in order to START the UPGRADE process.

And, it is SLOW to respond. I always have to say to myself,
“Wait for it …” Some pauses are as long as 1-full minute!

Be sure to do the HARD RESET step, because; you want it to use a USB stick and NOT the internet to perform the recovery. I’ve found that it can get STUCK trying to connect. The hard reset helps prevent that issue.

If you need help, I will be happy to try and help you.

BEST of luck to you SIR and GOD BLESS.

Roger Mukai

Joey / Sir-

One more note from me. The last time I did this was in 2016. Here are MY NOTES to MYSELF on doing this:

ONE MORE NOTE – I do recall, for reasons I cannot explain, that a couple of times, this took HOURS and HOURS to complete. When that happened, the big ugly red circle screen appeared, and; then just “sat there”. So…

I started the process, watched it reboot ONCE, then just walked away – For an entire DAY. And when I finally “checked” again a day later - it REBOOTED and was FINE. So do NOT be surprised, if the big red circle screen appears and just sits there.

BE PATIENT. If it doesn’t finish in 1-full day, TRY AGAIN. It sometimes acts that way. I do NOT understand why. It’s a SLOW process to RE-FLASH sometimes.

Best of luck - God bless.


You are mistaken.

I NEVER sent you any Email.

If fact, i have NEVER sent anyone EVER an Email in my time on this forum.

If you received an Email from a “JoeySmyth” it wasn’t me, and the person is an imposter.


Well, it may be that the WD Blog has a database problem, for who it is that is identified here… It is true, no email was sent to me ( until now ) by you. But there were posts on the forum, quite a while ago, that you posted about WD-TV live. That is where I got my first “contact” regarding this stuff. If Joey Smyth is NOT who you are… Perhaps something needs to be changed. For your id here on this email is “JoeySmyth”, and it is coming to and from “WD Community” online… That’s all I know. What my email shows. Perhaps the problem is ME – I may be mis-reading this, and if I’ve mis-identified you, please do, realize it was not intended. And I apologies for any mistake!

Regardless, BEST of luck with your WD effort to UN_BRICK your WD!

Take care, Be well, God bless.

-Roger Mukai-


My own sad saga occurred when I tried to downgrade firmware 2.02.32 to 2.01.86. Something happened in the downgrade process - bricking my WD device. Up came the “Insert…” message - and no manner of inserting a usb device - front or back - fat32 2gb 8gb 16gb - loaded alternately with both of the aforementioned firmwares - worked! After two weeks of this, and close to giving up, I stumbled upon firmware 2.03.20, on a WD legacy site. Loading this on to the 8gb flash drive, worked like a charm. In a few minutes time my WD was up and running! So, I take from this, that when that Insert message occurs, you need to feed the WD player the latest existing firmware!

Dear Lyate2004-

On one of my WD-TV Live, I experienced similar issues trying to “REVERT”. You do not have to use the latest firmware… Interesting truth… If you follow that “downgrade procedure”, and let the THUMB DRIVE SIT for a LONG, LONG, LONG, LONG time - eventually - it will FINALLY enter the RESTORE process. I once had to let the WD-TV sit there with that screen for 36-hours! Then suddenly, it worked! Strange and true. Also could NOT repeat that. On the same device, I ran the process again from scratch - and that “DELAY” did not occur.

I dunno why it is so very inconsistent in how it does things.

Best wishes, and God bless.

Most sincerely,

Roger Mukai

Hardly an expert on this, but I let the WD box marinate for 3 days with properly formatted usb drive containing firmware - with no discernible result. Loaded the newest firmware - and recovery process began almost instantaneously!

So, who knows?