Insert a USB Drive with firmware to recover your WDTV - resolved!

Hello everybody! This is just a message to tell all of you that after searching on the net and do many tests, I solved the problem of a failed update into a WD TV Live Streaming Media Player. This is what I did:

  1. First, I used a pen-drive with a partition of 2GB. (physical capacity of 16GB.). I did that partition under Windows 10.

  2. I unzipped all the files of “” ( into this pen-drive and I tried several times the WD TV will it begins the update process but did not succeed.

  3. Next, I used a 1GB physical capacity pen-drive with a full partition (under Linux Ubuntu). I unzipped the same file ( into this new pen-drive and put it on the front USB port of WD TV. Then, I rebooted the device.

  4. Voila! The update process began and then ended smoothly.

Linux rules! :slight_smile:

Hello and welcome to the WD Community.

Thanks for sharing your solution with the community. 

Hope this helps other users.

Hi there, So my boyfriend unplugged his wdtv live streaming media player while it was updating the firmware b/c he got impatient. Now he’s left it up to me to fix lol.

Nothing I do seem to work. I have a 32gig usb formatted to FAT32, nothing is on it, I’ve downloaded firmware and when I plug it in, whether I plug it in before I turn it on or not, nothing happens. I am in day 2 of this and ready to throw the towel in… I have read your response but I am not familiar with paritions etc… I am using a mac book pro… please help before I loose my mind… Thanks!

And I have no idea what gen this is, I am not familiar with these machines but the firmware I have says wdtvlive_gen 3

In all my years of Upgrading and Rolling Back Firmware i have never messed around with partitions on a flashdrive. I bought a 2GB Kingston Flashdrive for about $10 and use that … has worked perfectly for Years.

If you’re not sure which “Gen” it is have a look at the Part No. on the label on the device
eg. WDBHG70000NBK, WDBGXT0000NBK is Gen 3

I would recommend using a smaller flashdrive eg. 2GB 4GB or 8GB formatted FAT32 … unzip the firmware to the root of the drive (ie, there should Not be any folders on the drive) then power on and it should go into Firmware Recovery mode

Because of a mistake I got the “Insert USB pen with firmware” screen.
I tried countless times but it failed to load.
Than I remembered that the last working firmware was actually 2.02.32 and I was trying to reboot with rollback 2.01.86.
So tried once again with 2.02.32 and it worked. Only after that I did the rollback.
My advice to anyone stuck with the “Insert USB pen with firmware” screen, try to reboot the WD with the software that was installed before the crash.

Good luck

Linux usually formats a new usb drive as ext4 file system which is not recognized by the wd media player.