Stuck on "insert a USB drive with firmware to recover your WDTV"

#1

Hi,

I am using a WD TV Streaming box (WDBGXT0000)

I had a problem with the latest firmware update. It failed to reboot.

I now get the screen “insert a usb drive with firware to recover your WDTV”. I have downloaded the firmware the 1.16 firmware from here and the oldest firmware - http://support.wdc.com/KnowledgeBase/answer.aspx?ID=5860

I have tried a number of different usb drives, I have tried plugging into the usb port 1 & 2, I have tired plugging it in on boot and after boot, I have tired pressing the reset button.

Nothing happens its just stuck on that screen. The remote is unresponsive, I have to pull the power lead out to reboot.

Is there anything else I can do to recover it or is it kaput?!

Any help anyone can offer would be very much appreciated.

Regards, Nick

Issues with wd tv live gen 3
#2

2 days ago, it was a) swing rollback interpose plug and do reset) helped me Downgrade Firmware from 2.02.32 to 2.01.86

#3

Nope. So downloaded zip extracted files to root of usb drive. Booted with it in there, booted with it not and then plugged in. Nothing, still stuck on same screen.

Thanks for suggestion. Any other ideas?

#4

inserted into the player the downloaded file … turn on the player and reset

#5

reset when the inserted flash drive
evidence

#6

Tried with the USB-stick being formatted in FAT32?

#7

Yes

#8

Thanks guys. Whatever I did worked, its back up.

However getting the freezing error when connecting to my NAS. Didnt have this prior to the firmware upgrade, so might try and roll back 1.16 again (but this is what I did last time and got stuck in this loop). Shall I twist and try 1.16? what do you think?

#9

do as I wrote

#10

How do you insert the downloaded file into the player if the player does not boot up and is stuck with the firmware error message? It would be interesting if the suggestions members add are complete and thorough enough to actually be helpful.

#11

I am getting the same error message and I believe I followed andrey_andrey’s instructions correctly, but I still get the same message on my TV screen

Model of my WD Device:

Content of my 68gb usb drive:

Is there anything else I can try?

#12

you downloaded Gen 3 WDTV Rollback Firmware

your device is a Gen 2 WDTV … so that’s not gonna work

the only firmware available for your device is here: https://support-en.wd.com/app/products/product-detail/p/189#WD_downloads

oddly, they released another version firmware in 2013 (FW 1.06.42_B) … but no download links on the WD Site ? … oh well, should be out there if you google it.