Insert a USB drive with firmware to recover your WDTV after update 01.02.17 firmware

My WD TV Media Player, was updated to firmware 1.02.17 (Release 12/16/2014).

After the update, The HDMI output does not working and if I connect the WDTV to the TV via Composite output, I get the message: “Insert a USB drive with firmware to recover your WDTV”

When I connect the DiskOnKey with a firmware files - Nothing happens.

Any Idea ?

DiskOnKey??? That’s some old junk, there! Surprised the firmware even fits on it.

Try an ordinary USB stick formatted FAT32 with nothing but the firmware files one it.

“DiskOnKey” and “USB stick”, are two names of the same thing.

I’ve already try to use Sandisk 4GB formatted FAT32 with nothing but the firmware files one it. but as I said nothing happened.

I have the same problem (

Exact same issue being experienced here - any solution? 

Anyone know if there is a fix for this? I have put in a freshly formatted 8GB (FAT32) and nothing happens on boot.

Was in the middle of this and it hung - 

  1. download rollback firmware:


that’s the wrong firmware for this device … this forum is the 2014 WDTV  Firmware 1.02.17

Rollback Firmware is 1.01.30 or 1.00.42

A mi me pasa lo mismo, enciendo y me aparece la pantalla negra con el prohibido diciendo que conecte un USB con el firmware… Pero…¿CUAL FIRMWARE?

Which WDTV do you have?

WD TV Media Player


Hay tantos firmware que no se cual poner.

Y Gracias por responder.

Gracias, voy a probar ahora mismo

Nada de nada, Le he puesto ese Firm y en pantalla de la TV. sigue igual. Ya no se que hacer

Did you unzip it?

por supuesto:


Estos ficheros los pase a un USB y con el WD TV Media player encendido, pero no consigo salir de la pantalla negra con el prohibido en rojo.
He enviado e-mail a WD Support de mi problema pero no me han contestado aun.

Hi All,
Hopefully there’s still someone out there with WDTV knowledge who can help me… I’ve been given a WDTV Media Player (WDBPUF0000NKBK). It had never had its firmware updated so I followed the procedures as per above, unzipping the update 1.03.07 & copying the files onto a usb, inserting it etc. Here I get a little vague - I have Parkinson’s so my short term can get a little dodgy particularly when I stress like when tech goes wrong. I don’t remember what happened but I’ve now got the black screen with the red “do not enter” sign & white lettering as above instructing me to Insert a USB drive with firmware etc. I’ve tried doing so with multiple usb formats, multiple usbs, multiple changing the version number to “2.xx.xx” and no luck.

I’ve been sticking to one usb in particular that has an led to indicate it’s talking to the WDTV & it flashes a number of times - sometimes 2 groups of flashes, sometimes 3 but after that it just sits there saying “Is that all you’ve got?” & nothing…

Unfortunately as a result of my illness I’ve got myself thoroughly confused with the number of times I’ve attempted to restore the device & the different models, firmwares, etc and have been going round in circles. Is there a kindly, patient expert who can hold my hand through the steps to get this neat little device working again or is it destined to be a doorstop?


FAT32 is the format you should be using. (and MBR Partition Table to be safe. GPT may not work)

Also try using the USB port on the rear of the device if you’re getting no joy with the front … Number 7


You only need to do that if you’re Rolling Back to a previous Firmware

Try the official firmware again and don’t edit anything… just unzip the files BI2, .BIN, .VER, and .FFF files to the root of a portable USB drive

If that doesn’t work … try the official Rollback Firmware (you do not need to edit the VER file … as WD has already done it)

Joey, I am beyond words! This is fantastic - just what I needed. And quick!

Just need to clarify a few things:
1/ I setup my USB with a 1 GB partition (FAT32/MBR) - it’s a 16GB drive, the smallest to hand. Any issues with this?

2/ Does is matter if the the USB is put into the WDTV before or after switching it on?

3/ How long do I need to wait before I accept it has failed loading? Or alternatively, how long does it take for a loading screen appear?

4/ If I use the rollback - because the 1.03.07 fails - and it’s successful, am I tempting fate if I try to load 1.03.07?

Thanks once again & thanks for your patience :slight_smile:

I’ve always used a trusty 2GB Flashdrive … it’s the oldest and smallest one i have, and it’s my “go-to” flashdrive for installing firmware on every device i own.

Always have it plugged in before you power on the WDTV

I can’t remember … but it should happen within minutes.

Give it 15 Minutes at most … if it hasn’t worked by then. Then it’s time to Abort.

If the Rollback is Successful … there shouldn’t be any issues then updating to 1.03.07

(but, maybe consider staying on the Rollback since 1.03.07 didn’t fix much … mainly online service stuff which probably doesn’t even work anymore and removed a lot of obsolete online services discontinued ages ago.)

NOTE: When you download firmware and extract it to a flashdrive … ALWAYS Safely EJECT it from your PC … Don’t just rip it out from the PC USB Port, as it can corrupt the flashdrive/files

If the flashdrive won’t safely EJECT … shut down your PC and then remove it once the PC is shutdown.

No worries, i’m here to help :slight_smile:

Thanks once again.

I got your reply after repeated fails from the USB with the 1GB partition. Tried both front & back USBs with both firmwares & no luck-usb led flashed a number of times then stopped.

Then found an old 8Gb & loaded files onto a 1GB partition. Put it into the front USB, led flashed & I thought, “here we go”. 4 hours later (kids &life distractions) & usb led still flashing. So I got the first USB, plugged it into the rear USB & away it went. The roll back firmware that was on the rear USB loaded up. Then it found the later firmware on the still plugged in front USB & loaded that. Hurrah!

Plugged in my wd 3tb ntfs drive and… Bugger, the wdtv can’t see it. Never mind, it 1:30am anyhow. I’ll sort today :crossed_fingers:.

What a lovely gift to have it going & much appreciation again! Thank you from Aotearoa New Zealand, ngā mihi.