Downgrade Firmware from 2.02.32 to 2.01.86

To Downgrade 2.02.32 firmware to 2.01.86:

  1. Insert a blank USB Flash Drive into your PC.

  2. Download the previous 2.01.86 firmware here:

  3. Unzip the files to the root of the USB key.

  4. Power on your WDTV Live.

  5. When booting complete and at main screen, insert USB Key.

  6. Choose NEW FIRMWARE

  7. Update and complete.

You will be “rolled” back to the 2.01.86 firmware.

Enjoy until WD fixes the long laundry list of issues with its latest release.


It’s good to have an alternative firmware revision available.


OK, I’ve copied the old firmware files from that link you’ve attached to a FAT32 flash stick.

I’ve turned on the WDTV Live, inserted the stick into the USB - where is the NEW FIRMWARE option? Ths hasn’t appeared. Have I done something wrong here?

I really want to rollback to the earlier firmware, as now half of my Mp4s are for some reason been recognized as music, and I have NO clue why!

Try putting the USB drive in before turning the unit on.


Follow my steps 1 to 10

1 Like

Success. I’m back to the old firmware.


Half my entire MP4 content is STILL being recognized as music. Anyway to fix this?

I had a few folders with mp4 and jpg files in them. They all wound up in music instead of videos. Deleting the jpgs solved it and they weren’t needed anyway.

THis fix worked great.  Now I can see all the movie files on my hard drives again. Thanx

I followed these instructions.  All files were on the USB drive at the root, nothing else.  The New Firmware button appeared.  I did the firmware update.  At the end it said the firmware was incomplete, contact support.  It then hung on the WD screen.  I restarted it… now it is bricked… won’t boot - comes the screen that says Insert a USB drive with firmware to recover your WDTV.  When I try inserting the USB drive - it does nothing.


Thanks cravaccio. Nice and easy. Just completed on 2 of my boxes. Recommend the downgrade until the upgrade comes.

Edit: after using YouTube app, box is just as Laggy and unusable until restart.
Sorry. Recommendation rescinded. **bleep** thing better get fixed soon.

Edit2: it’s actually much worse. Completely locks the box up after exiting YouTube leanback. Have to unplug the box and reconnect.

Well, i as experiencing problems with firmware 2.02.32 but downgrading to 2.01.86 game me the same problems…

The WD TV is a piece o junk… sorry to say. I’ve *lost* 3 days of my life dealing with this unit and i cannot say good things about it. It tries to do MORE than it can handle, and does it in a very unwanted way.

Best just stick a USB pen in it and pray that it can play the videos without a glitch. THAT’S IT! I will never want anything more from this unit.

Wow still not fixed. WD, what’s up with that?

Hi, I followed the instructions here, but now seem to have a bricked device!!

It is now stuck on the " Insert a USB drive with firmware to recover your WDTV" screen

Any help appreciated


Downgrade to 2.01.86 from 2.02.32 firmware is working for me on WD TV Live WDBHG70000NBK-01 version, no freezing and the USB external hard drive can be recognized by WD TV Live. Thank you for this information. Make sure once downgrade the 2.01.86 is completed, set the “Setup > System > Auto Detect New Firmware > Off”.

Updated - 11/25/2015 - WDTV Live Mod
Added an internal Fan to the WDTV Live as shown (3 images). I used the Noctua NF-A4x10 FLX (12V), blowing downward and it is keep the unit so COOL and very quiet fan. You will need to drill 1.5 inch hole for this fan.


Internal View - not pretty but functional :slight_smile: - I couldn’t find on which wires to connect so that it would come on only if the unit is on, but well it is keeping the unit cool all the time since I have it on 24/7.

After - I decided not to use the 4 rubber legs to tighten it down, just use hot glue to glue the fan to the cover and it is not going anywhere:

I still can’t get the WDTV Live to read external Red WD 4TB USB 3.0 hard drive, it is reading 2TB USB 2.0 fine. Anyone have any luck on this issue?

Thanks in advance.

Did the same yesterday, downgraded to 2.01.86 from 2.02.32, and now is working OK! I have had problems for months, so am truly grateful for this.

Thank you very much. This hint is very helpful. It worked right away. I still don´t understand why WD is not willing do provide an update to their own product line. Or is it a message: dont´t rely on us and don´t by products from us?
Kind regards from Austria.

Has Western Digital stopped offering the 2.02.32 firmware for the Gen3? When I checked their website, I see all the old firmwares up to 2.01.86. When I checked for new firmware from the device, it downloaded 2.02.32.

I know this was asked a while ago but just incase anyone else is wondering you need to:
Go to Settings then System then scroll down to Auto Detect New Firmware and switch it on if its off BEFORE restarting and inserting your USB. That’s when New Firmware appears.

As detailed in Step 4 from my downgrade guide