NSURLErrorDomain error -1012

I have an iPhone and the WD My Cloud app downloaded. It was working fine but now I’m getting an error that the drive is offline. I also got this NSURLErrorDomain error -1012 error a couple of times. Any ideas?

I am having a similar issue with a MyBook Live Duo and iOS 13 iPhone. I never get a code using WD Cloud. Have reinstalled the app from scratch and get same error and I can get quick access until is says the NAS is off line (which it isn’t). I am on same network, plugged in, etc. MBLD is not listed in the app but a third party is there (not sure I trust it). I have rebooted the iPhone and NAS. No luck yet. I have a trouble ticket in to WD as well.
The third party app looks like it is easycloud for wd my cloud. No sure if there should be a concern with this app since it is not WD.

After the public release of iOS 13, I updated my phone to the latest version and I don’t get that error anymore. However, I have to log in every time I get home so my photos will upload. Kind of defeats the purpose of “auto backup.” Several times I’ve had to select the backup path again because it’s gone when I log in on the app.

Sounds like we are at a similar spot. I was able add the drive with the code but it was intermittently working. I checked the uPnP as well, it was fine. I am wondering if it is a certificate issue. And I was able to log in. It did not work the best. So I also logged into the drive using https://files.mycloud.com. This worked but not fully what I wanted to do. I got a response from my WD trouble ticket and plan on talking to them on Monday. If something comes of it I will post the process here. One issue is the app does not have my MBLD listed.

Thank you!

Jessica

I have the issue. I’m following this topic.

Apple Yazılım Güncelleme Sunucusu Sertifikasının Süresi Doldu.

bir hata oluştu

Bu sunucunun sertifikası geçersiz. Gizli bilgilerinizi riske sokabilecek “swscan.apple.com” gibi davranan bir sunucuya bağlanıyor olabilirsiniz.

Apple sertifika yenilemeyi unutmuş olabilir mi ?

Translating from Turkish:
“something went wrong
The certificate for this server is invalid. You may be connecting to a server that acts as “swscan.apple.com ecek that might put your confidential information at risk.”

I also found other people having the same issue with Apple iOS 13. If you notice WD “My Cloud Home” Was updated 5 days ago. I expect WD “My Cloud” would be updated soon. Hopefully I will have more info Monday night after speaking to WD tech support. What model NAS do people have?

I have the 1012 message when attempting to upload photos in the app, when I attempt to do it through iOS I get the device not available message - help???

Yes I have the latest iOS on my devices.

Could it be the firmware as it updated on October 3rd?

Same thing here. Extremely frustrated w access issues!

I talked to WD Technical Support and here is a summary:

  1. They are working on a fix for WD My Cloud to work with iOS 13 and not sure when it will be out. It is a priority for them.
  2. They do not recommend using the mobile app with MBLD as the firmware is not being updated anymore and is a security risk over the internet. The local network is ok. Same as what keremerdogan saying.
  3. Also asked about other things. The latest NAS is PR2100, with Plex, and can’t say if something else is in the works. I asked about transferring files and ensuring they were not corrupted if I went from MBLD to PR2100 but did not get a sound answer if there is something that checks the transfer. My other concern was getting another NAS and running into the same issue or having another function come out that is not supported or quickly becomes obsolete.

Hope this helps and now we just wait for the upgrade. Also Mac OS just upgraded and dumped several 32 bit software versions, printers… :slight_smile:

1 Like

Thank you for all that information. Truly appreciate your time and effort in contacting support!

Jessica

Any ETA? I’ve been struggling with what has been going on for a few days before I came across this thread.

WD Community,

Please check the following KBA for My Book Live NSURLErrorDomain error - 1012 on iOS 13. It may resolve your error message issue.

My Cloud Mobile App “NSURLErrorDomain error -1012” Error Message
https://support-en.wd.com/app/answers/detail/a_id/28739

SBrown, I tried the instructions the best I could follow them and ran into a few issues. Opening the My Cloud to Delete/Remove the My Book Live only works once it fails to connect (no manage option until it fails and “offline”. I have tried the remaining instructions except for the airplane mode on/off (used on/off and full app removal before) and clearing ALL of the dashboard is something I don’t want to do. The reason being I have computers and other devices connected (actually I still have WD Photos and WD2go as well). The only way I get the manage my devices and services is once I get the code in my dashboard and have removed that (and added it as well with same failed result). The other issue is that MBLD is not in the list but it still sees it. I am leaning towards the app needs to be upgraded. Side note is that my MACs are having issues with the icon on the computer as well. I do appreciate the write up. Regards,

1 Like

I have the same issue. I followed the suggested fix without success. Hopefully they will figure out a fix soon.

1 Like

I was greeting to this pleasant surprise tonight. I had MAJOR work to do and I rely on an iPad being able to talk to SEVERAL of my MYBOOKLIVEDUO devices on my LAN via WD MY CLOUD. I tried all suggested fixes listed and nothing worked. I find it strange that SOMETIMES the MY CLOUD app connects and can for example play an .mp3 or load a .jpg. But within a short time it just says the device is offline and access is lost. It does not work AT ALL when trying to use it in other apps, for example transferring a .jpg over in the PHOTOS app.

So I see from this thread here that the problem has been known for several weeks now, and… no fix. This doesn’t look good.

I’ve tried this a few times to no avail. Solution please!!!

Same issue here, logging in via iPhone APP or online fails.

WD Community,

We’re published a KBA to help workaround the iOS13 connection issue.
The same solution is applicable for My Book Live as well.

My Cloud Device Offline After Update to iOS 13

Answer ID 28736