MyCloud app for iOS13 don't work with my MyBookLive

I have two iPads, one still with iOS12 and one running the latest iOS13.
The MyCloud app on my iOS12 iPad works fine (as it always did) with my MyBookLive, but the app is not running on my iOS13 iPad. ‘Drive offline’ it says on ‘13’ on ‘12’ it’s assessable.
All my friends running ‘13’ have the same problem on their Apple devices. My friends running ‘12’ are still happy with the app and don’t have any problems at all.

I also have a MyCloudMIrror, with that NAS everything works fine. No problems at all.

So, … is there a know problem between (1) MyCloud app (2) WDMyBookLive and (3) iOS13 ?

Yes. There is a confirmed problem with iOS 13 with all sorts of MyCloud products. WD claimed it’s working on it, yet no obvious progress has been made as of 10/7/2019. See:

Yes this is unacceptable from WD. iOS 13 ain’t great but every single one of the hundreds of apps I have across devices works as intended . All apart from WD my cloud. They’ve had months to ensure this was sorted throughout the many betas of iOS 13. It is a shocking response to a major glitch and more or less ensures my next NAS solution will not be coming from them

I got this solution, witch works fine for me.

Bypass HTTPS Validation in the My Cloud Mobile App by following the steps listed below to disable and Bypass HTTPS Validation in the My cloud Mobile App:

• Open the My Cloud mobile app

• Tap the 3-line menu icon in the upper left corner of the screen

• Tap “Settings”

• Tap on the words “App Version” 4 times very quickly to access the debug screen

• Tap on “Bypass HTTPS Verification” (Slider ON) to enable

• Tap “Done” in the upper left-hand corner of the screen

• Close and open the mobile app

1 Like

My phone is on 12.2 and is not connecting and neither is my MacBook.

Does nothing for me.

That worked for me, thanks :+1:

perrydelfant: Thanks for the tip. It worked for me and a GREAT HELP! Yet another question if you could help. I sometimes upload photos from my iPhone to My Cloud via app, but I still couldn’t after I followed your steps. Instead I got a message: “Drive Offline, MyBookLive is not accessible.” Any ideas that could be resolved before WD fixed its bug?

I got these additional tips from WD:

  1. Force the My Book Live or Duo into Proxy Relay Mode by disabling network router UPnP or ensuring the My Book Live is Double NAT, located behind two IP address serving network routers.

  2. Open the mobile device internet browser and access the device using MyCloud.com web application. For instructions, please refer to Answer ID 4697: How to access a My Book Live and My Book Live Duo using MyCloud.com

Good luck
Perry

HTTPS bypass solution worked a treat…Thanks :+1:

The workaround KBA is posted here.

My Book Live Device Offline After Update to iOS 13

Answer ID 28742