My Cloud App for iOS 13

My Cloud App stopped working/accessing My Book Live after iOS upgrade to iOS 13.
Different messages presented. Most common is “It was not possible to contact this deveice…”.

Is there anybody facing the same situation? Does anybody know how to solve it?
I can access my device from my iPad (that was not upgraded to new iPadOS version. It is still on iOS 12).

Thanks.

1 Like

I can’t access my files from my IPhone 7 with the My Cloud App since upgrading to IOS 13 either. Each time I try and reload the app with MyBookLive it lets me set up where I want photos backing up to AND gives me access to my files. However, I then can’t reaccess as soon as I come out of the app and then try again. I get an error message ‘Drive offline MyBookLive is not accessible. Local documents are available’.

I get the same thing. It works the first time I set it up, but future attempts give the ‘Drive offline MyBookLive is not accessible. Local documents are available’ error message. It does that on my iPhone and iPad.

I can access the drive locally using the iOS Files app, but that doesn’t help remotely.

What concerns me is the fact that nobody from WD give an answer. I’m tired of this support from WD.
I have another NAS from WD (My Cloud Home) that is working fine, but when all the WD solutions reaches the End of Life, no support is properly done.

I don’t know what happened, but I have turned off my UPnP on my router and set the ports manually in My Book Live config and it started working again.
I’m not sure if this will work for everybody, but it is working for me.
I hope that I could help.

1 Like

Same thing here. If I remove and add the device, it works. If I close and re-open the app, it says the drive is offline. I had a phone with IOS 12 which worked perfectly, updated to IOS 13, and it does the same thing. App is not compatible with IOS 13 period.

Mine doesn’t work either. Sad times.

I have the same experience as StevenMcG, Morac and Km2455. I hope WD continues to support their legacy products with firmware updates.

same here all my other apple devices I haven’t updated work fine

I have the same problem, but solved it with the next workaround.

Turned off Upnp in router and reboot the router. No portforwarding required for My Cloud.
Log in My Book Live Duo using internal ip adres.
Goto settings, remote access and disable and enable remote access and be sure there is a connected connection status with a relay connection.
Check then settings, network and internet access, this must be good.
Goto the My Cloud App and check if it works again.
Good luck.

It works! Thank you for the detailed workaround. Although it’s a bit slow because it’s relay connection, at least it works.

Good work guys on finding the workaround BUT this is unacceptable from WD. A user should not have to disable a router feature to get this working! Who knows what side effects that may have. WD needs to update their app for full compatibility with iOS 13.

Same problem here!

I fully agree. The WA is only to unblock the access for those who has urgency to access their files. As the WA is not so easy to home users to change and we don’t know the side effects as you said, we are still waiting for WD to announce when they will launch the new version of their APP with the final solution.

As suggested by another contributor I turned off UPnP on my router advanced wireless settings. The logged out of the My Cloud app and logged back in. Now when I close and reopen the app it seems to be able to reconnect. Hopefully it will connect tomorrow night when I try again. For now it’s time for me to get to bed!

Mine worked fine before I left town on Thursday. But some time over the weekend my Mac can’t even find the book. I’ve tried various ports on the router with no difference.
I can hear it doing something, but the light on the front goes out after about a minute it only comes on if I disconnect and reconnect the power.

My iPhone and iPad on iOS 13.1.x seem to be equally problematic. [Both are on latest iOS updates, and I did restart the router/ gateway.]

Mycloud.com for remote access sees the My Book Live/ My Cloud device WMC4N1356833 and can access it. Same for mycloud app from iPad.
I have the latest firmware.

Mycloud.com for remote access doesn’t seem to work with My Book Live Duo WUZ230200814 at all. Error “drive offline”. [Though I do use this drive mainly for Apple TImemachine.]
Same for mycloud app from iPad.
I have the latest firmware.
[My Cloud Home related changes problem, KnowledgeBase 13162 ?]

WD Photos I do not use. (I have photos backing up to Google Photos.)

On iPad or iPhone, I am presently using the FileBrowser app from the Apple AppStore to get around this, especially when on the LAN.

On my MacBook Pro (High Sierra 10.13.x) WD Quick View on the LAN can see and access my WD devices just fine.
Same from MacOS Finder.
Or FTP.
My Cloud works to either WD device on the LAN.

???

The workaround for the iOS 13 connection issue is posted here https://support-en.wd.com/app/answers/detail/a_id/28736

It is working as a workaround, but it may cause interruption in other services that I use. Do you know when WD will deliver a new version of APP?

Hi all, i tried the workaround but i could not disable what mentioned in the thread. They also released an update for the App today but i still face the same issue. This is really annoying not being able to access or upload files anymore. How can we get a response from WD team?