No Remote Access - Drive Offline

Just bought my My Cloud device, it works fine on my home network, however when I go to use it from outside my home network all my devices think that the drive is offline. I have made sure that remote access is turned on, what else could be wrong??? I mostly bought this to have access when Im away so this is pretty frustrating!

Hi @Sam_Baker

if you log into the web intereface of your My Cloud (http://wdmycloud or http://ip-address), go to Settings at the right of the menue bar and scroll down to “Cloud Access”. What is the connection status? Does it state “Connected (Relay connection)” or something else?

If I’m on my home network then it connects fine. Says connected. I can access everything. If I’m at another location connected to another WiFi network or over my 4g network then it does not connect at all

That’s not the Mycloud’s Dashboard UI that Joerg suggested. Follow his suggestion.

Also, download and read the user manual to help you understand how to use the device.

Hi @Sam_Baker

if you are in your home network, use the web browser of a PC and open then management interface of the My Cloud by using the URL http://wdmycloud - or http://wdmycloud.local for a Mac.

This will kick you into the device web interface. Here you see the menue bar, at the rightmost end is “Settings”. Scroll a bit down to the Cloud Access and check the status.

How many devices have you given Cloud Access to? See example image below. Click on, tap or activate image to enlarge it.

Hi there thanks for the help, here is the attached screenshot of the pge you mentioned, it des say connected, however when trying to access from utside the network it its claiming to be offline. very odd.

Hi @Sam_Baker

it states conencted BUT it also states that you use Port Forwarding instead of Relay.

What ports have you opened during the manual Cloud Access setup? 80 and 443? or Others?
If you click on the “configure” right to the Remote Access, you see the ports. Or switch back to Relay connection if your router has an issue with port forwarding.

oh, yes that is weird. I have it set to auto.

ive not set up any port forwarding at all. ill check out the router settings and see if I can see anything there.

Hi @Sam_Baker

let it work with Auto, should be fine then. Auto means, the My Cloud actively opens the needed prots from inside to outside and takes care about this from inside; so you don’t need to configure any port forwarding in your router as you don’t need this then. The My Cloud is active behind your router and in so called “Relay Conenction” available for outside access to your device.

Take a look at the Cloud Access within Settings, it states Conencted with Relay-Conenction if everything went fine.

But they already have a valid connection, by port forwarding. It’s working, so don’t change it.

This problem may be related to the vague report by your colleague:

It would be good to have a better description of the problem, and have the thread highlighted and pegged, if there is currently a large-scale access problem. I note that there are now a few threads about ‘device offline’.

If you have a server problem that you’re working to resolve, identify it properly and announce it clearly.

Hi there

Yes it says connected. But again. When trying to connect from outside the network as I am now (FIFO worker) it says drive is off line.

Get Outlook for Android

It might be your home broadband provider is blocking the default port 80 and possibly port 443. You might want to try setting Remote Access to Manual and using alternate ports (like 8080 and 4443) then enable port forwarding within your home router to route the manual ports to your My Cloud. Then test remote access.

Also ensure your mobile WD apps are up to date.

Hey Sam,

I’m having the exact same issue. Did you get it resolved ? If so, May you please help me getting it resolved.