No Internet Access?

Need Help?!? How should I configure my Netgear Nighthawk R8000 router with my 4TB MyCloud?

After installing the device to my network and installing all the software, I would still get the No Access to Internet under the dashboard under settings/network. I’m having issues with connecting with the device to back up using TimeMachine. Can some one walk me through what I need to do to configure my router?

I have read several threads and also called the WD tech support and I am using a new device since I returned my original one thinking it might be a defective unit (as suggested by 2nd level tech support). But after receiving a new unit from WD, I’m still getting the same issue.

I think it has to be something to do with my configuration with my router. What do I need to do to open the Port 80 on my router? I think this could be one of the issues?

Can someone please help me with a step by step guide on setting up my router?

Hi there,

I don not have the same router as you so i wouldnot know how it is done on it, but normally you can see an option for port forwarding on the dashboard of the router in order to set it up. Here is a link that might help you with this procedure, however it does not show how to set it up in a router:

Hope this helps.

Some routers allow you to create port forwarding rule sets to support ‘games or applications’.

On the Technicolor 582n, for instance, it appears as “Assign a game or application to a local networking device”.

If you haven’t already done so, it’s probably worth reading the user manual for your modem/router.

Looks like Port forwarding is dealt with in Chapter 14. Looks pretty standard.

ArMak,

Thanks for the info. I did all that was mentioned in the link but still no luck. This is what I keep on seeing. It keeps telling me that the Network Status is “No Internet Access” Even the Cloud Access has it listed as Connection Status “No Internet Access” I really want this thing to work but it is getting very frustrating. Please some one help me!

cpt_paranoia,

I also looked at the manual along with multiple threads and web searches in regards to this issue but still nothing new. Attached below is what I have set up in my routers setting under port forwarding. Hopefully you or someone else on here can tell me if there is something I am missing. The screen shots that I showed ArMak has the settings that I have on the WD MyCloud Dashboard.

Here are the settings that I have under the MyCloud Dashboard as well to match what I have in my router.

Please!!! Can someone tell me what I am doing wrong?!?!?!

juantorio, when your My Cloud indicates, under Network Profile Status, “No Internet access” that almost always means a problem with either your Static IP configuration or your router is blocking the IP address the My Cloud is using from accessing the Internet. Generally the No Internet access means the My Cloud cannot reach the Internet.

Since you have a Static IP set, what happens if you change it back to DHCP? Does it then indicate Internet Access? If so then the first step on the Static IP Address screen is to ensure the Static IP Address (10.0.0.25) is not in use by any other device on the network. Next check the Gateway IP address. That is typically set to the IP address of the broadband router/gateway. Often the first DNS server is also set to the same IP address as Gateway.

If all that information is correct then check the router to see if you have any sort of IP blocking or restriction settings. Many routers have the option to block certain IP addresses from gaining access to the internet, often used by parents to block kids computers or restrict the time a device can access the Internet. Some people use MAC Address filtering as a method of restricting.granting access as well.

1 Like

Bennor,

Thanks for the info. I did just now switch it back to DHCP but it still has no internet access. That is how it was originally set at but I was told it was better to set up a static IP for it. Below is what it has for my iMac that is on the same network as the MyCloud. This is pretty much what I used to setup the static IP for the MyCloud with the exception of the MyCloud’s own IP address of 10.0.0.25. I even went on my router’s setting and made a reserved IP address for the my cloud which was the 10.0.0.25 and I also checked to see if there was anything else on my network that was using that IP which there isn’t. I went and assigned pretty much everything that is on my network their own IP address. I also went onto my router and made sure that nothing was being blocked under the security settings. That screen shot is below as well. I just don’t know what I am missing.

try to reset factory default for your router. Or ssh in to your WDMycloud and do a ping “ping 8.8.8.8” if that goes out then your have DNS problem.

jebusx,

How do you SSH into the WDMycloud and how do you ping 8.8.8.8? Never tried doing that yet?

You should be able to check for connectivity by clicking on the Firmware Check for Update button on the Settings > Firmware page. If connected it should return a message indicating firmware status.

For SSH see the following links.

How to enable SSH (Secure Shell) on a My Cloud: http://support.wdc.com/KnowledgeBase/answer.aspx?ID=10435

Use a program like Putty to SSH into the WD My Cloud and issue a Ping command. Putty can be downloaded from this link: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

Once connected via SSH, issue the ping command: ping www.google.com

Go to network setting page. Enable SSH and type in a password. On windows download putty.exe or on Mac open terminal.

Mac Terminal
type “ssh sshd@yournas.local” or “ssh sshd@10.0.0.5

Once you are in ssh
type “ping 8.8.8.8” your should get some reply back. If you get reply back then you should try “ping google.com” if you get replay back from ping google.com then you should be good.

I just did the Firmware Check and this is what I got.

I’m going to try the ping with the SSH. I will let you know what I come up with. Thanks again

On the Netgear router check Access Control under Security to ensure the My Cloud isn’t being blocked.

How to configure Access Control on R8000 Nighthawk X6 Smart Wi-Fi Router?
http://kb.netgear.com/app/answers/detail/a_id/25162/~/how-to-configure-access-control-on-r8000-nighthawk-x6-smart-wi-fi-router%3F

Bennor,

I just checked that and it is all on and I also checked to see if it is being blocked and it is not.  It is showing that the IP address for the MyCloud is allowed access.  I tried the SSH thing but I'm not sure if I'm doing it right.  This is what I have right now in my terminal screen.

You need to enter a password. welc0me is the default password. Also why do you have your first dns server pointing to your router? I would remove that entry and move the other two up.

RAC

rac8006,

I just tried that password but nothing either. I also moved my other 2 up. Any other suggestions on what the password should be? I don’t think I placed any password on the MyCloud that I know of.

[quote=“rac8006, post:15, topic:136716, full:true”]
Also why do you have your first dns server pointing to your router? I would remove that entry and move the other two up.[/quote]
Often broadband providers configure the customer’s broadband router so that the router’s DHCP server uses the gateway/router as the primary DNS resolver and not public DNS entries. In some instances its because of services provided by the broadband provider require it. In this case changing the DNS entries probably won’t solve the problem the OP has.

Did you use welc0me. Where the 0 is a zero?

RAC

One other thing to try if you haven’t already, enable UPnP on the router. With UPnP active you probably won’t have to do port configuring on the router for the WD My Cloud to pass client remote traffic.

How do I enable Universal Plug and Play on my Nighthawk router?
http://kb.netgear.com/app/answers/detail/a_id/24306/~/how-do-i-enable-universal-plug-and-play-on-my-nighthawk-router%3F

Bennor,

UPnP is already enabled and still nothing.

@rac8006,

I did use the a “0” (zero) in the “o” place and still nothing too.