MyCloud shows No Internet Access

I have a 6GB My Cloud, FW 04.04.04-101. It can be seen plain as day on my 802.11n based home network by both my Wintels and my MacPro. The problem is it contiually says there is no internet access. Just for giggles, I tried to log in using and had no problem seeing it.

So, why for does it say there is no internet access? I did a factory reset last September.

Have you tried restarting your router?

I’m on Frontier Telecomm DSL with a Netgear 7550 router, which Netgear no longer support but Frontier & AT&T still provide. I’m restarting the POS several times a week because it loses its connection regularly.

Couple of things. First is to assign/reserve the My Cloud an IP address through the router’s administration screen. Second, configure the My Cloud Remote connection to Manual then configure port forwarding to the My cloud within the router’s administration screen.

There’s a good chance these two things are connected. I’d see about replacing the router - the steps @Bennor provided are very helpful and might be a good bandaid, but if the router is failing or otherwise has issues than it’s only a matter of time before other symptoms manifest.

I’ve been away for a while. Funktier FINALLY admitted their Netgear 7550 modem/router was junk and replaced it with a Netgear D2200D. I’ll see if the NAS boxes have connectivity, asuming I can get the network to see them.

A very long time coming update. Both my MyBookLiveDuo and My Cloud show no internet connection even with the “new” router. Something is rotten in the state of Denmark as the problem exists under Win7 and Win10.