No Internet Access My Cloud EX2 Ultra

Just got an 8TB My Cloud EX2 Ultra two days ago.
I have the backups figured out and working using Acronis.

What I can’t get to work from the WD Dashboard is looking for firmware updates or Apps.

Keep getting No Internet Access

I know this has been talked about on the boards and I’ve tried everything I though was applicable and I still get the error.

Cloud Access is off.
Have static IP setup in the drive and router.
Router is Verizon FIOS.
Can ping the drive from the PC.
Running current version of Windows 10 on the PC.
Tried using the Google default DNS but that also didn’t work.
IP 192.168.1.XXX
Subnet Mask
Gateway DNS
DNS Server 1
DNS Server 2
The DNS Server 2 address is what I used on a 2TB MyBookLive and listed for my area as FIOS DNS server.
Do I need port forwarding in the router for the IP Address ?


Thanks for the suggestion.
I don’t see anywhere in the router firewall where WAN NAT Redirection would be located to be filtered or blocked.
I tried setting the firewall to minimum from medium where it was set as the default which should allow all inbound and outbound traffic.
Router is Verizon FIOS Quantum G1100.
Sill getting No Internet Access from the My Cloud EX2 Ultra dashboard.

Anything else you can suggest ?

I was able to get the internet access working by going back to DHCP for the IP instead of static.
I have static IPs set up on my router for other things and never had a problem before.
Only thing I can think of is that the DHCP assigned was .194 and the static I chose was .below .127 where I have my other static IPs.
I’m just glad it’s working and I’m going to leave it as DHCP.