No interface for MyCloud

My WDMyCloud has recently been unable to be SSHed into, and http:wdmycloud brings up a blank page. The device is still seen as online, and still able to transfer files from the public shares. Any help is appreciated.

Can you access your unit’s Dashboard by using any of the shortcuts within WD SmartWare, Windows Explorer, or WD Discovery? Can the Dashboard be accessed from a different computer? Does the Dashboard reset switch allow for the unit to grant you access? If not, your unit may have to be replaced under warranty.

Thank you for your response, I tried accessing the UI from smartware and discovery. Both report the drive is online and working, Trying to the configure drive brings me to the same blank page, which I attached. Windows Explorer also recognizes it as a network device, but will not access it. I can still copy files on the public share with no problem, I just cant configure it at all.

Have you tried a 4-second or 40-second reset?

Yes, tried both and the reset button, same UI page. SSH is refused also. Tried on Smartware and discovery.

I would appreciate any other help, the mycloud was great when it was working.

What web browser are you using? Have you tried an alternate web browser? Have you tried turning off all browser extensions? Have you tried disabling the computer’s Firewall or security software? Have you tried using the My Cloud IP address rather than wdmycloud?

How did you do the 40 second reset?

Have tried on Chromium and Firefox, both with extensions enabled, and disabled. Same blank page with just a WD logo.

Unplugged the Mycloud for 40 seconds. I also hit the reset button on a different 40 second reset.

You may be miisunderstanding the 40-second reset. You have to unplug power, press and hold reset, plug in power (holding reset), and release reset after 40 seconds.

Thanks for clarifying! It worked. Thanks for all who helped me.