Unable to Access Dashboard MYCLOUD

I cannot access “Dashboard” for my WDMYCLOUD
Click WD Quick View – “Dashboard” browser (Microsoft Edge) opens for address 192.168.1.65
Screen remains blank. After a while, error message “192.168.1.65 is not responding”.
File access to the drive is fine. Can copy or paste files across.
What next please?

@grecian17 If you have a WD My Cloud and not a My Cloud Home then you may want to post this in the My Cloud sub-forum.

https://community.wd.com/c/personal-cloud-storage/wd-my-cloud

Using Quick View have you tried a reboot of your device? Right click on Quick View then choose Shutdown. See example image below. Unplug, wait one minute, then plug your device back in. Do you have a static or reserved address for your My Cloud?
image

have you tried a different browser? i would suggest chrome.

Thank for suggestions. Reboot and try different browser. Did both. Was using Microsoft Edge, which had been working fine. Tried Microsoft Internet Explorer. Access OK. Don’t know why Edge had stopped giving access. Maybe an update?

So. . . are you sure the IP address (192.168.1.65) is correct?

You can check on the router itself to see what address is assigned.

If this device is like other WD devices, you access the device directly by typing the IP in a browser address bar. Also, in windows explorer, the device should show up as a “storage” device. Clinking on that should default to opening the dashboard in your default browser.

I have exactly the same problem… How do you reset it completely without a dashboard so to factory settings i have transferred all my file off it

When I tried Microsoft Explorer I could get in to the dashboard no problem. The difficulty seems to be something to do with Microsoft Edge.

What browser are you using?

What does arp -a show? It should display the devices that the system knows about. Look for the mac address of your My Cloud.

Having the same issue for 2 weeks now. It is not just the browser, Cloud service is also not available.
I have just received a Synology DiskStation today and am in the process of moving my files off the My Cloud Mirror (Gen 2). WD is such a pathetic company. Good hard drives but everything else is just an utter nightmare.

Not saying this is the fix… But this is one step you can try that was causing a lot of issues for me. I had the same problem… also went through every option trying to figure out why my Network icons were not what they should be for the My Cloud Device also… Sure enough, it was just so simple… I went to the Device Manager in the Control Panel, Found the My Cloud Device, right clicked and selected Update Driver, Restarted my PC… and Whala. PERFECT NOW!!!

Good Luck. I know it’s frustrating!