Can't access UI

I’m having some issues with my 4TB single drive MyCloud.

When I attempted to access the UI last night, I got a splash screen followed by a page that is all white, except for a WD MyCloud logo in the upper left corner. The browser finishes loading the page (http://wdmycloud/UI), but there’s no more content. Refreshing the browser changes nothing, as does clearing the browser cache. Also tried with the local IP…

I’ve tried with IE 11, Edge, and Chrome… all to the same effect.

I tried a 40s reset (Hard power down, press reset, plug in and hold 40s) with no luck. It comes up to the splash screen, opens a window with info about MyCloud user accounts, but I can’t press Next or Cancel. Refresh takes me back to the white page with the MyCloud logo. Only now, I’ve lost SSH, too… :(.

Any advice besides cracking this thing opening and re-imaging?

If you look at your network and under Storage see WDMYCLOUD try a right click on it and then click on, View device webpage. See image below. Hope this helps.

it takes me to the twonky default page on port 9000.

I had no issues with this previously… seems to have just become a problem recently.

I can browse to the share, but can’t do anything other than that…

OK. Well this is just irritating.

I’ve now tried IE, Edge, Chrome, and Firefox.

In IE 11, I went to view --> source, and there is source being returned. I saved it as an html file, and it opened, but is nonfunctional.

Sorry, WD - but the fact that you disable SSH by default is ■■■■. I’m locked out of my NAS, and didn’t even make any changes…

You’d better speak to WD, then… I suspect they’ll say that it’s a security feature.

There are a number of reports of ‘white, except for WD logo’ at the moment; it sounds like the recent firmware upgrade has caused a problem, unless these reports are merely coincidences.

“Feature”…

I’ll hold my tongue on a security feature that prioritizes HTTP over port 80 and an insecure API over Secure Shell :slight_smile:

Has there been any word from WD on this issue?

Honestly… I’m about 1 more issue from buying another 4TB drive and a Synology barebones… I’ve already had 3 firmware bricks since I purchased. 1 WD replacement, 1 that I reimaged myself (hooray voided warranty!) and now this… I had turned off automatic updates at one point, but re-enabled it after I updated last time… wishing I hadn’t.