Web UI connects but won't load


Suddenly, I am able to conenct to my WD MyCloud via the Desktop app, but when attempting to connect to the Web UI it won’t load.  Details:

  1. Connect to IP of drive via Chrome/Safari/Android Chrome/IE (tested with 4 browsers on two devices)
  2. It redirects to HTTP://“IP”/UI
  3. Page animates to say “Accessing WD MyCloud” and then “Attempting to Authenticate”
  4. The page then goes gray (other than the black bar on top with WD MyCloud logo).  
  5. Nothing else - leave it for hours, it never loads.

Any thoughts?  Any support is greatly appreciated.

Thank you,


Additional notes:

  1. Tried power cycling (left off for an hour), no luck.
  2. Tried holding reset button for 4 seconds (heard it reboot), no luck.
  3. Light on front is steady Blue.
  4. Shares are accessible from Desktop app.
  5. I would try using the desktop app to apply a new firmware, but it tells me an admin must login to apply firmware…but I don’t see a way to change the login ID used within the Desktop app.
  6. Not accessible from SSH/FTP/SMB.

Hello there, welcome to the community.

I’m sorry to read that you are unable to access the UI of your drive. After what you have tried, I would recommend you to  contact support and see if they have anything else to add.


Do you could solve your problem ?.

I’m on the same situation. It connects and so, but no UI, just the logo no top.