"No available Apps"


I have just purchased a 2TB My Cloud Mirror brand new, plugged it in and set it up via the setup software, entered the dashboard for the first time and was told a new firmware update was available so installed it and then wanted to install the squeezecenter/logitech media server app (which was one of the main reasons I bought it). When I go to the apps tab and click to install a new app I get the message “No available Apps”.

I have tried resetting the device to factory setting but this doesn’t make any difference.

I find it totally unacceptable that WD plaster it all over the web and the packaging that you can install apps and then none are available.

I understand they can wash their hands of the functionality of the third party apps but I would argue it’s their responsibility to make sure the apps are available at least.

Does anyone have a fix for this before I take it back and sue them for breach of trade descriptions? :stuck_out_tongue:


Firmware version is 1.05.30

The MCM does have a range of apps available, including SqueezeCenter. So it’s something specific either on your device or how it’s set up. 

As you’ve done the factory reset, it may be worth double-checking that the device has a functional internet connection via the router. It’s a bit of a long-shot as I guess you downloaded the firmware update that way, but it’s about the only thing I can think of that would maybe stop such a download/installation.

One other question - does your MCM have the pre-existing apps installed (HTTP, FTP and P2P downloads, plus the web file viewer) and available for use?

Also after the firmware update, did you reboot the device fully?

Hi Darren

Yes to all.

Still no joy…

Then I think it’s one to raise with WD tech support directly, as it sounds to me like you may have a defective unit.

You’ve done all the obvious user-side tests that I can think of, so all I can do is reassure you that it’s not a generic defect with the MCM and that firmware, as mine doesn’t have the issue.

Good luck!

Does anyone know where to get previous firmware versions so that I can see if the newest version is causing my problem?


Bought another 4TB mirror today, plugged it in, ran set up, it had the latest firmware straight out of the box and bam… same problem. So its not hardware related. Can anybody suggest any settings that might cause this problem or offer any other solutions?

Getting desperate now…


Given that, possibly the only thing I can think of that it could be is if you have a firewall or something similar in your router/switch (or whatever you have between the MCMs and the internet) which is blocking the MCM’s access to the WD server so that it can’t see the available list of 3rd party apps. Either that or it’s something further upstream in your ISP doing something similar.

I guess you could test that by taking it to a friends house and see if you can see the apps if it’s on a different router and/or ISP set-up.

It is possible to download some of the apps (including Squeezecentre) as source code from the MCM download pageand there is a manual install tag in the dashboard apps list, but offhand I’m not sure if you can use one to install the other or not (I’ve personally never tried it). It won’t directly resolve your problem, but it may give you a work-around to get the end result you were originally looking for.

By the way, did you contect WD tech support about the issue? What was their response?

Ok so randomly i can now install apps.

Im not sure but i think this was all to do with the performance speed of the device. i.e. if i go to the apps tab and click to install an app immediately then when the window appears it has the message no available apps. If you close that window and leave it for a couple of minutes before clicking again then it opens with the list of available apps. So i guess it was just taking its time to retrieve the app information.

Not sure what i think of that…

That sounds more like the speed of the MCM talking to the WD servers that host the apps for download, rather than the speed of the device itself (especially as you’ve now had two of them do it, which would discount a bad individual device).

It could be interesting to enable the remote (cloud) access and then use a phone, tablet or computer off your network to access the MCM and see what kind of speeds you get in communicating remotely with the MCM via the relevant WD application on the remote device. That may give some indication of whether your MCM is having issues in talking to/from the wider internet for some reason (relating probably to either your router or your ISP). You may also be able to get some judgement of that by the speed that any app you download from WD actually arrives at your MCM.

On my MCM I get the list instantly and apps download in about 10-20s (I downloaded and installed phpMyAdmin last night and it took about that long) if you need a benchmark. That’s on a home broadband of ~8Mbps download speed via a Netgear D6200 router with the MCM plugged directly into it (gigabit ethernet connection).

solved for a moment !!?

Just in case anyone else has a similar “No available apps” issue, I re-booted the MCM and they re-appeared.